%global _empty_manifest_terminate_build 0 Name: python-djlint Version: 1.25.0 Release: 1 Summary: HTML Template Linter and Formatter License: GPL-3.0-or-later URL: https://github.com/Riverside-Healthcare/djlint Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dc/4d/c96d5b78309da57af7d4099405ba555e30ac9e267f776489c9b6b6a83318/djlint-1.25.0.tar.gz BuildArch: noarch Requires: python3-click Requires: python3-PyYAML Requires: python3-colorama Requires: python3-regex Requires: python3-tqdm Requires: python3-tomli Requires: python3-pathspec Requires: python3-html-void-elements Requires: python3-html-tag-names Requires: python3-jsbeautifier Requires: python3-cssbeautifier %description


djLint Logo

🏗️ Maintainers needed, please reach out on discord or email!

The missing formatter and linter for HTML templates.

tweet Discord Chat

Codecov Status Codacy Status Downloads npm Pypi Download

How to useКак пользоватьсяUtilisation

What lang are you using?

DjangoJinjaNunjucksTwigHandlebarsMustacheGoLangAngular

demo

## 🤔 For What? Once upon a time all the other programming languages had a formatter and linter. Css, javascript, python, the c suite, typescript, ruby, php, go, swift, and you know the others. The cool kids on the block. HTML templates were left out there on their own, in the cold, unformatted and unlinted :( The dirty corner in your repository. Something had to change. **djLint is a community build project to and add consistency to html templates.** ## ✨ How? Grab it with `pip` ```bash pip install djlint ``` *Or with the npm experimental install - Note, this requires python and pip to be on your system path.* ```bash npm i djlint ``` Lint your project ```bash djlint . --extension=html.j2 --lint ``` Check your format ```bash djlint . --extension=html.j2 --check ``` Fix my format! ```bash djlint . --extension=html.j2 --reformat ``` ## 💙 Like it? Add a badge to your projects ```readme.md```: ```md [![Code style: djlint](https://img.shields.io/badge/html%20style-djlint-blue.svg)](https://www.djlint.com) ``` Add a badge to your ```readme.rst```: ```rst .. image:: https://img.shields.io/badge/html%20style-djlint-blue.svg :target: https://www.djlint.com ``` Looks like this: [![djLint](https://img.shields.io/badge/html%20style-djLint-blue.svg)](https://github.com/Riverside-Healthcare/djlint) ## 🛠️ Can I help? Yes! *Would you like to add a rule to the linter?* Take a look at the [linter docs](https://djlint.com/docs/linter/) and [source code](https://github.com/Riverside-Healthcare/djLint/blob/master/src/djlint/rules.yaml) *Are you a regex pro?* Benchmark and submit a pr with improved regex for the [linter rules](https://github.com/Riverside-Healthcare/djLint/blob/master/src/djlint/rules.yaml) **⚠️ Help Needed! ⚠️** *Good with python?* djLint was an experimental project and is catching on with other devs. Help out with a rewrite of the formatter to improve speed and html style for edge cases. Contribute on the [2.0 branch](https://github.com/Riverside-Healthcare/djLint/tree/block_indent) ## 🏃 Other Tools Of Note * [DjHTML](https://github.com/rtts/djhtml) A pure-Python Django/Jinja template indenter without dependencies. * [HTMLHint](https://htmlhint.com) Static code analysis tool you need for your HTML * [curlylint](https://www.curlylint.org) Experimental HTML templates linting for Jinja, Nunjucks, Django templates, Twig, Liquid %package -n python3-djlint Summary: HTML Template Linter and Formatter Provides: python-djlint BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-djlint


djLint Logo

🏗️ Maintainers needed, please reach out on discord or email!

The missing formatter and linter for HTML templates.

tweet Discord Chat

Codecov Status Codacy Status Downloads npm Pypi Download

How to useКак пользоватьсяUtilisation

What lang are you using?

DjangoJinjaNunjucksTwigHandlebarsMustacheGoLangAngular

demo

## 🤔 For What? Once upon a time all the other programming languages had a formatter and linter. Css, javascript, python, the c suite, typescript, ruby, php, go, swift, and you know the others. The cool kids on the block. HTML templates were left out there on their own, in the cold, unformatted and unlinted :( The dirty corner in your repository. Something had to change. **djLint is a community build project to and add consistency to html templates.** ## ✨ How? Grab it with `pip` ```bash pip install djlint ``` *Or with the npm experimental install - Note, this requires python and pip to be on your system path.* ```bash npm i djlint ``` Lint your project ```bash djlint . --extension=html.j2 --lint ``` Check your format ```bash djlint . --extension=html.j2 --check ``` Fix my format! ```bash djlint . --extension=html.j2 --reformat ``` ## 💙 Like it? Add a badge to your projects ```readme.md```: ```md [![Code style: djlint](https://img.shields.io/badge/html%20style-djlint-blue.svg)](https://www.djlint.com) ``` Add a badge to your ```readme.rst```: ```rst .. image:: https://img.shields.io/badge/html%20style-djlint-blue.svg :target: https://www.djlint.com ``` Looks like this: [![djLint](https://img.shields.io/badge/html%20style-djLint-blue.svg)](https://github.com/Riverside-Healthcare/djlint) ## 🛠️ Can I help? Yes! *Would you like to add a rule to the linter?* Take a look at the [linter docs](https://djlint.com/docs/linter/) and [source code](https://github.com/Riverside-Healthcare/djLint/blob/master/src/djlint/rules.yaml) *Are you a regex pro?* Benchmark and submit a pr with improved regex for the [linter rules](https://github.com/Riverside-Healthcare/djLint/blob/master/src/djlint/rules.yaml) **⚠️ Help Needed! ⚠️** *Good with python?* djLint was an experimental project and is catching on with other devs. Help out with a rewrite of the formatter to improve speed and html style for edge cases. Contribute on the [2.0 branch](https://github.com/Riverside-Healthcare/djLint/tree/block_indent) ## 🏃 Other Tools Of Note * [DjHTML](https://github.com/rtts/djhtml) A pure-Python Django/Jinja template indenter without dependencies. * [HTMLHint](https://htmlhint.com) Static code analysis tool you need for your HTML * [curlylint](https://www.curlylint.org) Experimental HTML templates linting for Jinja, Nunjucks, Django templates, Twig, Liquid %package help Summary: Development documents and examples for djlint Provides: python3-djlint-doc %description help


djLint Logo

🏗️ Maintainers needed, please reach out on discord or email!

The missing formatter and linter for HTML templates.

tweet Discord Chat

Codecov Status Codacy Status Downloads npm Pypi Download

How to useКак пользоватьсяUtilisation

What lang are you using?

DjangoJinjaNunjucksTwigHandlebarsMustacheGoLangAngular

demo

## 🤔 For What? Once upon a time all the other programming languages had a formatter and linter. Css, javascript, python, the c suite, typescript, ruby, php, go, swift, and you know the others. The cool kids on the block. HTML templates were left out there on their own, in the cold, unformatted and unlinted :( The dirty corner in your repository. Something had to change. **djLint is a community build project to and add consistency to html templates.** ## ✨ How? Grab it with `pip` ```bash pip install djlint ``` *Or with the npm experimental install - Note, this requires python and pip to be on your system path.* ```bash npm i djlint ``` Lint your project ```bash djlint . --extension=html.j2 --lint ``` Check your format ```bash djlint . --extension=html.j2 --check ``` Fix my format! ```bash djlint . --extension=html.j2 --reformat ``` ## 💙 Like it? Add a badge to your projects ```readme.md```: ```md [![Code style: djlint](https://img.shields.io/badge/html%20style-djlint-blue.svg)](https://www.djlint.com) ``` Add a badge to your ```readme.rst```: ```rst .. image:: https://img.shields.io/badge/html%20style-djlint-blue.svg :target: https://www.djlint.com ``` Looks like this: [![djLint](https://img.shields.io/badge/html%20style-djLint-blue.svg)](https://github.com/Riverside-Healthcare/djlint) ## 🛠️ Can I help? Yes! *Would you like to add a rule to the linter?* Take a look at the [linter docs](https://djlint.com/docs/linter/) and [source code](https://github.com/Riverside-Healthcare/djLint/blob/master/src/djlint/rules.yaml) *Are you a regex pro?* Benchmark and submit a pr with improved regex for the [linter rules](https://github.com/Riverside-Healthcare/djLint/blob/master/src/djlint/rules.yaml) **⚠️ Help Needed! ⚠️** *Good with python?* djLint was an experimental project and is catching on with other devs. Help out with a rewrite of the formatter to improve speed and html style for edge cases. Contribute on the [2.0 branch](https://github.com/Riverside-Healthcare/djLint/tree/block_indent) ## 🏃 Other Tools Of Note * [DjHTML](https://github.com/rtts/djhtml) A pure-Python Django/Jinja template indenter without dependencies. * [HTMLHint](https://htmlhint.com) Static code analysis tool you need for your HTML * [curlylint](https://www.curlylint.org) Experimental HTML templates linting for Jinja, Nunjucks, Django templates, Twig, Liquid %prep %autosetup -n djlint-1.25.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-djlint -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri May 05 2023 Python_Bot - 1.25.0-1 - Package Spec generated