%global _empty_manifest_terminate_build 0
Name: python-matminer
Version: 0.8.0
Release: 1
Summary: matminer is a library that contains tools for data mining in Materials Science
License: modified BSD
URL: https://github.com/hackingmaterials/matminer
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/16/c0/3cc16d6eb828c8f3f95255c194bef48260a2627a7e63f4c665a9be4f6af9/matminer-0.8.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-requests
Requires: python3-pandas
Requires: python3-tqdm
Requires: python3-pymongo
Requires: python3-future
Requires: python3-scikit-learn
Requires: python3-sympy
Requires: python3-monty
Requires: python3-pymatgen
Requires: python3-aflow
Requires: python3-citrination-client
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-coverage
Requires: python3-coveralls
Requires: python3-flake8
Requires: python3-black
Requires: python3-pylint
Requires: python3-sphinx
Requires: python3-dscribe
Requires: python3-mdf-forge
Requires: python3-ujson
Requires: python3-jmespath
Requires: python3-httplib2
Requires: python3-ase
Requires: python3-jsonschema
%description
#
matminer is a library for performing data mining in the field of materials science.
- **[Website (including documentation)](https://hackingmaterials.github.io/matminer/)**
- **[Examples Repository](https://github.com/hackingmaterials/matminer_examples)**
- **[Help/Support Forum](https://matsci.org/c/matminer/16)**
- **[Source Repository](https://github.com/hackingmaterials/matminer)**
matminer supports Python 3.8+.
#### Related packages:
- If you like matminer, you might also try [automatminer](https://github.com/hackingmaterials/automatminer).
- If you are interested in furthering development of datasets in matminer, you may be interested in [matbench](https://github.com/hackingmaterials/matbench).
- If you are looking for figrecipes, it is now in its [own repo](https://github.com/hackingmaterials/figrecipes).
#### Citation
If you find matminer useful, please encourage its development by citing the following paper in your research:
```
Ward, L., Dunn, A., Faghaninia, A., Zimmermann, N. E. R., Bajaj, S., Wang, Q.,
Montoya, J. H., Chen, J., Bystrom, K., Dylla, M., Chard, K., Asta, M., Persson,
K., Snyder, G. J., Foster, I., Jain, A., Matminer: An open source toolkit for
materials data mining. Comput. Mater. Sci. 152, 60-69 (2018).
```
Matminer helps users apply methods and data sets developed by the community. Please also cite the original sources, as this will add clarity to your article and credit the original authors:
- If you use one or more **datasets** accessed through matminer, check the dataset metadata info for relevant citations on the original datasets.
- If you use one or more **data retrieval methods**, check ``citations()`` method of the data retrieval class. This method will provide a list of BibTeX-formatted citations for that featurizer, making it easy to keep track of and cite the original publications.
- If you use one or more **featurizers**, please take advantage of the ```citations()``` function present for every featurizer in matminer.
%package -n python3-matminer
Summary: matminer is a library that contains tools for data mining in Materials Science
Provides: python-matminer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-matminer
#
matminer is a library for performing data mining in the field of materials science.
- **[Website (including documentation)](https://hackingmaterials.github.io/matminer/)**
- **[Examples Repository](https://github.com/hackingmaterials/matminer_examples)**
- **[Help/Support Forum](https://matsci.org/c/matminer/16)**
- **[Source Repository](https://github.com/hackingmaterials/matminer)**
matminer supports Python 3.8+.
#### Related packages:
- If you like matminer, you might also try [automatminer](https://github.com/hackingmaterials/automatminer).
- If you are interested in furthering development of datasets in matminer, you may be interested in [matbench](https://github.com/hackingmaterials/matbench).
- If you are looking for figrecipes, it is now in its [own repo](https://github.com/hackingmaterials/figrecipes).
#### Citation
If you find matminer useful, please encourage its development by citing the following paper in your research:
```
Ward, L., Dunn, A., Faghaninia, A., Zimmermann, N. E. R., Bajaj, S., Wang, Q.,
Montoya, J. H., Chen, J., Bystrom, K., Dylla, M., Chard, K., Asta, M., Persson,
K., Snyder, G. J., Foster, I., Jain, A., Matminer: An open source toolkit for
materials data mining. Comput. Mater. Sci. 152, 60-69 (2018).
```
Matminer helps users apply methods and data sets developed by the community. Please also cite the original sources, as this will add clarity to your article and credit the original authors:
- If you use one or more **datasets** accessed through matminer, check the dataset metadata info for relevant citations on the original datasets.
- If you use one or more **data retrieval methods**, check ``citations()`` method of the data retrieval class. This method will provide a list of BibTeX-formatted citations for that featurizer, making it easy to keep track of and cite the original publications.
- If you use one or more **featurizers**, please take advantage of the ```citations()``` function present for every featurizer in matminer.
%package help
Summary: Development documents and examples for matminer
Provides: python3-matminer-doc
%description help
#
matminer is a library for performing data mining in the field of materials science.
- **[Website (including documentation)](https://hackingmaterials.github.io/matminer/)**
- **[Examples Repository](https://github.com/hackingmaterials/matminer_examples)**
- **[Help/Support Forum](https://matsci.org/c/matminer/16)**
- **[Source Repository](https://github.com/hackingmaterials/matminer)**
matminer supports Python 3.8+.
#### Related packages:
- If you like matminer, you might also try [automatminer](https://github.com/hackingmaterials/automatminer).
- If you are interested in furthering development of datasets in matminer, you may be interested in [matbench](https://github.com/hackingmaterials/matbench).
- If you are looking for figrecipes, it is now in its [own repo](https://github.com/hackingmaterials/figrecipes).
#### Citation
If you find matminer useful, please encourage its development by citing the following paper in your research:
```
Ward, L., Dunn, A., Faghaninia, A., Zimmermann, N. E. R., Bajaj, S., Wang, Q.,
Montoya, J. H., Chen, J., Bystrom, K., Dylla, M., Chard, K., Asta, M., Persson,
K., Snyder, G. J., Foster, I., Jain, A., Matminer: An open source toolkit for
materials data mining. Comput. Mater. Sci. 152, 60-69 (2018).
```
Matminer helps users apply methods and data sets developed by the community. Please also cite the original sources, as this will add clarity to your article and credit the original authors:
- If you use one or more **datasets** accessed through matminer, check the dataset metadata info for relevant citations on the original datasets.
- If you use one or more **data retrieval methods**, check ``citations()`` method of the data retrieval class. This method will provide a list of BibTeX-formatted citations for that featurizer, making it easy to keep track of and cite the original publications.
- If you use one or more **featurizers**, please take advantage of the ```citations()``` function present for every featurizer in matminer.
%prep
%autosetup -n matminer-0.8.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-matminer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.8.0-1
- Package Spec generated