%global _empty_manifest_terminate_build 0
Name: python-ReFrame-HPC
Version: 4.2.0
Release: 1
Summary: ReFrame is a powerful framework for writing system regression tests and benchmarks, specifically targeted to HPC systems
License: BSD 3-Clause
URL: https://github.com/reframe-hpc/reframe
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/65/198dfe2893347f80195043c81472437f80794e9016de46a59c632c58307d/ReFrame-HPC-4.2.0.tar.gz
BuildArch: noarch
Requires: python3-archspec
Requires: python3-argcomplete
Requires: python3-jsonschema
Requires: python3-lxml
Requires: python3-PyYAML
Requires: python3-requests
Requires: python3-semver
%description
[](https://github.com/reframe-hpc/reframe)
[](https://github.com/reframe-hpc/reframe/actions?query=workflow%3A%22ReFrame+CI%22)
[](https://reframe-hpc.readthedocs.io/en/latest/?badge=latest)
[](https://codecov.io/github/reframe-hpc/reframe)



[](https://badge.fury.io/py/ReFrame-HPC)

[](https://pepy.tech/project/reframe-hpc)
[](https://pepy.tech/project/reframe-hpc)
[](https://reframe-slack.herokuapp.com/)
[](https://opensource.org/licenses/BSD-3-Clause)
[](https://zenodo.org/badge/latestdoi/89384186)
[](https://twitter.com/ReFrameHPC)
# ReFrame in a Nutshell
ReFrame is a powerful framework for writing system regression tests and benchmarks, specifically targeted to HPC systems.
The goal of the framework is to abstract away the complexity of the interactions with the system, separating the logic of a test from the low-level details, which pertain to the system configuration and setup.
This allows users to write portable tests in a declarative way that describes only the test's functionality.
Tests in ReFrame are simple Python classes that specify the basic variables and parameters of the test.
ReFrame offers an intuitive and very powerful syntax that allows users to create test libraries, test factories, as well as complete test workflows using other tests as fixtures.
ReFrame will load the tests and send them down a well-defined pipeline that will execute them in parallel.
The stages of this pipeline take care of all the system interaction details, such as programming environment switching, compilation, job submission, job status query, sanity checking and performance assessment.
Please visit the project's documentation [page](https://reframe-hpc.readthedocs.io/) and [GitHub repository](https://github.com/reframe-hpc/reframe) for all the details!
## Contact
You can get in contact with the ReFrame community in the following ways:
### Slack
Please join the community's [Slack channel](https://reframe-slack.herokuapp.com) for keeping up with the latest news about ReFrame, posting questions and, generally getting in touch with other users and the developers.
## Contributing back
ReFrame is an open-source project and we welcome and encourage contributions!
Check out our Contribution Guide [here](https://github.com/reframe-hpc/reframe/wiki/contributing-to-reframe).
%package -n python3-ReFrame-HPC
Summary: ReFrame is a powerful framework for writing system regression tests and benchmarks, specifically targeted to HPC systems
Provides: python-ReFrame-HPC
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ReFrame-HPC
[](https://github.com/reframe-hpc/reframe)
[](https://github.com/reframe-hpc/reframe/actions?query=workflow%3A%22ReFrame+CI%22)
[](https://reframe-hpc.readthedocs.io/en/latest/?badge=latest)
[](https://codecov.io/github/reframe-hpc/reframe)



[](https://badge.fury.io/py/ReFrame-HPC)

[](https://pepy.tech/project/reframe-hpc)
[](https://pepy.tech/project/reframe-hpc)
[](https://reframe-slack.herokuapp.com/)
[](https://opensource.org/licenses/BSD-3-Clause)
[](https://zenodo.org/badge/latestdoi/89384186)
[](https://twitter.com/ReFrameHPC)
# ReFrame in a Nutshell
ReFrame is a powerful framework for writing system regression tests and benchmarks, specifically targeted to HPC systems.
The goal of the framework is to abstract away the complexity of the interactions with the system, separating the logic of a test from the low-level details, which pertain to the system configuration and setup.
This allows users to write portable tests in a declarative way that describes only the test's functionality.
Tests in ReFrame are simple Python classes that specify the basic variables and parameters of the test.
ReFrame offers an intuitive and very powerful syntax that allows users to create test libraries, test factories, as well as complete test workflows using other tests as fixtures.
ReFrame will load the tests and send them down a well-defined pipeline that will execute them in parallel.
The stages of this pipeline take care of all the system interaction details, such as programming environment switching, compilation, job submission, job status query, sanity checking and performance assessment.
Please visit the project's documentation [page](https://reframe-hpc.readthedocs.io/) and [GitHub repository](https://github.com/reframe-hpc/reframe) for all the details!
## Contact
You can get in contact with the ReFrame community in the following ways:
### Slack
Please join the community's [Slack channel](https://reframe-slack.herokuapp.com) for keeping up with the latest news about ReFrame, posting questions and, generally getting in touch with other users and the developers.
## Contributing back
ReFrame is an open-source project and we welcome and encourage contributions!
Check out our Contribution Guide [here](https://github.com/reframe-hpc/reframe/wiki/contributing-to-reframe).
%package help
Summary: Development documents and examples for ReFrame-HPC
Provides: python3-ReFrame-HPC-doc
%description help
[](https://github.com/reframe-hpc/reframe)
[](https://github.com/reframe-hpc/reframe/actions?query=workflow%3A%22ReFrame+CI%22)
[](https://reframe-hpc.readthedocs.io/en/latest/?badge=latest)
[](https://codecov.io/github/reframe-hpc/reframe)



[](https://badge.fury.io/py/ReFrame-HPC)

[](https://pepy.tech/project/reframe-hpc)
[](https://pepy.tech/project/reframe-hpc)
[](https://reframe-slack.herokuapp.com/)
[](https://opensource.org/licenses/BSD-3-Clause)
[](https://zenodo.org/badge/latestdoi/89384186)
[](https://twitter.com/ReFrameHPC)
# ReFrame in a Nutshell
ReFrame is a powerful framework for writing system regression tests and benchmarks, specifically targeted to HPC systems.
The goal of the framework is to abstract away the complexity of the interactions with the system, separating the logic of a test from the low-level details, which pertain to the system configuration and setup.
This allows users to write portable tests in a declarative way that describes only the test's functionality.
Tests in ReFrame are simple Python classes that specify the basic variables and parameters of the test.
ReFrame offers an intuitive and very powerful syntax that allows users to create test libraries, test factories, as well as complete test workflows using other tests as fixtures.
ReFrame will load the tests and send them down a well-defined pipeline that will execute them in parallel.
The stages of this pipeline take care of all the system interaction details, such as programming environment switching, compilation, job submission, job status query, sanity checking and performance assessment.
Please visit the project's documentation [page](https://reframe-hpc.readthedocs.io/) and [GitHub repository](https://github.com/reframe-hpc/reframe) for all the details!
## Contact
You can get in contact with the ReFrame community in the following ways:
### Slack
Please join the community's [Slack channel](https://reframe-slack.herokuapp.com) for keeping up with the latest news about ReFrame, posting questions and, generally getting in touch with other users and the developers.
## Contributing back
ReFrame is an open-source project and we welcome and encourage contributions!
Check out our Contribution Guide [here](https://github.com/reframe-hpc/reframe/wiki/contributing-to-reframe).
%prep
%autosetup -n ReFrame-HPC-4.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ReFrame-HPC -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 4.2.0-1
- Package Spec generated