%global _empty_manifest_terminate_build 0
Name: python-miniworldmaker
Version: 2.17.0.5
Release: 1
Summary: Create 2D Miniworlds and Games
License: OSI Approved :: MIT License
URL: https://github.com/asbl/miniworldmaker
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/99/6f159cf09db4d20a9eb9a2f40fc95d32890d61eaf7c19324339a971c9f25/miniworldmaker-2.17.0.5.tar.gz
BuildArch: noarch
%description
miniworldmaker allows you to create 2D mini worlds and games.
It is a 2D engine inspired by greenfoot and gamegrid based on pygame.
### Tutorial
[English](https://miniworldmaker.de/objectsfirst_english/01_installation.html) | [German](https://miniworldmaker.de/objectsfirst_german/01_installation.html)
### Examples
* [Angry Birds](https://replit.com/@a_siebel/miniworldmaker-Angry-birds): This demonstrates the physics engine. It runs somewhat slowly on repl.it, should buy smoothly on modern computers without problems.
* [Kara](https://replit.com/@a_siebel/Kara-in-miniworldmaker"): Kara Prototype
* [RPG Framework](https://replit.com/@a_siebel/RPG-Framework-for-miniworldmaker): Framework for simple RPGs and Textadventures
### Features
* miniworldmaker supports pixel-based games as well as games with
tiles (e.g. Rogue-Likes)
* Easy creation of animations
* Music and sound effects
* Integrated GUI elements like console for output, toolbar, ...
* Load and Save to SQLite Databases
* Integrated Physics-Engine based on Pymunk
* Open Source
* miniworldmaker is a 2D Engine based on Python 3, pygame and pymunk.
%package -n python3-miniworldmaker
Summary: Create 2D Miniworlds and Games
Provides: python-miniworldmaker
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-miniworldmaker
miniworldmaker allows you to create 2D mini worlds and games.
It is a 2D engine inspired by greenfoot and gamegrid based on pygame.
### Tutorial
[English](https://miniworldmaker.de/objectsfirst_english/01_installation.html) | [German](https://miniworldmaker.de/objectsfirst_german/01_installation.html)
### Examples
* [Angry Birds](https://replit.com/@a_siebel/miniworldmaker-Angry-birds): This demonstrates the physics engine. It runs somewhat slowly on repl.it, should buy smoothly on modern computers without problems.
* [Kara](https://replit.com/@a_siebel/Kara-in-miniworldmaker"): Kara Prototype
* [RPG Framework](https://replit.com/@a_siebel/RPG-Framework-for-miniworldmaker): Framework for simple RPGs and Textadventures
### Features
* miniworldmaker supports pixel-based games as well as games with
tiles (e.g. Rogue-Likes)
* Easy creation of animations
* Music and sound effects
* Integrated GUI elements like console for output, toolbar, ...
* Load and Save to SQLite Databases
* Integrated Physics-Engine based on Pymunk
* Open Source
* miniworldmaker is a 2D Engine based on Python 3, pygame and pymunk.
%package help
Summary: Development documents and examples for miniworldmaker
Provides: python3-miniworldmaker-doc
%description help
miniworldmaker allows you to create 2D mini worlds and games.
It is a 2D engine inspired by greenfoot and gamegrid based on pygame.
### Tutorial
[English](https://miniworldmaker.de/objectsfirst_english/01_installation.html) | [German](https://miniworldmaker.de/objectsfirst_german/01_installation.html)
### Examples
* [Angry Birds](https://replit.com/@a_siebel/miniworldmaker-Angry-birds): This demonstrates the physics engine. It runs somewhat slowly on repl.it, should buy smoothly on modern computers without problems.
* [Kara](https://replit.com/@a_siebel/Kara-in-miniworldmaker"): Kara Prototype
* [RPG Framework](https://replit.com/@a_siebel/RPG-Framework-for-miniworldmaker): Framework for simple RPGs and Textadventures
### Features
* miniworldmaker supports pixel-based games as well as games with
tiles (e.g. Rogue-Likes)
* Easy creation of animations
* Music and sound effects
* Integrated GUI elements like console for output, toolbar, ...
* Load and Save to SQLite Databases
* Integrated Physics-Engine based on Pymunk
* Open Source
* miniworldmaker is a 2D Engine based on Python 3, pygame and pymunk.
%prep
%autosetup -n miniworldmaker-2.17.0.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-miniworldmaker -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.17.0.5-1
- Package Spec generated