%global _empty_manifest_terminate_build 0
Name: python-erddapy
Version: 2.0.1
Release: 1
Summary: Python interface for ERDDAP
License: Copyright 2017 Filipe Fernandes Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
URL: https://pypi.org/project/erddapy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9b/61/26133b283d9187561276a9da795e7465b0f839fa87b4c560372463de71a0/erddapy-2.0.1.tar.gz
BuildArch: noarch
Requires: python3-httpx
Requires: python3-pandas
Requires: python3-pytz
%description
erddapy: ERDDAP + Python.
# Table of contents
- [Overview](#overview)
- [Example](#example)
- [Get in touch](#get-in-touch)
- [License and copyright](#license-and-copyright)
## Overview
Easier access to scientific data.
erddapy takes advantage of ERDDAP's RESTful web services and creates the ERDDAP URL for any request,
like searching for datasets, acquiring metadata, downloading the data, etc.
What is ERDDAP?
ERDDAP unifies the different types of data servers and offers a consistent way to get the data in multiple the formats.
For more information on ERDDAP servers please see [https://coastwatch.pfeg.noaa.gov/erddap/index.html](https://coastwatch.pfeg.noaa.gov/erddap/index.html).
### Documentation and code
The documentation is hosted at .
The code is hosted at .
### Installation
For `conda` users you can
```shell
conda install --channel conda-forge erddapy
```
or, if you are a `pip` users
```shell
python -m pip install erddapy
```
Note that, if you are installing the `requirements-dev.txt`, the `iris` package
is named `scitools-iris` on PyPI so `pip` users must rename that before installing.
### Example
```python
from erddapy import ERDDAP
e = ERDDAP(
server="https://gliders.ioos.us/erddap",
protocol="tabledap",
)
e.response = "csv"
e.dataset_id = "whoi_406-20160902T1700"
e.constraints = {
"time>=": "2016-07-10T00:00:00Z",
"time<=": "2017-02-10T00:00:00Z",
"latitude>=": 38.0,
"latitude<=": 41.0,
"longitude>=": -72.0,
"longitude<=": -69.0,
}
e.variables = [
"depth",
"latitude",
"longitude",
"salinity",
"temperature",
"time",
]
df = e.to_pandas()
```
## Get in touch
Report bugs, suggest features or view the source code on [GitHub](https://github.com/ioos/erddapy/issues).
## Projects using erddapy
- [argopy](https://github.com/euroargodev/argopy)
- [gliderpy](https://github.com/ioos/gliderpy)
- [gdutils](https://github.com/kerfoot/gdutils)
- [colocate](https://github.com/ioos/colocate)
- [intake-erddap](https://github.com/jmunroe/intake-erddap)
- [ioos_qc](https://github.com/ioos/ioos_qc)
## Similar projects
- [rerddap](https://cran.r-project.org/web/packages/rerddap) implements a nice client for R that performs searches on a curated set of servers instead of a query per server like erddapy.
- [erddap-python](https://github.com/hmedrano/erddap-python) 99% of the same functionality as erddapy but with a JavaScript-like API.
## License and copyright
Erddapy is licensed under BSD 3-Clause "New" or "Revised" License (BSD-3-Clause).
Development occurs on GitHub at .
%package -n python3-erddapy
Summary: Python interface for ERDDAP
Provides: python-erddapy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-erddapy
erddapy: ERDDAP + Python.
# Table of contents
- [Overview](#overview)
- [Example](#example)
- [Get in touch](#get-in-touch)
- [License and copyright](#license-and-copyright)
## Overview
Easier access to scientific data.
erddapy takes advantage of ERDDAP's RESTful web services and creates the ERDDAP URL for any request,
like searching for datasets, acquiring metadata, downloading the data, etc.
What is ERDDAP?
ERDDAP unifies the different types of data servers and offers a consistent way to get the data in multiple the formats.
For more information on ERDDAP servers please see [https://coastwatch.pfeg.noaa.gov/erddap/index.html](https://coastwatch.pfeg.noaa.gov/erddap/index.html).
### Documentation and code
The documentation is hosted at .
The code is hosted at .
### Installation
For `conda` users you can
```shell
conda install --channel conda-forge erddapy
```
or, if you are a `pip` users
```shell
python -m pip install erddapy
```
Note that, if you are installing the `requirements-dev.txt`, the `iris` package
is named `scitools-iris` on PyPI so `pip` users must rename that before installing.
### Example
```python
from erddapy import ERDDAP
e = ERDDAP(
server="https://gliders.ioos.us/erddap",
protocol="tabledap",
)
e.response = "csv"
e.dataset_id = "whoi_406-20160902T1700"
e.constraints = {
"time>=": "2016-07-10T00:00:00Z",
"time<=": "2017-02-10T00:00:00Z",
"latitude>=": 38.0,
"latitude<=": 41.0,
"longitude>=": -72.0,
"longitude<=": -69.0,
}
e.variables = [
"depth",
"latitude",
"longitude",
"salinity",
"temperature",
"time",
]
df = e.to_pandas()
```
## Get in touch
Report bugs, suggest features or view the source code on [GitHub](https://github.com/ioos/erddapy/issues).
## Projects using erddapy
- [argopy](https://github.com/euroargodev/argopy)
- [gliderpy](https://github.com/ioos/gliderpy)
- [gdutils](https://github.com/kerfoot/gdutils)
- [colocate](https://github.com/ioos/colocate)
- [intake-erddap](https://github.com/jmunroe/intake-erddap)
- [ioos_qc](https://github.com/ioos/ioos_qc)
## Similar projects
- [rerddap](https://cran.r-project.org/web/packages/rerddap) implements a nice client for R that performs searches on a curated set of servers instead of a query per server like erddapy.
- [erddap-python](https://github.com/hmedrano/erddap-python) 99% of the same functionality as erddapy but with a JavaScript-like API.
## License and copyright
Erddapy is licensed under BSD 3-Clause "New" or "Revised" License (BSD-3-Clause).
Development occurs on GitHub at .
%package help
Summary: Development documents and examples for erddapy
Provides: python3-erddapy-doc
%description help
erddapy: ERDDAP + Python.
# Table of contents
- [Overview](#overview)
- [Example](#example)
- [Get in touch](#get-in-touch)
- [License and copyright](#license-and-copyright)
## Overview
Easier access to scientific data.
erddapy takes advantage of ERDDAP's RESTful web services and creates the ERDDAP URL for any request,
like searching for datasets, acquiring metadata, downloading the data, etc.
What is ERDDAP?
ERDDAP unifies the different types of data servers and offers a consistent way to get the data in multiple the formats.
For more information on ERDDAP servers please see [https://coastwatch.pfeg.noaa.gov/erddap/index.html](https://coastwatch.pfeg.noaa.gov/erddap/index.html).
### Documentation and code
The documentation is hosted at .
The code is hosted at .
### Installation
For `conda` users you can
```shell
conda install --channel conda-forge erddapy
```
or, if you are a `pip` users
```shell
python -m pip install erddapy
```
Note that, if you are installing the `requirements-dev.txt`, the `iris` package
is named `scitools-iris` on PyPI so `pip` users must rename that before installing.
### Example
```python
from erddapy import ERDDAP
e = ERDDAP(
server="https://gliders.ioos.us/erddap",
protocol="tabledap",
)
e.response = "csv"
e.dataset_id = "whoi_406-20160902T1700"
e.constraints = {
"time>=": "2016-07-10T00:00:00Z",
"time<=": "2017-02-10T00:00:00Z",
"latitude>=": 38.0,
"latitude<=": 41.0,
"longitude>=": -72.0,
"longitude<=": -69.0,
}
e.variables = [
"depth",
"latitude",
"longitude",
"salinity",
"temperature",
"time",
]
df = e.to_pandas()
```
## Get in touch
Report bugs, suggest features or view the source code on [GitHub](https://github.com/ioos/erddapy/issues).
## Projects using erddapy
- [argopy](https://github.com/euroargodev/argopy)
- [gliderpy](https://github.com/ioos/gliderpy)
- [gdutils](https://github.com/kerfoot/gdutils)
- [colocate](https://github.com/ioos/colocate)
- [intake-erddap](https://github.com/jmunroe/intake-erddap)
- [ioos_qc](https://github.com/ioos/ioos_qc)
## Similar projects
- [rerddap](https://cran.r-project.org/web/packages/rerddap) implements a nice client for R that performs searches on a curated set of servers instead of a query per server like erddapy.
- [erddap-python](https://github.com/hmedrano/erddap-python) 99% of the same functionality as erddapy but with a JavaScript-like API.
## License and copyright
Erddapy is licensed under BSD 3-Clause "New" or "Revised" License (BSD-3-Clause).
Development occurs on GitHub at .
%prep
%autosetup -n erddapy-2.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-erddapy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.1-1
- Package Spec generated