%global _empty_manifest_terminate_build 0
Name: python-restricted_pkg
Version: 1.1.2
Release: 1
Summary: A simple setup.py helper for private repositories
License: MIT
URL: http://github.com/rbarrois/restricted_pkg
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/63/5ac2d21284e642d9963e63c9bbe415d61f5f545df8c3e92d4dc82fe84495/restricted_pkg-1.1.2.tar.gz
BuildArch: noarch
%description
This python package provide a simple wrapper around `Distribute `_ to handle
private projects.
It is mostly intended for use in a package's ``setup.py`` script.
It provides the following features:
- Using a private package index when fetching package dependencies during ``python setup.py install``
- Restricting the ``register`` and ``upload`` commands to a private package index, or to disable them completely
- Easy support for authenticated URLs when accessing the index.
%package -n python3-restricted_pkg
Summary: A simple setup.py helper for private repositories
Provides: python-restricted_pkg
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-restricted_pkg
This python package provide a simple wrapper around `Distribute `_ to handle
private projects.
It is mostly intended for use in a package's ``setup.py`` script.
It provides the following features:
- Using a private package index when fetching package dependencies during ``python setup.py install``
- Restricting the ``register`` and ``upload`` commands to a private package index, or to disable them completely
- Easy support for authenticated URLs when accessing the index.
%package help
Summary: Development documents and examples for restricted_pkg
Provides: python3-restricted_pkg-doc
%description help
This python package provide a simple wrapper around `Distribute `_ to handle
private projects.
It is mostly intended for use in a package's ``setup.py`` script.
It provides the following features:
- Using a private package index when fetching package dependencies during ``python setup.py install``
- Restricting the ``register`` and ``upload`` commands to a private package index, or to disable them completely
- Easy support for authenticated URLs when accessing the index.
%prep
%autosetup -n restricted_pkg-1.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-restricted_pkg -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.1.2-1
- Package Spec generated