%global _empty_manifest_terminate_build 0
Name:		python-ner
Version:	0.1
Release:	1
Summary:	Python client for the Stanford Named Entity Recognizer
License:	BSD
URL:		http://github.com/dat/pyner
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/9a/5a/6aaa7bef798504cafe5ecd06cf4d274c492f387c5e1e58e57dc53f672f61/ner-0.1.tar.gz
BuildArch:	noarch


%description
# PyNER 

The Python interface to the [Stanford Named Entity Recognizer](https://github.com/dat/stanford-ner).

## Project Homepage

* [Stanford Named Entity Recognizer](http://nlp.stanford.edu/software/CRF-NER.shtml)

## Installation

    $ python setup.py install

## Basic Usage

    >>> import ner
    >>> tagger = ner.HttpNER(host='localhost', port=8080)
    >>> tagger.get_entities("University of California is located in California, United States")
    {'LOCATION': ['California', 'United States'],
     'ORGANIZATION': ['University of California']}
    >>> tagger.json_entities("Alice went to the Museum of Natural History.")
    '{"ORGANIZATION": ["Museum of Natural History"], "PERSON": ["Alice"]}'

## Online Demo

* [Graphical demo of several models](http://nlp.stanford.edu:8080/ner/)

## License

BSD License

## Author

PyNER is developed by maintained by Dat Hoang.
It can be found here: http://github.com/dat/pyner

%package -n python3-ner
Summary:	Python client for the Stanford Named Entity Recognizer
Provides:	python-ner
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ner
# PyNER 

The Python interface to the [Stanford Named Entity Recognizer](https://github.com/dat/stanford-ner).

## Project Homepage

* [Stanford Named Entity Recognizer](http://nlp.stanford.edu/software/CRF-NER.shtml)

## Installation

    $ python setup.py install

## Basic Usage

    >>> import ner
    >>> tagger = ner.HttpNER(host='localhost', port=8080)
    >>> tagger.get_entities("University of California is located in California, United States")
    {'LOCATION': ['California', 'United States'],
     'ORGANIZATION': ['University of California']}
    >>> tagger.json_entities("Alice went to the Museum of Natural History.")
    '{"ORGANIZATION": ["Museum of Natural History"], "PERSON": ["Alice"]}'

## Online Demo

* [Graphical demo of several models](http://nlp.stanford.edu:8080/ner/)

## License

BSD License

## Author

PyNER is developed by maintained by Dat Hoang.
It can be found here: http://github.com/dat/pyner

%package help
Summary:	Development documents and examples for ner
Provides:	python3-ner-doc
%description help
# PyNER 

The Python interface to the [Stanford Named Entity Recognizer](https://github.com/dat/stanford-ner).

## Project Homepage

* [Stanford Named Entity Recognizer](http://nlp.stanford.edu/software/CRF-NER.shtml)

## Installation

    $ python setup.py install

## Basic Usage

    >>> import ner
    >>> tagger = ner.HttpNER(host='localhost', port=8080)
    >>> tagger.get_entities("University of California is located in California, United States")
    {'LOCATION': ['California', 'United States'],
     'ORGANIZATION': ['University of California']}
    >>> tagger.json_entities("Alice went to the Museum of Natural History.")
    '{"ORGANIZATION": ["Museum of Natural History"], "PERSON": ["Alice"]}'

## Online Demo

* [Graphical demo of several models](http://nlp.stanford.edu:8080/ner/)

## License

BSD License

## Author

PyNER is developed by maintained by Dat Hoang.
It can be found here: http://github.com/dat/pyner

%prep
%autosetup -n ner-0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ner -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1-1
- Package Spec generated