%global _empty_manifest_terminate_build 0
Name: python-Flask-WebTest
Version: 0.1.1
Release: 1
Summary: Utilities for testing Flask applications with WebTest.
License: BSD
URL: https://github.com/level12/flask-webtest
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0c/8e/086f35966ea530f40c1dc8c6abc36316d483b02ec6ae6e8b322923db4049/Flask-WebTest-0.1.1.tar.gz
BuildArch: noarch
Requires: python3-Flask
Requires: python3-WebTest
Requires: python3-blinker
Requires: python3-flask-sqlalchemy
%description
Provides a set of utilities to ease testing Flask applications with WebTest.
Links
`````
* `documentation `_
* `development version
`_
%package -n python3-Flask-WebTest
Summary: Utilities for testing Flask applications with WebTest.
Provides: python-Flask-WebTest
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-WebTest
Provides a set of utilities to ease testing Flask applications with WebTest.
Links
`````
* `documentation `_
* `development version
`_
%package help
Summary: Development documents and examples for Flask-WebTest
Provides: python3-Flask-WebTest-doc
%description help
Provides a set of utilities to ease testing Flask applications with WebTest.
Links
`````
* `documentation `_
* `development version
`_
%prep
%autosetup -n Flask-WebTest-0.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-WebTest -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.1-1
- Package Spec generated