%global _empty_manifest_terminate_build 0
Name: python-shippinglabel
Version: 1.5.0
Release: 1
Summary: Utilities for handling packages.
License: Copyright (c) 2020-2022 Dominic Davis-Foster Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
URL: https://github.com/domdfcoding/shippinglabel
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d7/2f/080498767f07fddb8e3119246522ebdb4c3f97f477ce16d6dbb56b115895/shippinglabel-1.5.0.tar.gz
BuildArch: noarch
Requires: python3-apeye
Requires: python3-dist-meta
Requires: python3-dom-toml
Requires: python3-domdf-python-tools
Requires: python3-packaging
Requires: python3-platformdirs
Requires: python3-typing-extensions
%description
``shippinglabel`` can be installed from PyPI or Anaconda.
To install with ``pip``:
$ python -m pip install shippinglabel
To install with ``conda``:
$ conda install -c conda-forge shippinglabel
``shippinglabel`` includes a vendored copy of `trove-classifiers `_.
If you install a newer version of ``trove-classifiers`` with pip ``shippinglabel`` will use that version instead.
%package -n python3-shippinglabel
Summary: Utilities for handling packages.
Provides: python-shippinglabel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-shippinglabel
``shippinglabel`` can be installed from PyPI or Anaconda.
To install with ``pip``:
$ python -m pip install shippinglabel
To install with ``conda``:
$ conda install -c conda-forge shippinglabel
``shippinglabel`` includes a vendored copy of `trove-classifiers `_.
If you install a newer version of ``trove-classifiers`` with pip ``shippinglabel`` will use that version instead.
%package help
Summary: Development documents and examples for shippinglabel
Provides: python3-shippinglabel-doc
%description help
``shippinglabel`` can be installed from PyPI or Anaconda.
To install with ``pip``:
$ python -m pip install shippinglabel
To install with ``conda``:
$ conda install -c conda-forge shippinglabel
``shippinglabel`` includes a vendored copy of `trove-classifiers `_.
If you install a newer version of ``trove-classifiers`` with pip ``shippinglabel`` will use that version instead.
%prep
%autosetup -n shippinglabel-1.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-shippinglabel -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.5.0-1
- Package Spec generated