%global _empty_manifest_terminate_build 0
Name: python-simplere
Version: 1.2.13
Release: 1
Summary: Simpler, cleaner access to regular expressions. Globs too.
License: Apache License 2.0
URL: https://bitbucket.org/jeunice/simplere
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/13/06/61dfe9a30a3b450b76ee4ef9dfc13a473f0858114489bdc4611f269989a7/simplere-1.2.13.zip
BuildArch: noarch
%description
Python regular expressions are powerful, but the language's lack
of an *en passant* (in passing) assignment requires a preparatory
motion and then a test::
import re
match = re.search(pattern, some_string)
if match:
print match.group(1)
With ``simplere``, you can do it in fewer steps::
from simplere import *
if match / re.search(pattern, some_string):
print match[1]
That's particularly valuable in complex search-and-manipulate
code that requires multiple levels of searching along with
pre-conditions, error checking, and post-match cleanup, formatting,
and actions.
As a bonus,
``simplere`` also provides simple glob access.::
if 'globtastic' in Glob('glob*'):
print "Yes! It is!"
else:
raise ValueError('OH YES IT IS!')
It can also conveniently match against multiple glob
patterns, and/or do case-insensitive glob searches.
See `Read the Docs `_
for the full installation and usage documentation.
%package -n python3-simplere
Summary: Simpler, cleaner access to regular expressions. Globs too.
Provides: python-simplere
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-simplere
Python regular expressions are powerful, but the language's lack
of an *en passant* (in passing) assignment requires a preparatory
motion and then a test::
import re
match = re.search(pattern, some_string)
if match:
print match.group(1)
With ``simplere``, you can do it in fewer steps::
from simplere import *
if match / re.search(pattern, some_string):
print match[1]
That's particularly valuable in complex search-and-manipulate
code that requires multiple levels of searching along with
pre-conditions, error checking, and post-match cleanup, formatting,
and actions.
As a bonus,
``simplere`` also provides simple glob access.::
if 'globtastic' in Glob('glob*'):
print "Yes! It is!"
else:
raise ValueError('OH YES IT IS!')
It can also conveniently match against multiple glob
patterns, and/or do case-insensitive glob searches.
See `Read the Docs `_
for the full installation and usage documentation.
%package help
Summary: Development documents and examples for simplere
Provides: python3-simplere-doc
%description help
Python regular expressions are powerful, but the language's lack
of an *en passant* (in passing) assignment requires a preparatory
motion and then a test::
import re
match = re.search(pattern, some_string)
if match:
print match.group(1)
With ``simplere``, you can do it in fewer steps::
from simplere import *
if match / re.search(pattern, some_string):
print match[1]
That's particularly valuable in complex search-and-manipulate
code that requires multiple levels of searching along with
pre-conditions, error checking, and post-match cleanup, formatting,
and actions.
As a bonus,
``simplere`` also provides simple glob access.::
if 'globtastic' in Glob('glob*'):
print "Yes! It is!"
else:
raise ValueError('OH YES IT IS!')
It can also conveniently match against multiple glob
patterns, and/or do case-insensitive glob searches.
See `Read the Docs `_
for the full installation and usage documentation.
%prep
%autosetup -n simplere-1.2.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-simplere -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.13-1
- Package Spec generated