%global _empty_manifest_terminate_build 0 Name: python-neuralnets Version: 1.1.9.1 Release: 1 Summary: A library, based on PyTorch, that implements basic neural network algorithms and useful functions License: GNU General Public License (GPL) URL: https://github.com/saeyslab/neuralnets Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2e/ba/85b7e49cf8fb85e7ca0c502953df84c4e0da1e6262ca979d03a0f92c609c/neuralnets-1.1.9.1.tar.gz BuildArch: noarch Requires: python3-torch Requires: python3-torchvision Requires: python3-pytorch-lightning Requires: python3-future Requires: python3-pyyaml Requires: python3-tensorboard Requires: python3-numpy Requires: python3-tifffile Requires: python3-h5py Requires: python3-scikit-image Requires: python3-opencv-python Requires: python3-elasticdeform Requires: python3-progress Requires: python3-six Requires: python3-sklearn %description # NeuralNets This code implements various useful utilities for training neural networks (particularly for segmentation). Make sure to check out our [documentation page](https://neuralnets.readthedocs.io/en/latest/)! ## Installation Installation is straightforward through pip:
pip install neuralnets
%package -n python3-neuralnets
Summary: A library, based on PyTorch, that implements basic neural network algorithms and useful functions
Provides: python-neuralnets
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-neuralnets
# NeuralNets
This code implements various useful utilities for training neural networks (particularly for segmentation). Make sure to check out our [documentation page](https://neuralnets.readthedocs.io/en/latest/)!
## Installation
Installation is straightforward through pip:
pip install neuralnets
%package help
Summary: Development documents and examples for neuralnets
Provides: python3-neuralnets-doc
%description help
# NeuralNets
This code implements various useful utilities for training neural networks (particularly for segmentation). Make sure to check out our [documentation page](https://neuralnets.readthedocs.io/en/latest/)!
## Installation
Installation is straightforward through pip:
pip install neuralnets
%prep
%autosetup -n neuralnets-1.1.9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-neuralnets -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot