%global _empty_manifest_terminate_build 0
Name:		python-dmba
Version:	0.2.3
Release:	1
Summary:	Utility functions for 'Data Mining for Business Analytics: Concepts, Techniques, and Applications in Python'
License:	MIT License
URL:		https://github.com/gedeck/dmba
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f7/2e/cae5cc58deb76be47acd93f1f1ec6d4a9656eda6c82fafd69ccdc9d49c12/dmba-0.2.3.tar.gz
BuildArch:	noarch

Requires:	python3-graphviz
Requires:	python3-matplotlib
Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-scikit-learn
Requires:	python3-scipy
Requires:	python3-ipython

%description
[![PyPI](https://badge.fury.io/py/dmba.svg)](https://pypi.org/project/dmba/)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/dmba)](https://pypi.org/project/dmba/)
![Python](https://github.com/gedeck/dmba/actions/workflows/build.yml/badge.svg)

# Data Mining for Business Analytics: Concepts, Techniques, and  Applications in Python

Collection of utility functions used in the book

> _Data Mining for Business Analytics: Concepts, Techniques, and Applications in Python_ (First Edition) 
> Galit Shmueli, Peter C. Bruce, Peter Gedeck, and Nitin R. Patel
> (c) 2019 John Wiley & Sons, Inc. 

Code for the book and the used datasets are available on https://www.dataminingbook.com/book/python-edition.


## Installation
Use `pip` to install the `dmba` package from pypi (https://pypi.org/project/dmba/).
```
pip install dmba
```
Should this not work, for example when you are behind a firewall, download the package from pypi and install from file, e.g.
```
pip install dmba-0.2.3.tar.gz 
```
Adjust the link as required.


%package -n python3-dmba
Summary:	Utility functions for 'Data Mining for Business Analytics: Concepts, Techniques, and Applications in Python'
Provides:	python-dmba
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dmba
[![PyPI](https://badge.fury.io/py/dmba.svg)](https://pypi.org/project/dmba/)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/dmba)](https://pypi.org/project/dmba/)
![Python](https://github.com/gedeck/dmba/actions/workflows/build.yml/badge.svg)

# Data Mining for Business Analytics: Concepts, Techniques, and  Applications in Python

Collection of utility functions used in the book

> _Data Mining for Business Analytics: Concepts, Techniques, and Applications in Python_ (First Edition) 
> Galit Shmueli, Peter C. Bruce, Peter Gedeck, and Nitin R. Patel
> (c) 2019 John Wiley & Sons, Inc. 

Code for the book and the used datasets are available on https://www.dataminingbook.com/book/python-edition.


## Installation
Use `pip` to install the `dmba` package from pypi (https://pypi.org/project/dmba/).
```
pip install dmba
```
Should this not work, for example when you are behind a firewall, download the package from pypi and install from file, e.g.
```
pip install dmba-0.2.3.tar.gz 
```
Adjust the link as required.


%package help
Summary:	Development documents and examples for dmba
Provides:	python3-dmba-doc
%description help
[![PyPI](https://badge.fury.io/py/dmba.svg)](https://pypi.org/project/dmba/)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/dmba)](https://pypi.org/project/dmba/)
![Python](https://github.com/gedeck/dmba/actions/workflows/build.yml/badge.svg)

# Data Mining for Business Analytics: Concepts, Techniques, and  Applications in Python

Collection of utility functions used in the book

> _Data Mining for Business Analytics: Concepts, Techniques, and Applications in Python_ (First Edition) 
> Galit Shmueli, Peter C. Bruce, Peter Gedeck, and Nitin R. Patel
> (c) 2019 John Wiley & Sons, Inc. 

Code for the book and the used datasets are available on https://www.dataminingbook.com/book/python-edition.


## Installation
Use `pip` to install the `dmba` package from pypi (https://pypi.org/project/dmba/).
```
pip install dmba
```
Should this not work, for example when you are behind a firewall, download the package from pypi and install from file, e.g.
```
pip install dmba-0.2.3.tar.gz 
```
Adjust the link as required.


%prep
%autosetup -n dmba-0.2.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dmba -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.3-1
- Package Spec generated