%global _empty_manifest_terminate_build 0
Name: python-monai-weekly
Version: 1.2.dev2318
Release: 1
Summary: AI Toolkit for Healthcare Imaging
License: Apache License 2.0
URL: https://monai.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a0/80/76a653b7776408041f2c15d7607c8ac8c93781e6806a3a0625c8b388664e/monai-weekly-1.2.dev2318.tar.gz
BuildArch: noarch
Requires: python3-torch
Requires: python3-numpy
Requires: python3-nibabel
Requires: python3-ninja
Requires: python3-scikit-image
Requires: python3-pillow
Requires: python3-tensorboard
Requires: python3-gdown
Requires: python3-pytorch-ignite
Requires: python3-torchvision
Requires: python3-itk
Requires: python3-tqdm
Requires: python3-lmdb
Requires: python3-psutil
Requires: python3-cucim
Requires: python3-openslide-python
Requires: python3-tifffile
Requires: python3-imagecodecs
Requires: python3-pandas
Requires: python3-einops
Requires: python3-transformers
Requires: python3-mlflow
Requires: python3-clearml
Requires: python3-matplotlib
Requires: python3-tensorboardX
Requires: python3-pyyaml
Requires: python3-fire
Requires: python3-jsonschema
Requires: python3-pynrrd
Requires: python3-pydicom
Requires: python3-h5py
Requires: python3-nni
Requires: python3-optuna
Requires: python3-onnx
Requires: python3-onnxruntime
Requires: python3-cucim
Requires: python3-einops
Requires: python3-fire
Requires: python3-gdown
Requires: python3-h5py
Requires: python3-pytorch-ignite
Requires: python3-imagecodecs
Requires: python3-itk
Requires: python3-jsonschema
Requires: python3-lmdb
Requires: python3-matplotlib
Requires: python3-mlflow
Requires: python3-nibabel
Requires: python3-ninja
Requires: python3-nni
Requires: python3-onnx
Requires: python3-onnxruntime
Requires: python3-openslide-python
Requires: python3-optuna
Requires: python3-pandas
Requires: python3-pillow
Requires: python3-psutil
Requires: python3-pydicom
Requires: python3-pynrrd
Requires: python3-pyyaml
Requires: python3-scikit-image
Requires: python3-tensorboard
Requires: python3-tensorboardX
Requires: python3-tifffile
Requires: python3-torchvision
Requires: python3-tqdm
Requires: python3-transformers
%description
**M**edical **O**pen **N**etwork for **AI**

[](https://opensource.org/licenses/Apache-2.0)
[](https://badge.fury.io/py/monai)
[](https://hub.docker.com/r/projectmonai/monai)
[](https://anaconda.org/conda-forge/monai)
[](https://github.com/Project-MONAI/MONAI/actions/workflows/pythonapp.yml)
[](https://github.com/Project-MONAI/MONAI/actions?query=branch%3Adev)
[](https://github.com/Project-MONAI/MONAI/actions/workflows/docker.yml)
[](https://docs.monai.io/en/latest/)
[](https://codecov.io/gh/Project-MONAI/MONAI)
MONAI is a [PyTorch](https://pytorch.org/)-based, [open-source](https://github.com/Project-MONAI/MONAI/blob/dev/LICENSE) framework for deep learning in healthcare imaging, part of [PyTorch Ecosystem](https://pytorch.org/ecosystem/).
Its ambitions are:
- developing a community of academic, industrial and clinical researchers collaborating on a common foundation;
- creating state-of-the-art, end-to-end training workflows for healthcare imaging;
- providing researchers with the optimized and standardized way to create and evaluate deep learning models.
## Features
> _Please see [the technical highlights](https://docs.monai.io/en/latest/highlights.html) and [What's New](https://docs.monai.io/en/latest/whatsnew.html) of the milestone releases._
- flexible pre-processing for multi-dimensional medical imaging data;
- compositional & portable APIs for ease of integration in existing workflows;
- domain-specific implementations for networks, losses, evaluation metrics and more;
- customizable design for varying user expertise;
- multi-GPU data parallelism support.
## Installation
To install [the current release](https://pypi.org/project/monai/), you can simply run:
```bash
pip install monai
```
Please refer to [the installation guide](https://docs.monai.io/en/latest/installation.html) for other installation options.
## Getting Started
[MedNIST demo](https://colab.research.google.com/drive/1wy8XUSnNWlhDNazFdvGBHLfdkGvOHBKe) and [MONAI for PyTorch Users](https://colab.research.google.com/drive/1boqy7ENpKrqaJoxFlbHIBnIODAs1Ih1T) are available on Colab.
Examples and notebook tutorials are located at [Project-MONAI/tutorials](https://github.com/Project-MONAI/tutorials).
Technical documentation is available at [docs.monai.io](https://docs.monai.io).
## Citation
If you have used MONAI in your research, please cite us! The citation can be exported from: https://arxiv.org/abs/2211.02701.
## Model Zoo
[The MONAI Model Zoo](https://github.com/Project-MONAI/model-zoo) is a place for researchers and data scientists to share the latest and great models from the community.
Utilizing [the MONAI Bundle format](https://docs.monai.io/en/latest/bundle_intro.html) makes it easy to [get started](https://github.com/Project-MONAI/tutorials/tree/main/model_zoo) building workflows with MONAI.
## Contributing
For guidance on making a contribution to MONAI, see the [contributing guidelines](https://github.com/Project-MONAI/MONAI/blob/dev/CONTRIBUTING.md).
## Community
Join the conversation on Twitter [@ProjectMONAI](https://twitter.com/ProjectMONAI) or join our [Slack channel](https://forms.gle/QTxJq3hFictp31UM9).
Ask and answer questions over on [MONAI's GitHub Discussions tab](https://github.com/Project-MONAI/MONAI/discussions).
## Links
- Website: https://monai.io/
- API documentation (milestone): https://docs.monai.io/
- API documentation (latest dev): https://docs.monai.io/en/latest/
- Code: https://github.com/Project-MONAI/MONAI
- Project tracker: https://github.com/Project-MONAI/MONAI/projects
- Issue tracker: https://github.com/Project-MONAI/MONAI/issues
- Wiki: https://github.com/Project-MONAI/MONAI/wiki
- Test status: https://github.com/Project-MONAI/MONAI/actions
- PyPI package: https://pypi.org/project/monai/
- conda-forge: https://anaconda.org/conda-forge/monai
- Weekly previews: https://pypi.org/project/monai-weekly/
- Docker Hub: https://hub.docker.com/r/projectmonai/monai
%package -n python3-monai-weekly
Summary: AI Toolkit for Healthcare Imaging
Provides: python-monai-weekly
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-monai-weekly
**M**edical **O**pen **N**etwork for **AI**

[](https://opensource.org/licenses/Apache-2.0)
[](https://badge.fury.io/py/monai)
[](https://hub.docker.com/r/projectmonai/monai)
[](https://anaconda.org/conda-forge/monai)
[](https://github.com/Project-MONAI/MONAI/actions/workflows/pythonapp.yml)
[](https://github.com/Project-MONAI/MONAI/actions?query=branch%3Adev)
[](https://github.com/Project-MONAI/MONAI/actions/workflows/docker.yml)
[](https://docs.monai.io/en/latest/)
[](https://codecov.io/gh/Project-MONAI/MONAI)
MONAI is a [PyTorch](https://pytorch.org/)-based, [open-source](https://github.com/Project-MONAI/MONAI/blob/dev/LICENSE) framework for deep learning in healthcare imaging, part of [PyTorch Ecosystem](https://pytorch.org/ecosystem/).
Its ambitions are:
- developing a community of academic, industrial and clinical researchers collaborating on a common foundation;
- creating state-of-the-art, end-to-end training workflows for healthcare imaging;
- providing researchers with the optimized and standardized way to create and evaluate deep learning models.
## Features
> _Please see [the technical highlights](https://docs.monai.io/en/latest/highlights.html) and [What's New](https://docs.monai.io/en/latest/whatsnew.html) of the milestone releases._
- flexible pre-processing for multi-dimensional medical imaging data;
- compositional & portable APIs for ease of integration in existing workflows;
- domain-specific implementations for networks, losses, evaluation metrics and more;
- customizable design for varying user expertise;
- multi-GPU data parallelism support.
## Installation
To install [the current release](https://pypi.org/project/monai/), you can simply run:
```bash
pip install monai
```
Please refer to [the installation guide](https://docs.monai.io/en/latest/installation.html) for other installation options.
## Getting Started
[MedNIST demo](https://colab.research.google.com/drive/1wy8XUSnNWlhDNazFdvGBHLfdkGvOHBKe) and [MONAI for PyTorch Users](https://colab.research.google.com/drive/1boqy7ENpKrqaJoxFlbHIBnIODAs1Ih1T) are available on Colab.
Examples and notebook tutorials are located at [Project-MONAI/tutorials](https://github.com/Project-MONAI/tutorials).
Technical documentation is available at [docs.monai.io](https://docs.monai.io).
## Citation
If you have used MONAI in your research, please cite us! The citation can be exported from: https://arxiv.org/abs/2211.02701.
## Model Zoo
[The MONAI Model Zoo](https://github.com/Project-MONAI/model-zoo) is a place for researchers and data scientists to share the latest and great models from the community.
Utilizing [the MONAI Bundle format](https://docs.monai.io/en/latest/bundle_intro.html) makes it easy to [get started](https://github.com/Project-MONAI/tutorials/tree/main/model_zoo) building workflows with MONAI.
## Contributing
For guidance on making a contribution to MONAI, see the [contributing guidelines](https://github.com/Project-MONAI/MONAI/blob/dev/CONTRIBUTING.md).
## Community
Join the conversation on Twitter [@ProjectMONAI](https://twitter.com/ProjectMONAI) or join our [Slack channel](https://forms.gle/QTxJq3hFictp31UM9).
Ask and answer questions over on [MONAI's GitHub Discussions tab](https://github.com/Project-MONAI/MONAI/discussions).
## Links
- Website: https://monai.io/
- API documentation (milestone): https://docs.monai.io/
- API documentation (latest dev): https://docs.monai.io/en/latest/
- Code: https://github.com/Project-MONAI/MONAI
- Project tracker: https://github.com/Project-MONAI/MONAI/projects
- Issue tracker: https://github.com/Project-MONAI/MONAI/issues
- Wiki: https://github.com/Project-MONAI/MONAI/wiki
- Test status: https://github.com/Project-MONAI/MONAI/actions
- PyPI package: https://pypi.org/project/monai/
- conda-forge: https://anaconda.org/conda-forge/monai
- Weekly previews: https://pypi.org/project/monai-weekly/
- Docker Hub: https://hub.docker.com/r/projectmonai/monai
%package help
Summary: Development documents and examples for monai-weekly
Provides: python3-monai-weekly-doc
%description help
**M**edical **O**pen **N**etwork for **AI**

[](https://opensource.org/licenses/Apache-2.0)
[](https://badge.fury.io/py/monai)
[](https://hub.docker.com/r/projectmonai/monai)
[](https://anaconda.org/conda-forge/monai)
[](https://github.com/Project-MONAI/MONAI/actions/workflows/pythonapp.yml)
[](https://github.com/Project-MONAI/MONAI/actions?query=branch%3Adev)
[](https://github.com/Project-MONAI/MONAI/actions/workflows/docker.yml)
[](https://docs.monai.io/en/latest/)
[](https://codecov.io/gh/Project-MONAI/MONAI)
MONAI is a [PyTorch](https://pytorch.org/)-based, [open-source](https://github.com/Project-MONAI/MONAI/blob/dev/LICENSE) framework for deep learning in healthcare imaging, part of [PyTorch Ecosystem](https://pytorch.org/ecosystem/).
Its ambitions are:
- developing a community of academic, industrial and clinical researchers collaborating on a common foundation;
- creating state-of-the-art, end-to-end training workflows for healthcare imaging;
- providing researchers with the optimized and standardized way to create and evaluate deep learning models.
## Features
> _Please see [the technical highlights](https://docs.monai.io/en/latest/highlights.html) and [What's New](https://docs.monai.io/en/latest/whatsnew.html) of the milestone releases._
- flexible pre-processing for multi-dimensional medical imaging data;
- compositional & portable APIs for ease of integration in existing workflows;
- domain-specific implementations for networks, losses, evaluation metrics and more;
- customizable design for varying user expertise;
- multi-GPU data parallelism support.
## Installation
To install [the current release](https://pypi.org/project/monai/), you can simply run:
```bash
pip install monai
```
Please refer to [the installation guide](https://docs.monai.io/en/latest/installation.html) for other installation options.
## Getting Started
[MedNIST demo](https://colab.research.google.com/drive/1wy8XUSnNWlhDNazFdvGBHLfdkGvOHBKe) and [MONAI for PyTorch Users](https://colab.research.google.com/drive/1boqy7ENpKrqaJoxFlbHIBnIODAs1Ih1T) are available on Colab.
Examples and notebook tutorials are located at [Project-MONAI/tutorials](https://github.com/Project-MONAI/tutorials).
Technical documentation is available at [docs.monai.io](https://docs.monai.io).
## Citation
If you have used MONAI in your research, please cite us! The citation can be exported from: https://arxiv.org/abs/2211.02701.
## Model Zoo
[The MONAI Model Zoo](https://github.com/Project-MONAI/model-zoo) is a place for researchers and data scientists to share the latest and great models from the community.
Utilizing [the MONAI Bundle format](https://docs.monai.io/en/latest/bundle_intro.html) makes it easy to [get started](https://github.com/Project-MONAI/tutorials/tree/main/model_zoo) building workflows with MONAI.
## Contributing
For guidance on making a contribution to MONAI, see the [contributing guidelines](https://github.com/Project-MONAI/MONAI/blob/dev/CONTRIBUTING.md).
## Community
Join the conversation on Twitter [@ProjectMONAI](https://twitter.com/ProjectMONAI) or join our [Slack channel](https://forms.gle/QTxJq3hFictp31UM9).
Ask and answer questions over on [MONAI's GitHub Discussions tab](https://github.com/Project-MONAI/MONAI/discussions).
## Links
- Website: https://monai.io/
- API documentation (milestone): https://docs.monai.io/
- API documentation (latest dev): https://docs.monai.io/en/latest/
- Code: https://github.com/Project-MONAI/MONAI
- Project tracker: https://github.com/Project-MONAI/MONAI/projects
- Issue tracker: https://github.com/Project-MONAI/MONAI/issues
- Wiki: https://github.com/Project-MONAI/MONAI/wiki
- Test status: https://github.com/Project-MONAI/MONAI/actions
- PyPI package: https://pypi.org/project/monai/
- conda-forge: https://anaconda.org/conda-forge/monai
- Weekly previews: https://pypi.org/project/monai-weekly/
- Docker Hub: https://hub.docker.com/r/projectmonai/monai
%prep
%autosetup -n monai-weekly-1.2.dev2318
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-monai-weekly -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.dev2318-1
- Package Spec generated