%global _empty_manifest_terminate_build 0
Name: python-readtime
Version: 2.0.0
Release: 1
Summary: Calculates the time some text takes the average human to read, based on Medium's read time forumula
License: BSD
URL: https://github.com/alanhamlett/readtime
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/14/a7/4b74e4c3b98ce61f1333ff75431beeca98bb9f48460b441e684c056e3b70/readtime-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-beautifulsoup4
Requires: python3-markdown2
Requires: python3-pyquery
%description
# readtime
[![Tests](https://img.shields.io/github/workflow/status/alanhamlett/readtime/Tests/master)](https://github.com/alanhamlett/readtime/actions/workflows/tests.yml)
[![Coverage](https://codecov.io/gh/alanhamlett/readtime/branch/master/graph/badge.svg?token=EbUnuwbra3)](https://codecov.io/gh/alanhamlett/readtime)
Calculates the time some text takes the average human to read, based on Medium's [read time forumula](https://help.medium.com/hc/en-us/articles/214991667-Read-time).
### Algorithm
Medium's Help Center says,
> Read time is based on the average reading speed of an adult (roughly 265 WPM). We take the total word count of a post and translate it into minutes, with an adjustment made for images. For posts in Chinese, Japanese and Korean, it's a function of number of characters (500 characters/min) with an adjustment made for images.
Source: https://help.medium.com/hc/en-us/articles/214991667-Read-time (Read Sept 23rd, 2018)
Double checking with real articles, the English algorithm is:
seconds = num_words / 265 * 60 + img_weight * num_images
With `img_weight` starting at `12` and decreasing one second with each image encountered, with a minium `img_weight` of `3` seconds.
### Installation
virtualenv venv
. venv/bin/activate
pip install readtime
Or if you like to live dangerously:
sudo pip install readtime
### Usage
Import `readtime` and pass it some text, HTML, or Markdown to get back the time it takes to read:
>>> import readtime
>>> result = readtime.of_text('The shortest blog post in the world!')
>>> result.seconds
2
>>> result.text
u'1 min'
The result can also be used as a string:
>>> str(readtime.of_text('The shortest blog post in the world!'))
u'1 min read'
To calculate read time of Markdown:
>>> readtime.of_markdown('This is **Markdown**')
1 min read
To calculate read time of HTML:
>>> readtime.of_html('This is HTML')
1 min read
To customize the WPM (default 265):
>>> result = readtime.of_text('The shortest blog post in the world!', wpm=5)
>>> result.seconds
96
>>> result.text
u'2 min'
>>> result.wpm
5
### Contributing
Before contributing a pull request, make sure tests pass:
virtualenv venv
. venv/bin/activate
pip install tox
tox
Many thanks to all [contributors](https://github.com/alanhamlett/readtime/blob/master/AUTHORS)!
%package -n python3-readtime
Summary: Calculates the time some text takes the average human to read, based on Medium's read time forumula
Provides: python-readtime
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-readtime
# readtime
[![Tests](https://img.shields.io/github/workflow/status/alanhamlett/readtime/Tests/master)](https://github.com/alanhamlett/readtime/actions/workflows/tests.yml)
[![Coverage](https://codecov.io/gh/alanhamlett/readtime/branch/master/graph/badge.svg?token=EbUnuwbra3)](https://codecov.io/gh/alanhamlett/readtime)
Calculates the time some text takes the average human to read, based on Medium's [read time forumula](https://help.medium.com/hc/en-us/articles/214991667-Read-time).
### Algorithm
Medium's Help Center says,
> Read time is based on the average reading speed of an adult (roughly 265 WPM). We take the total word count of a post and translate it into minutes, with an adjustment made for images. For posts in Chinese, Japanese and Korean, it's a function of number of characters (500 characters/min) with an adjustment made for images.
Source: https://help.medium.com/hc/en-us/articles/214991667-Read-time (Read Sept 23rd, 2018)
Double checking with real articles, the English algorithm is:
seconds = num_words / 265 * 60 + img_weight * num_images
With `img_weight` starting at `12` and decreasing one second with each image encountered, with a minium `img_weight` of `3` seconds.
### Installation
virtualenv venv
. venv/bin/activate
pip install readtime
Or if you like to live dangerously:
sudo pip install readtime
### Usage
Import `readtime` and pass it some text, HTML, or Markdown to get back the time it takes to read:
>>> import readtime
>>> result = readtime.of_text('The shortest blog post in the world!')
>>> result.seconds
2
>>> result.text
u'1 min'
The result can also be used as a string:
>>> str(readtime.of_text('The shortest blog post in the world!'))
u'1 min read'
To calculate read time of Markdown:
>>> readtime.of_markdown('This is **Markdown**')
1 min read
To calculate read time of HTML:
>>> readtime.of_html('This is HTML')
1 min read
To customize the WPM (default 265):
>>> result = readtime.of_text('The shortest blog post in the world!', wpm=5)
>>> result.seconds
96
>>> result.text
u'2 min'
>>> result.wpm
5
### Contributing
Before contributing a pull request, make sure tests pass:
virtualenv venv
. venv/bin/activate
pip install tox
tox
Many thanks to all [contributors](https://github.com/alanhamlett/readtime/blob/master/AUTHORS)!
%package help
Summary: Development documents and examples for readtime
Provides: python3-readtime-doc
%description help
# readtime
[![Tests](https://img.shields.io/github/workflow/status/alanhamlett/readtime/Tests/master)](https://github.com/alanhamlett/readtime/actions/workflows/tests.yml)
[![Coverage](https://codecov.io/gh/alanhamlett/readtime/branch/master/graph/badge.svg?token=EbUnuwbra3)](https://codecov.io/gh/alanhamlett/readtime)
Calculates the time some text takes the average human to read, based on Medium's [read time forumula](https://help.medium.com/hc/en-us/articles/214991667-Read-time).
### Algorithm
Medium's Help Center says,
> Read time is based on the average reading speed of an adult (roughly 265 WPM). We take the total word count of a post and translate it into minutes, with an adjustment made for images. For posts in Chinese, Japanese and Korean, it's a function of number of characters (500 characters/min) with an adjustment made for images.
Source: https://help.medium.com/hc/en-us/articles/214991667-Read-time (Read Sept 23rd, 2018)
Double checking with real articles, the English algorithm is:
seconds = num_words / 265 * 60 + img_weight * num_images
With `img_weight` starting at `12` and decreasing one second with each image encountered, with a minium `img_weight` of `3` seconds.
### Installation
virtualenv venv
. venv/bin/activate
pip install readtime
Or if you like to live dangerously:
sudo pip install readtime
### Usage
Import `readtime` and pass it some text, HTML, or Markdown to get back the time it takes to read:
>>> import readtime
>>> result = readtime.of_text('The shortest blog post in the world!')
>>> result.seconds
2
>>> result.text
u'1 min'
The result can also be used as a string:
>>> str(readtime.of_text('The shortest blog post in the world!'))
u'1 min read'
To calculate read time of Markdown:
>>> readtime.of_markdown('This is **Markdown**')
1 min read
To calculate read time of HTML:
>>> readtime.of_html('This is HTML')
1 min read
To customize the WPM (default 265):
>>> result = readtime.of_text('The shortest blog post in the world!', wpm=5)
>>> result.seconds
96
>>> result.text
u'2 min'
>>> result.wpm
5
### Contributing
Before contributing a pull request, make sure tests pass:
virtualenv venv
. venv/bin/activate
pip install tox
tox
Many thanks to all [contributors](https://github.com/alanhamlett/readtime/blob/master/AUTHORS)!
%prep
%autosetup -n readtime-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-readtime -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.0-1
- Package Spec generated