%global _empty_manifest_terminate_build 0
Name: python-qtoml
Version: 0.3.1
Release: 1
Summary: New TOML encoder/decoder
License: MIT
URL: https://github.com/alethiophile/qtoml
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/eb/0e/31e7e1288de5ccb891c4d39092e02b955306f2a648e4354cb62faef4b987/qtoml-0.3.1.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-attrs
%description
qtoml is available on `PyPI `_. You can install
it using pip:
$ pip install qtoml
qtoml supports the standard ``load``/``loads``/``dump``/``dumps`` API common to
most similar modules. Usage:
>>> import qtoml
>>> toml_string = """
>>> qtoml.loads(toml_string)
{'test_value': 7}
>>> print(qtoml.dumps({'a': 4, 'b': 5.0}))
a = 4
b = 5.0
>>> infile = open('filename.toml', 'r')
>>> parsed_structure = qtoml.load(infile)
>>> outfile = open('new_filename.toml', 'w')
>>> qtoml.dump(parsed_structure, outfile)
TOML supports a fairly complete subset of the Python data model, but notably
does not include a null or ``None`` value. If you have a large dictionary from
somewhere else including ``None`` values, it can occasionally be useful to
substitute them on encode:
>>> print(qtoml.dumps({ 'none': None }))
qtoml.encoder.TOMLEncodeError: TOML cannot encode None
>>> print(qtoml.dumps({ 'none': None }, encode_none='None'))
none = 'None'
The ``encode_none`` value must be a replacement encodable by TOML, such as zero
or a string.
This breaks reversibility of the encoding, by rendering ``None`` values
indistinguishable from literal occurrences of whatever sentinel you chose. Thus,
it should not be used when exact representations are critical.
%package -n python3-qtoml
Summary: New TOML encoder/decoder
Provides: python-qtoml
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-qtoml
qtoml is available on `PyPI `_. You can install
it using pip:
$ pip install qtoml
qtoml supports the standard ``load``/``loads``/``dump``/``dumps`` API common to
most similar modules. Usage:
>>> import qtoml
>>> toml_string = """
>>> qtoml.loads(toml_string)
{'test_value': 7}
>>> print(qtoml.dumps({'a': 4, 'b': 5.0}))
a = 4
b = 5.0
>>> infile = open('filename.toml', 'r')
>>> parsed_structure = qtoml.load(infile)
>>> outfile = open('new_filename.toml', 'w')
>>> qtoml.dump(parsed_structure, outfile)
TOML supports a fairly complete subset of the Python data model, but notably
does not include a null or ``None`` value. If you have a large dictionary from
somewhere else including ``None`` values, it can occasionally be useful to
substitute them on encode:
>>> print(qtoml.dumps({ 'none': None }))
qtoml.encoder.TOMLEncodeError: TOML cannot encode None
>>> print(qtoml.dumps({ 'none': None }, encode_none='None'))
none = 'None'
The ``encode_none`` value must be a replacement encodable by TOML, such as zero
or a string.
This breaks reversibility of the encoding, by rendering ``None`` values
indistinguishable from literal occurrences of whatever sentinel you chose. Thus,
it should not be used when exact representations are critical.
%package help
Summary: Development documents and examples for qtoml
Provides: python3-qtoml-doc
%description help
qtoml is available on `PyPI `_. You can install
it using pip:
$ pip install qtoml
qtoml supports the standard ``load``/``loads``/``dump``/``dumps`` API common to
most similar modules. Usage:
>>> import qtoml
>>> toml_string = """
>>> qtoml.loads(toml_string)
{'test_value': 7}
>>> print(qtoml.dumps({'a': 4, 'b': 5.0}))
a = 4
b = 5.0
>>> infile = open('filename.toml', 'r')
>>> parsed_structure = qtoml.load(infile)
>>> outfile = open('new_filename.toml', 'w')
>>> qtoml.dump(parsed_structure, outfile)
TOML supports a fairly complete subset of the Python data model, but notably
does not include a null or ``None`` value. If you have a large dictionary from
somewhere else including ``None`` values, it can occasionally be useful to
substitute them on encode:
>>> print(qtoml.dumps({ 'none': None }))
qtoml.encoder.TOMLEncodeError: TOML cannot encode None
>>> print(qtoml.dumps({ 'none': None }, encode_none='None'))
none = 'None'
The ``encode_none`` value must be a replacement encodable by TOML, such as zero
or a string.
This breaks reversibility of the encoding, by rendering ``None`` values
indistinguishable from literal occurrences of whatever sentinel you chose. Thus,
it should not be used when exact representations are critical.
%prep
%autosetup -n qtoml-0.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-qtoml -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.3.1-1
- Package Spec generated