%global _empty_manifest_terminate_build 0
Name: python-credsafe
Version: 3.1.0
Release: 1
Summary: Store application credentials in keyring with RSA and AES-256.
License: AGPL-3.0
URL: https://github.com/foxe6/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f7/a9/45d31f01dcd8a87a21c1245bbf49d01d415ffd3ff66a7bab47b7b142fc5e/credsafe-3.1.0.tar.gz
BuildArch: noarch
Requires: python3-aescipher
Requires: python3-easyrsa
Requires: python3-omnitools
Requires: python3-keyring
%description
# Credentials Safe
[](https://pypi.org/project/credsafe/)
[](https://pypi.org/project/credsafe/)
[](https://pypi.org/project/credsafe/)
[](https://saythanks.io/to/foxe6)
[](https://paypal.me/foxe6)
[](https://paypal.me/foxe6)
Store application credentials in keyring with RSA and AES-256.
# Hierarchy
```
credsafe
|---- Agent()
| |---- set()
| |---- get()
| |---- rm()
| '---- destroy()
|---- AgentV2()
| |---- set()
| |---- get()
| |---- rm()
| '---- destroy()
'---- AgentV1()
|---- set()
|---- get()
|---- rm()
'---- destroy()
```
# Example
## python
See `test`.
%package -n python3-credsafe
Summary: Store application credentials in keyring with RSA and AES-256.
Provides: python-credsafe
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-credsafe
# Credentials Safe
[](https://pypi.org/project/credsafe/)
[](https://pypi.org/project/credsafe/)
[](https://pypi.org/project/credsafe/)
[](https://saythanks.io/to/foxe6)
[](https://paypal.me/foxe6)
[](https://paypal.me/foxe6)
Store application credentials in keyring with RSA and AES-256.
# Hierarchy
```
credsafe
|---- Agent()
| |---- set()
| |---- get()
| |---- rm()
| '---- destroy()
|---- AgentV2()
| |---- set()
| |---- get()
| |---- rm()
| '---- destroy()
'---- AgentV1()
|---- set()
|---- get()
|---- rm()
'---- destroy()
```
# Example
## python
See `test`.
%package help
Summary: Development documents and examples for credsafe
Provides: python3-credsafe-doc
%description help
# Credentials Safe
[](https://pypi.org/project/credsafe/)
[](https://pypi.org/project/credsafe/)
[](https://pypi.org/project/credsafe/)
[](https://saythanks.io/to/foxe6)
[](https://paypal.me/foxe6)
[](https://paypal.me/foxe6)
Store application credentials in keyring with RSA and AES-256.
# Hierarchy
```
credsafe
|---- Agent()
| |---- set()
| |---- get()
| |---- rm()
| '---- destroy()
|---- AgentV2()
| |---- set()
| |---- get()
| |---- rm()
| '---- destroy()
'---- AgentV1()
|---- set()
|---- get()
|---- rm()
'---- destroy()
```
# Example
## python
See `test`.
%prep
%autosetup -n credsafe-3.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-credsafe -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 3.1.0-1
- Package Spec generated