%global _empty_manifest_terminate_build 0
Name: python-rdk
Version: 0.13.0
Release: 1
Summary: Rule Development Kit CLI for AWS Config
License: Apache-2.0
URL: https://github.com/awslabs/aws-config-rdk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1e/f6/7139e5b9c897de790f31206a48da17dbcc40390b3dd001632412f073015f/rdk-0.13.0.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-pyyaml
%description
|pypibadge| |downloadsbadge|
Rule Development Kit
We greatly appreciate feedback and bug reports at rdk-maintainers@amazon.com! You may also create an issue on this repo.
The RDK is designed to support a "Compliance-as-Code" workflow that is intuitive and productive. It abstracts away much of the undifferentiated heavy lifting associated with deploying AWS Config rules backed by custom lambda functions, and provides a streamlined develop-deploy-monitor iterative process.
For complete documentation, including command reference, check out the `ReadTheDocs documentation `_.
%package -n python3-rdk
Summary: Rule Development Kit CLI for AWS Config
Provides: python-rdk
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rdk
|pypibadge| |downloadsbadge|
Rule Development Kit
We greatly appreciate feedback and bug reports at rdk-maintainers@amazon.com! You may also create an issue on this repo.
The RDK is designed to support a "Compliance-as-Code" workflow that is intuitive and productive. It abstracts away much of the undifferentiated heavy lifting associated with deploying AWS Config rules backed by custom lambda functions, and provides a streamlined develop-deploy-monitor iterative process.
For complete documentation, including command reference, check out the `ReadTheDocs documentation `_.
%package help
Summary: Development documents and examples for rdk
Provides: python3-rdk-doc
%description help
|pypibadge| |downloadsbadge|
Rule Development Kit
We greatly appreciate feedback and bug reports at rdk-maintainers@amazon.com! You may also create an issue on this repo.
The RDK is designed to support a "Compliance-as-Code" workflow that is intuitive and productive. It abstracts away much of the undifferentiated heavy lifting associated with deploying AWS Config rules backed by custom lambda functions, and provides a streamlined develop-deploy-monitor iterative process.
For complete documentation, including command reference, check out the `ReadTheDocs documentation `_.
%prep
%autosetup -n rdk-0.13.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rdk -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.13.0-1
- Package Spec generated