%global _empty_manifest_terminate_build 0
Name: python-django-likes
Version: 2.0.1
Release: 1
Summary: Django app providing view interface to django-secretballot.
License: BSD
URL: http://github.com/praekelt/django-likes
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/d2/326196372a156a1992340087e3879b702e6d1602ce7a667faa051c7f3ae1/django-likes-2.0.1.tar.gz
BuildArch: noarch
%description
**Django app providing view interface to django-secretballot.**
This app utilizes `Django Secretballot `_ to provide Facebook or Google+1 style item liking of Django model objects. Authenticated or anonymous users are allowed to like any given object only once.
%package -n python3-django-likes
Summary: Django app providing view interface to django-secretballot.
Provides: python-django-likes
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-likes
**Django app providing view interface to django-secretballot.**
This app utilizes `Django Secretballot `_ to provide Facebook or Google+1 style item liking of Django model objects. Authenticated or anonymous users are allowed to like any given object only once.
%package help
Summary: Development documents and examples for django-likes
Provides: python3-django-likes-doc
%description help
**Django app providing view interface to django-secretballot.**
This app utilizes `Django Secretballot `_ to provide Facebook or Google+1 style item liking of Django model objects. Authenticated or anonymous users are allowed to like any given object only once.
%prep
%autosetup -n django-likes-2.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-likes -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.1-1
- Package Spec generated