%global _empty_manifest_terminate_build 0
Name: python-ColanderAlchemy
Version: 0.3.4
Release: 1
Summary: Autogenerate Colander schemas based on SQLAlchemy models.
License: MIT
URL: https://github.com/stefanofontanelli/ColanderAlchemy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/6b/21c34465df8ebacd875f4fb8ae407870bd5b357b90122275aff34f353b78/ColanderAlchemy-0.3.4.tar.gz
BuildArch: noarch
Requires: python3-colander
Requires: python3-SQLAlchemy
%description
`ColanderAlchemy` helps you to auto-generate `Colander
`_ schemas
that are based on `SQLAlchemy `_ mapped
classes.
Such `Colander` schemas can be used with libraries like `Deform
`_ and helps remove the
need for duplication of schema definitions.
%package -n python3-ColanderAlchemy
Summary: Autogenerate Colander schemas based on SQLAlchemy models.
Provides: python-ColanderAlchemy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ColanderAlchemy
`ColanderAlchemy` helps you to auto-generate `Colander
`_ schemas
that are based on `SQLAlchemy `_ mapped
classes.
Such `Colander` schemas can be used with libraries like `Deform
`_ and helps remove the
need for duplication of schema definitions.
%package help
Summary: Development documents and examples for ColanderAlchemy
Provides: python3-ColanderAlchemy-doc
%description help
`ColanderAlchemy` helps you to auto-generate `Colander
`_ schemas
that are based on `SQLAlchemy `_ mapped
classes.
Such `Colander` schemas can be used with libraries like `Deform
`_ and helps remove the
need for duplication of schema definitions.
%prep
%autosetup -n ColanderAlchemy-0.3.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ColanderAlchemy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.3.4-1
- Package Spec generated