%global _empty_manifest_terminate_build 0
Name: python-Flask-Environments
Version: 0.1
Release: 1
Summary: Environment tools and configuration for Flask applications
License: MIT
URL: http://packages.python.org/flask-environments/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/25/85/1e555af8a44c490fabe367f864e9a0c8cf536733f0f0fc6bf53dd3165b07/Flask-Environments-0.1.tar.gz
BuildArch: noarch
%description
Environment tools and configuration for Flask applications
Resources
`````````
- `Documentation `_
- `Issue Tracker `_
- `Code `_
- `Development Version
`_
%package -n python3-Flask-Environments
Summary: Environment tools and configuration for Flask applications
Provides: python-Flask-Environments
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-Environments
Environment tools and configuration for Flask applications
Resources
`````````
- `Documentation `_
- `Issue Tracker `_
- `Code `_
- `Development Version
`_
%package help
Summary: Development documents and examples for Flask-Environments
Provides: python3-Flask-Environments-doc
%description help
Environment tools and configuration for Flask applications
Resources
`````````
- `Documentation `_
- `Issue Tracker `_
- `Code `_
- `Development Version
`_
%prep
%autosetup -n Flask-Environments-0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-Environments -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1-1
- Package Spec generated