%global _empty_manifest_terminate_build 0
Name: python-dinteractions-Paginator
Version: 2.0.2
Release: 1
Summary: Official interactions.py paginator
License: GNU
URL: https://github.com/Toricane/dinteractions-Paginator
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/a8/f9048609e8a5a57f141a8f1df40d9bbd61b199f3cf372102df1ded160e41/dinteractions_Paginator-2.0.2.tar.gz
BuildArch: noarch
Requires: python3-discord-py-interactions
Requires: python3-interactions-wait-for
%description
## *class* Data
### Attributes
- `paginator: Paginator`: The `Paginator` object.
- `original_ctx: CommandContext | ComponentContext`: The original context supplied to the paginator.
- `component_ctx: ComponentContext`: The component context.
%package -n python3-dinteractions-Paginator
Summary: Official interactions.py paginator
Provides: python-dinteractions-Paginator
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dinteractions-Paginator
## *class* Data
### Attributes
- `paginator: Paginator`: The `Paginator` object.
- `original_ctx: CommandContext | ComponentContext`: The original context supplied to the paginator.
- `component_ctx: ComponentContext`: The component context.
%package help
Summary: Development documents and examples for dinteractions-Paginator
Provides: python3-dinteractions-Paginator-doc
%description help
## *class* Data
### Attributes
- `paginator: Paginator`: The `Paginator` object.
- `original_ctx: CommandContext | ComponentContext`: The original context supplied to the paginator.
- `component_ctx: ComponentContext`: The component context.
%prep
%autosetup -n dinteractions-Paginator-2.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dinteractions-Paginator -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.2-1
- Package Spec generated