%global _empty_manifest_terminate_build 0
Name: python-wbdata
Version: 0.3.0
Release: 1
Summary: A library to access World Bank data
License: GPL-2.0+
URL: https://pypi.org/project/wbdata/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/43/00/62874961cf9ee986c29a83dff8feabf524202faadfe8437beda278dd7f18/wbdata-0.3.0.tar.gz
BuildArch: noarch
Requires: python3-decorator
Requires: python3-requests
Requires: python3-pandas
Requires: python3-sphinx
Requires: python3-tabulate
Requires: python3-appdirs
%description
# wbdata
| Branch | Status |
|--------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| master | [![master branch status](https://github.com/OliverSherouse/wbdata/workflows/Tests/badge.svg?branch=master)](https://github.com/OliverSherouse/wbdata/actions?query=workflow%3A%22Tests%22+branch%3Amaster) |
| dev | [![dev branch status](https://github.com/OliverSherouse/wbdata/workflows/Tests/badge.svg?branch=dev)](https://github.com/OliverSherouse/wbdata/actions?query=workflow%3A%22Tests%22+branch%3Adev) |
Wbdata is a simple python interface to find and request information from the
World Bank's various databases, either as a dictionary containing full metadata
or as a [pandas](http://pandas.pydata.org) DataFrame or series. Currently,
wbdata wraps most of the [World Bank
API](http://data.worldbank.org/developers/api-overview), and also adds some
convenience functions for searching and retrieving information.
Documentation is available at .
%package -n python3-wbdata
Summary: A library to access World Bank data
Provides: python-wbdata
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wbdata
# wbdata
| Branch | Status |
|--------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| master | [![master branch status](https://github.com/OliverSherouse/wbdata/workflows/Tests/badge.svg?branch=master)](https://github.com/OliverSherouse/wbdata/actions?query=workflow%3A%22Tests%22+branch%3Amaster) |
| dev | [![dev branch status](https://github.com/OliverSherouse/wbdata/workflows/Tests/badge.svg?branch=dev)](https://github.com/OliverSherouse/wbdata/actions?query=workflow%3A%22Tests%22+branch%3Adev) |
Wbdata is a simple python interface to find and request information from the
World Bank's various databases, either as a dictionary containing full metadata
or as a [pandas](http://pandas.pydata.org) DataFrame or series. Currently,
wbdata wraps most of the [World Bank
API](http://data.worldbank.org/developers/api-overview), and also adds some
convenience functions for searching and retrieving information.
Documentation is available at .
%package help
Summary: Development documents and examples for wbdata
Provides: python3-wbdata-doc
%description help
# wbdata
| Branch | Status |
|--------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| master | [![master branch status](https://github.com/OliverSherouse/wbdata/workflows/Tests/badge.svg?branch=master)](https://github.com/OliverSherouse/wbdata/actions?query=workflow%3A%22Tests%22+branch%3Amaster) |
| dev | [![dev branch status](https://github.com/OliverSherouse/wbdata/workflows/Tests/badge.svg?branch=dev)](https://github.com/OliverSherouse/wbdata/actions?query=workflow%3A%22Tests%22+branch%3Adev) |
Wbdata is a simple python interface to find and request information from the
World Bank's various databases, either as a dictionary containing full metadata
or as a [pandas](http://pandas.pydata.org) DataFrame or series. Currently,
wbdata wraps most of the [World Bank
API](http://data.worldbank.org/developers/api-overview), and also adds some
convenience functions for searching and retrieving information.
Documentation is available at .
%prep
%autosetup -n wbdata-0.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wbdata -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.3.0-1
- Package Spec generated