%global _empty_manifest_terminate_build 0
Name: python-PBar2
Version: 2.2.2
Release: 1
Summary: Display customizable progress bars on the terminal easily.
License: MIT License
URL: https://darvil82.github.io/PBar
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f3/18/d49ff7c685b1dc52d98ef6d5aedc83aeb623eb8749382813f02081809efa/PBar2-2.2.2.tar.gz
BuildArch: noarch
%description
### PBar is a small Python library to display highly customizable progress bars on the terminal easily. Contributions are welcome!
https://user-images.githubusercontent.com/48654552/140072905-f83a1ff4-fba7-481d-925d-727caed6c3e8.mp4
More examples
https://user-images.githubusercontent.com/48654552/148692560-87e005f7-076a-48cc-9ae9-4c168ee040bc.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/relative_pos.py)
https://user-images.githubusercontent.com/48654552/134776865-c7516cf1-0c66-44da-ae2c-f2cbedd2527c.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/anim.py)
https://user-images.githubusercontent.com/48654552/137568056-aafa1ba1-35c2-4ecd-84f8-99ca0093cab5.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/conds.py)
## Wiki
Please visit the different wiki pages available **[here](https://github.com/DarviL82/PBar/wiki)** to see all the features of this package!
## Requirements
- Python 3.9+
- A terminal that can display VT100 sequences and escape codes such as `\v`.
Windows CMD and PowerShell do not support some of these entirely, though Windows Terminal does.
## Installation
### Pip
PBar is available on the *Python Package Index*:
`pip install pbar2`
You can also install this package through *GitHub* with pip:
`pip install git+https://github.com/DarviL82/PBar`
For uninstalling:
`pip uninstall pbar2`
### AUR
There is also an [*Arch User Repository package*](https://aur.archlinux.org/packages/python-pbar/) made by **MithicSpirit**.
## Additional Credits
| User | Task |
|------------|---------------|
| DrMeepster | Type Checking |
%package -n python3-PBar2
Summary: Display customizable progress bars on the terminal easily.
Provides: python-PBar2
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PBar2
### PBar is a small Python library to display highly customizable progress bars on the terminal easily. Contributions are welcome!
https://user-images.githubusercontent.com/48654552/140072905-f83a1ff4-fba7-481d-925d-727caed6c3e8.mp4
More examples
https://user-images.githubusercontent.com/48654552/148692560-87e005f7-076a-48cc-9ae9-4c168ee040bc.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/relative_pos.py)
https://user-images.githubusercontent.com/48654552/134776865-c7516cf1-0c66-44da-ae2c-f2cbedd2527c.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/anim.py)
https://user-images.githubusercontent.com/48654552/137568056-aafa1ba1-35c2-4ecd-84f8-99ca0093cab5.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/conds.py)
## Wiki
Please visit the different wiki pages available **[here](https://github.com/DarviL82/PBar/wiki)** to see all the features of this package!
## Requirements
- Python 3.9+
- A terminal that can display VT100 sequences and escape codes such as `\v`.
Windows CMD and PowerShell do not support some of these entirely, though Windows Terminal does.
## Installation
### Pip
PBar is available on the *Python Package Index*:
`pip install pbar2`
You can also install this package through *GitHub* with pip:
`pip install git+https://github.com/DarviL82/PBar`
For uninstalling:
`pip uninstall pbar2`
### AUR
There is also an [*Arch User Repository package*](https://aur.archlinux.org/packages/python-pbar/) made by **MithicSpirit**.
## Additional Credits
| User | Task |
|------------|---------------|
| DrMeepster | Type Checking |
%package help
Summary: Development documents and examples for PBar2
Provides: python3-PBar2-doc
%description help
### PBar is a small Python library to display highly customizable progress bars on the terminal easily. Contributions are welcome!
https://user-images.githubusercontent.com/48654552/140072905-f83a1ff4-fba7-481d-925d-727caed6c3e8.mp4
More examples
https://user-images.githubusercontent.com/48654552/148692560-87e005f7-076a-48cc-9ae9-4c168ee040bc.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/relative_pos.py)
https://user-images.githubusercontent.com/48654552/134776865-c7516cf1-0c66-44da-ae2c-f2cbedd2527c.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/anim.py)
https://user-images.githubusercontent.com/48654552/137568056-aafa1ba1-35c2-4ecd-84f8-99ca0093cab5.mp4
Source available [here.](https://github.com/DarviL82/PBar/blob/main/resources/examples/conds.py)
## Wiki
Please visit the different wiki pages available **[here](https://github.com/DarviL82/PBar/wiki)** to see all the features of this package!
## Requirements
- Python 3.9+
- A terminal that can display VT100 sequences and escape codes such as `\v`.
Windows CMD and PowerShell do not support some of these entirely, though Windows Terminal does.
## Installation
### Pip
PBar is available on the *Python Package Index*:
`pip install pbar2`
You can also install this package through *GitHub* with pip:
`pip install git+https://github.com/DarviL82/PBar`
For uninstalling:
`pip uninstall pbar2`
### AUR
There is also an [*Arch User Repository package*](https://aur.archlinux.org/packages/python-pbar/) made by **MithicSpirit**.
## Additional Credits
| User | Task |
|------------|---------------|
| DrMeepster | Type Checking |
%prep
%autosetup -n PBar2-2.2.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PBar2 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.2.2-1
- Package Spec generated