%global _empty_manifest_terminate_build 0
Name:		python-csbdeep
Version:	0.7.3
Release:	1
Summary:	CSBDeep - a toolbox for Content-aware Image Restoration (CARE)
License:	BSD 3-Clause License
URL:		http://csbdeep.bioimagecomputing.com/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ce/51/46132795844348e19a77ce4fb0201e4339d0e14956666ff22f6b82e0d6f6/csbdeep-0.7.3.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-matplotlib
Requires:	python3-six
Requires:	python3-tifffile
Requires:	python3-tqdm
Requires:	python3-packaging
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-pytest
Requires:	python3-keras
Requires:	python3-protobuf

%description
[![PyPI version](https://badge.fury.io/py/csbdeep.svg)](https://pypi.org/project/csbdeep)
[![Anaconda-Server Badge](https://anaconda.org/conda-forge/csbdeep/badges/version.svg)](https://anaconda.org/conda-forge/csbdeep)
[![Test](https://github.com/CSBDeep/CSBDeep/workflows/Test/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3ATest)
[![Test (PyPI)](https://github.com/CSBDeep/CSBDeep/workflows/Test%20(PyPI)/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3A%22Test+%28PyPI%29%22)
[![Test (Legacy)](https://github.com/CSBDeep/CSBDeep/workflows/Test%20(Legacy)/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3A%22Test+%28Legacy%29%22)

# CSBDeep – a toolbox for CARE

This is the CSBDeep Python package, which provides a toolbox for content-aware restoration of fluorescence microscopy images (CARE), based on deep learning via Keras and TensorFlow.

Please see the documentation at http://csbdeep.bioimagecomputing.com/doc/.




%package -n python3-csbdeep
Summary:	CSBDeep - a toolbox for Content-aware Image Restoration (CARE)
Provides:	python-csbdeep
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-csbdeep
[![PyPI version](https://badge.fury.io/py/csbdeep.svg)](https://pypi.org/project/csbdeep)
[![Anaconda-Server Badge](https://anaconda.org/conda-forge/csbdeep/badges/version.svg)](https://anaconda.org/conda-forge/csbdeep)
[![Test](https://github.com/CSBDeep/CSBDeep/workflows/Test/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3ATest)
[![Test (PyPI)](https://github.com/CSBDeep/CSBDeep/workflows/Test%20(PyPI)/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3A%22Test+%28PyPI%29%22)
[![Test (Legacy)](https://github.com/CSBDeep/CSBDeep/workflows/Test%20(Legacy)/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3A%22Test+%28Legacy%29%22)

# CSBDeep – a toolbox for CARE

This is the CSBDeep Python package, which provides a toolbox for content-aware restoration of fluorescence microscopy images (CARE), based on deep learning via Keras and TensorFlow.

Please see the documentation at http://csbdeep.bioimagecomputing.com/doc/.




%package help
Summary:	Development documents and examples for csbdeep
Provides:	python3-csbdeep-doc
%description help
[![PyPI version](https://badge.fury.io/py/csbdeep.svg)](https://pypi.org/project/csbdeep)
[![Anaconda-Server Badge](https://anaconda.org/conda-forge/csbdeep/badges/version.svg)](https://anaconda.org/conda-forge/csbdeep)
[![Test](https://github.com/CSBDeep/CSBDeep/workflows/Test/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3ATest)
[![Test (PyPI)](https://github.com/CSBDeep/CSBDeep/workflows/Test%20(PyPI)/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3A%22Test+%28PyPI%29%22)
[![Test (Legacy)](https://github.com/CSBDeep/CSBDeep/workflows/Test%20(Legacy)/badge.svg)](https://github.com/CSBDeep/CSBDeep/actions?query=workflow%3A%22Test+%28Legacy%29%22)

# CSBDeep – a toolbox for CARE

This is the CSBDeep Python package, which provides a toolbox for content-aware restoration of fluorescence microscopy images (CARE), based on deep learning via Keras and TensorFlow.

Please see the documentation at http://csbdeep.bioimagecomputing.com/doc/.




%prep
%autosetup -n csbdeep-0.7.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-csbdeep -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.3-1
- Package Spec generated