%global _empty_manifest_terminate_build 0
Name: python-drf-yasg-stubs
Version: 0.1.4
Release: 1
Summary: Typing stubs for drf-yasg library (PEP 484 stubs for Mypy and PyCharm)
License: MIT
URL: https://github.com/intgr/drf-yasg-stubs
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0d/a4/f5795fbec2671afda4ae8d1e68aec0fde741e074a00282a592c639b716ce/drf-yasg-stubs-0.1.4.tar.gz
BuildArch: noarch
%description
# Typing stubs for drf-yasg library
[](https://badge.fury.io/py/drf-yasg-stubs)
[](https://github.com/intgr/drf-yasg-stubs/actions?query=workflow:Tests)
PEP 484 type stubs for Mypy and PyCharm.
This package contains type stubs to provide more precise static types and
type inference for
[drf-yasg](https://drf-yasg.readthedocs.io/en/stable/), the OpenAPI/Swagger
generator for Django REST Framework.
## Installation
```bash
pip install drf-yasg-stubs
```
That's all, run Mypy and it should be able to pick up these stubs.
## Changelog
#### 0.1.4 (2021-06-29)
* Allow passing `request_body=no_body` to `swagger_auto_schema` (#14)
Contributed by Étienne Noss @etene
#### 0.1.3 (2021-01-15)
* Add re-exports to `inspectors/__init__.py` (#13)
* get_schema_view() now expects list arguments instead of tuple, as in
drf-yasg 1.20 (#11)
* Type hints for OpenAPISchemaGenerator (#10)
#### 0.1.2 (2020-08-19)
* Fixed get_schema_view() arguments authentication_classes, permission_classes (#6)
#### 0.1.1 (2020-08-18)
* Fixed SchemaView method annotations (#2)
* Fixed @swagger_serializer_method decorator hints
* Improved hints for EndpointEnumerator, OpenAPISchemaGenerator
#### 0.1.0 (2020-01-13)
* Initial release
## Development
Release process: https://twine.readthedocs.io/en/stable/#using-twine
* docker build --tag=drf-yasg-stubs .
* docker run --rm -it drf-yasg-stubs twine upload 'dist/*'
* Create tag at https://github.com/intgr/drf-yasg-stubs/releases/new
%package -n python3-drf-yasg-stubs
Summary: Typing stubs for drf-yasg library (PEP 484 stubs for Mypy and PyCharm)
Provides: python-drf-yasg-stubs
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-drf-yasg-stubs
# Typing stubs for drf-yasg library
[](https://badge.fury.io/py/drf-yasg-stubs)
[](https://github.com/intgr/drf-yasg-stubs/actions?query=workflow:Tests)
PEP 484 type stubs for Mypy and PyCharm.
This package contains type stubs to provide more precise static types and
type inference for
[drf-yasg](https://drf-yasg.readthedocs.io/en/stable/), the OpenAPI/Swagger
generator for Django REST Framework.
## Installation
```bash
pip install drf-yasg-stubs
```
That's all, run Mypy and it should be able to pick up these stubs.
## Changelog
#### 0.1.4 (2021-06-29)
* Allow passing `request_body=no_body` to `swagger_auto_schema` (#14)
Contributed by Étienne Noss @etene
#### 0.1.3 (2021-01-15)
* Add re-exports to `inspectors/__init__.py` (#13)
* get_schema_view() now expects list arguments instead of tuple, as in
drf-yasg 1.20 (#11)
* Type hints for OpenAPISchemaGenerator (#10)
#### 0.1.2 (2020-08-19)
* Fixed get_schema_view() arguments authentication_classes, permission_classes (#6)
#### 0.1.1 (2020-08-18)
* Fixed SchemaView method annotations (#2)
* Fixed @swagger_serializer_method decorator hints
* Improved hints for EndpointEnumerator, OpenAPISchemaGenerator
#### 0.1.0 (2020-01-13)
* Initial release
## Development
Release process: https://twine.readthedocs.io/en/stable/#using-twine
* docker build --tag=drf-yasg-stubs .
* docker run --rm -it drf-yasg-stubs twine upload 'dist/*'
* Create tag at https://github.com/intgr/drf-yasg-stubs/releases/new
%package help
Summary: Development documents and examples for drf-yasg-stubs
Provides: python3-drf-yasg-stubs-doc
%description help
# Typing stubs for drf-yasg library
[](https://badge.fury.io/py/drf-yasg-stubs)
[](https://github.com/intgr/drf-yasg-stubs/actions?query=workflow:Tests)
PEP 484 type stubs for Mypy and PyCharm.
This package contains type stubs to provide more precise static types and
type inference for
[drf-yasg](https://drf-yasg.readthedocs.io/en/stable/), the OpenAPI/Swagger
generator for Django REST Framework.
## Installation
```bash
pip install drf-yasg-stubs
```
That's all, run Mypy and it should be able to pick up these stubs.
## Changelog
#### 0.1.4 (2021-06-29)
* Allow passing `request_body=no_body` to `swagger_auto_schema` (#14)
Contributed by Étienne Noss @etene
#### 0.1.3 (2021-01-15)
* Add re-exports to `inspectors/__init__.py` (#13)
* get_schema_view() now expects list arguments instead of tuple, as in
drf-yasg 1.20 (#11)
* Type hints for OpenAPISchemaGenerator (#10)
#### 0.1.2 (2020-08-19)
* Fixed get_schema_view() arguments authentication_classes, permission_classes (#6)
#### 0.1.1 (2020-08-18)
* Fixed SchemaView method annotations (#2)
* Fixed @swagger_serializer_method decorator hints
* Improved hints for EndpointEnumerator, OpenAPISchemaGenerator
#### 0.1.0 (2020-01-13)
* Initial release
## Development
Release process: https://twine.readthedocs.io/en/stable/#using-twine
* docker build --tag=drf-yasg-stubs .
* docker run --rm -it drf-yasg-stubs twine upload 'dist/*'
* Create tag at https://github.com/intgr/drf-yasg-stubs/releases/new
%prep
%autosetup -n drf-yasg-stubs-0.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-drf-yasg-stubs -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.4-1
- Package Spec generated