%global _empty_manifest_terminate_build 0
Name: python-botw-havok
Version: 0.3.18
Release: 1
Summary: A library for manipulating Breath of the Wild Havok packfiles
License: GNU General Public License v3 or later (GPLv3+)
URL: https://github.com/krenyy/botw_havok
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/f6/c222ba63f5aa97d260dfb7560ec1a251a4164a564fdc3b0e5a95dd64c687/botw_havok-0.3.18.tar.gz
BuildArch: noarch
Requires: python3-colorama
Requires: python3-numpy
Requires: python3-oead
%description
This library comes with these commands:
* `hk_to_json`: Havok packfile -> JSON
* `json_to_hk`: JSON -> Havok packfile
* `hk_compare`: Compare two or more packfiles
* `hkrb_extract`: Extract shapes from Static Compound files by HashId
* `hksc_to_hkrb`: Convert all Static Compound shapes into a single HKRB
%package -n python3-botw-havok
Summary: A library for manipulating Breath of the Wild Havok packfiles
Provides: python-botw-havok
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-botw-havok
This library comes with these commands:
* `hk_to_json`: Havok packfile -> JSON
* `json_to_hk`: JSON -> Havok packfile
* `hk_compare`: Compare two or more packfiles
* `hkrb_extract`: Extract shapes from Static Compound files by HashId
* `hksc_to_hkrb`: Convert all Static Compound shapes into a single HKRB
%package help
Summary: Development documents and examples for botw-havok
Provides: python3-botw-havok-doc
%description help
This library comes with these commands:
* `hk_to_json`: Havok packfile -> JSON
* `json_to_hk`: JSON -> Havok packfile
* `hk_compare`: Compare two or more packfiles
* `hkrb_extract`: Extract shapes from Static Compound files by HashId
* `hksc_to_hkrb`: Convert all Static Compound shapes into a single HKRB
%prep
%autosetup -n botw-havok-0.3.18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-botw-havok -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.3.18-1
- Package Spec generated