%global _empty_manifest_terminate_build 0
Name: python-pdb-profiling
Version: 0.4.4
Release: 1
Summary: Profiling Protein Structures from Protein Data Bank and integrate various resources.🏄♂️
License: MIT
URL: https://github.com/NatureGeorge/pdb-profiling
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e1/47/613f1ea5cb7b8bd7dc4dd2af58f678ec82234fb2df62755d22e3958cfa29/pdb_profiling-0.4.4.tar.gz
BuildArch: noarch
%description
# pdb-profiling
[](https://zenodo.org/badge/latestdoi/247475852)
[](https://github.com/naturegeorge/pdb-profiling/blob/master/LICENSE)
[](https://pypi.org/project/pdb-profiling/)
[](https://github.com/naturegeorge/pdb-profiling/blob/master/pdb_profiling/__init__.py)
[](https://pypi.org/project/pdb-profiling/)
[](https://github.com/NatureGeorge/pdb-profiling/releases/)
[](https://github.com/naturegeorge/pdb-profiling)
[](https://coveralls.io/github/NatureGeorge/pdb-profiling?branch=master)

Profiling Protein Structures from Protein Data Bank and integrate various resources.
## Features
* `Collection`: Implement various API to collect the well-organized metadata of PDB in real time.
* `Integration`: Provide a unified call for API-interface and return-data-form as well as subsequent data processing.
* `Detection`: Reorganize metadata to evaluate a PDB structure in Entry-Assembly/Model-Entity-Chain-Residue level and integrated with UniProt-KB.
* `Interaction`: Include UniProt Isoform Interaction in Asymmetric unit plus Biological Assembly level.
* `Selection`: Define the representative set of PDB structures in Monomeric|Homomeric|Heteromeric states.
* `Mapping`: Provide interface for both entry-identifier/accession-level and residue-level bidirectional mapping.
## Install
> Notice: require Python Environment >= 3.7, Platform Independent
Install by `pip` command.
### *Before your Installation
* Make sure that your 64-bit machine is installed with 64-bit Python.
* To avoid some unexpected issues, you should upgrade your `pip` beforehand:
```bash
python -m pip install --upgrade pip
```
### Official Installation
```bash
python -m pip install pdb-profiling
```
If you have already installed an older version of `pdb-profiling`, use the following command to install the latest version:
```bash
python -m pip install --upgrade pdb-profiling
```
### Build From Source (optional, for non-windows environment)
```bash
python -m pip install cython
python -m pip install numpy
git clone https://github.com/NatureGeorge/pdb-profiling.git
python setup.py build_ext --inplace # Need GCC or Other Compiler For C
python setup.py install # or "sudo python setup.py install" or "python setup.py install --user"
```
## Documentation
## Examples
### Basic Usage
* [Command Line Example](https://github.com/NatureGeorge/pdb-profiling/discussions/2)
* [Retrieve Bound Molecule Data From PDBe](https://github.com/NatureGeorge/pdb-profiling/discussions/3)
* ...
### Large-Scale-Example
* [ExAC](https://github.com/NatureGeorge/pdb-profiling/blob/master/examples/exac_example.md)
## Resources
* PDBe Entry-Based API
* PDBe Aggregated API (PDBe Graph API)
* PDBe ModelServer API
* SWISS-MODEL Repository API
* UniProt API
* EBI Proteins API
* RCSB Data API
* RCSB Search API
* Eutils API (minimum usage)
* ...
> click [here](https://pdb-profiling.netlify.app/docs/5-reference/) for more details
## Related Resources
> Using similar data resources but meant to achieve different goals.
Click to view
* `RCSB`: [Build Customize Tabular Reports of PDB Data](https://www.rcsb.org/news?year=2020&article=5f6529e207302466657ec0e9&feature=true)
* [MolArt](https://github.com/davidhoksza/MolArt)
## Copyright Notice
This project is developed by [Zefeng Zhu](https://github.com/NatureGeorge) and hold by [Minghui Group](https://lilab.jysw.suda.edu.cn/).
## License
The `pdb_profiling.cython.py_qcprot` module is derived from the [cython wrapper contributed by Bernhard Thiel](https://github.com/Bernhard10/py_qcprot) and is distributed under the terms of a BSD-3-Clause License. And it also contains the dependent C-code from written by Pu Liu and Douglas Theobald (with slight modification by Bernhard Thiel) and is licensed under a BSD-3-Clause License.
The `pdb_profiling` is distributed under the terms of the MIT License.
%package -n python3-pdb-profiling
Summary: Profiling Protein Structures from Protein Data Bank and integrate various resources.🏄♂️
Provides: python-pdb-profiling
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pdb-profiling
# pdb-profiling
[](https://zenodo.org/badge/latestdoi/247475852)
[](https://github.com/naturegeorge/pdb-profiling/blob/master/LICENSE)
[](https://pypi.org/project/pdb-profiling/)
[](https://github.com/naturegeorge/pdb-profiling/blob/master/pdb_profiling/__init__.py)
[](https://pypi.org/project/pdb-profiling/)
[](https://github.com/NatureGeorge/pdb-profiling/releases/)
[](https://github.com/naturegeorge/pdb-profiling)
[](https://coveralls.io/github/NatureGeorge/pdb-profiling?branch=master)

Profiling Protein Structures from Protein Data Bank and integrate various resources.
## Features
* `Collection`: Implement various API to collect the well-organized metadata of PDB in real time.
* `Integration`: Provide a unified call for API-interface and return-data-form as well as subsequent data processing.
* `Detection`: Reorganize metadata to evaluate a PDB structure in Entry-Assembly/Model-Entity-Chain-Residue level and integrated with UniProt-KB.
* `Interaction`: Include UniProt Isoform Interaction in Asymmetric unit plus Biological Assembly level.
* `Selection`: Define the representative set of PDB structures in Monomeric|Homomeric|Heteromeric states.
* `Mapping`: Provide interface for both entry-identifier/accession-level and residue-level bidirectional mapping.
## Install
> Notice: require Python Environment >= 3.7, Platform Independent
Install by `pip` command.
### *Before your Installation
* Make sure that your 64-bit machine is installed with 64-bit Python.
* To avoid some unexpected issues, you should upgrade your `pip` beforehand:
```bash
python -m pip install --upgrade pip
```
### Official Installation
```bash
python -m pip install pdb-profiling
```
If you have already installed an older version of `pdb-profiling`, use the following command to install the latest version:
```bash
python -m pip install --upgrade pdb-profiling
```
### Build From Source (optional, for non-windows environment)
```bash
python -m pip install cython
python -m pip install numpy
git clone https://github.com/NatureGeorge/pdb-profiling.git
python setup.py build_ext --inplace # Need GCC or Other Compiler For C
python setup.py install # or "sudo python setup.py install" or "python setup.py install --user"
```
## Documentation
## Examples
### Basic Usage
* [Command Line Example](https://github.com/NatureGeorge/pdb-profiling/discussions/2)
* [Retrieve Bound Molecule Data From PDBe](https://github.com/NatureGeorge/pdb-profiling/discussions/3)
* ...
### Large-Scale-Example
* [ExAC](https://github.com/NatureGeorge/pdb-profiling/blob/master/examples/exac_example.md)
## Resources
* PDBe Entry-Based API
* PDBe Aggregated API (PDBe Graph API)
* PDBe ModelServer API
* SWISS-MODEL Repository API
* UniProt API
* EBI Proteins API
* RCSB Data API
* RCSB Search API
* Eutils API (minimum usage)
* ...
> click [here](https://pdb-profiling.netlify.app/docs/5-reference/) for more details
## Related Resources
> Using similar data resources but meant to achieve different goals.
Click to view
* `RCSB`: [Build Customize Tabular Reports of PDB Data](https://www.rcsb.org/news?year=2020&article=5f6529e207302466657ec0e9&feature=true)
* [MolArt](https://github.com/davidhoksza/MolArt)
## Copyright Notice
This project is developed by [Zefeng Zhu](https://github.com/NatureGeorge) and hold by [Minghui Group](https://lilab.jysw.suda.edu.cn/).
## License
The `pdb_profiling.cython.py_qcprot` module is derived from the [cython wrapper contributed by Bernhard Thiel](https://github.com/Bernhard10/py_qcprot) and is distributed under the terms of a BSD-3-Clause License. And it also contains the dependent C-code from written by Pu Liu and Douglas Theobald (with slight modification by Bernhard Thiel) and is licensed under a BSD-3-Clause License.
The `pdb_profiling` is distributed under the terms of the MIT License.
%package help
Summary: Development documents and examples for pdb-profiling
Provides: python3-pdb-profiling-doc
%description help
# pdb-profiling
[](https://zenodo.org/badge/latestdoi/247475852)
[](https://github.com/naturegeorge/pdb-profiling/blob/master/LICENSE)
[](https://pypi.org/project/pdb-profiling/)
[](https://github.com/naturegeorge/pdb-profiling/blob/master/pdb_profiling/__init__.py)
[](https://pypi.org/project/pdb-profiling/)
[](https://github.com/NatureGeorge/pdb-profiling/releases/)
[](https://github.com/naturegeorge/pdb-profiling)
[](https://coveralls.io/github/NatureGeorge/pdb-profiling?branch=master)

Profiling Protein Structures from Protein Data Bank and integrate various resources.
## Features
* `Collection`: Implement various API to collect the well-organized metadata of PDB in real time.
* `Integration`: Provide a unified call for API-interface and return-data-form as well as subsequent data processing.
* `Detection`: Reorganize metadata to evaluate a PDB structure in Entry-Assembly/Model-Entity-Chain-Residue level and integrated with UniProt-KB.
* `Interaction`: Include UniProt Isoform Interaction in Asymmetric unit plus Biological Assembly level.
* `Selection`: Define the representative set of PDB structures in Monomeric|Homomeric|Heteromeric states.
* `Mapping`: Provide interface for both entry-identifier/accession-level and residue-level bidirectional mapping.
## Install
> Notice: require Python Environment >= 3.7, Platform Independent
Install by `pip` command.
### *Before your Installation
* Make sure that your 64-bit machine is installed with 64-bit Python.
* To avoid some unexpected issues, you should upgrade your `pip` beforehand:
```bash
python -m pip install --upgrade pip
```
### Official Installation
```bash
python -m pip install pdb-profiling
```
If you have already installed an older version of `pdb-profiling`, use the following command to install the latest version:
```bash
python -m pip install --upgrade pdb-profiling
```
### Build From Source (optional, for non-windows environment)
```bash
python -m pip install cython
python -m pip install numpy
git clone https://github.com/NatureGeorge/pdb-profiling.git
python setup.py build_ext --inplace # Need GCC or Other Compiler For C
python setup.py install # or "sudo python setup.py install" or "python setup.py install --user"
```
## Documentation
## Examples
### Basic Usage
* [Command Line Example](https://github.com/NatureGeorge/pdb-profiling/discussions/2)
* [Retrieve Bound Molecule Data From PDBe](https://github.com/NatureGeorge/pdb-profiling/discussions/3)
* ...
### Large-Scale-Example
* [ExAC](https://github.com/NatureGeorge/pdb-profiling/blob/master/examples/exac_example.md)
## Resources
* PDBe Entry-Based API
* PDBe Aggregated API (PDBe Graph API)
* PDBe ModelServer API
* SWISS-MODEL Repository API
* UniProt API
* EBI Proteins API
* RCSB Data API
* RCSB Search API
* Eutils API (minimum usage)
* ...
> click [here](https://pdb-profiling.netlify.app/docs/5-reference/) for more details
## Related Resources
> Using similar data resources but meant to achieve different goals.
Click to view
* `RCSB`: [Build Customize Tabular Reports of PDB Data](https://www.rcsb.org/news?year=2020&article=5f6529e207302466657ec0e9&feature=true)
* [MolArt](https://github.com/davidhoksza/MolArt)
## Copyright Notice
This project is developed by [Zefeng Zhu](https://github.com/NatureGeorge) and hold by [Minghui Group](https://lilab.jysw.suda.edu.cn/).
## License
The `pdb_profiling.cython.py_qcprot` module is derived from the [cython wrapper contributed by Bernhard Thiel](https://github.com/Bernhard10/py_qcprot) and is distributed under the terms of a BSD-3-Clause License. And it also contains the dependent C-code from written by Pu Liu and Douglas Theobald (with slight modification by Bernhard Thiel) and is licensed under a BSD-3-Clause License.
The `pdb_profiling` is distributed under the terms of the MIT License.
%prep
%autosetup -n pdb-profiling-0.4.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pdb-profiling -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.4.4-1
- Package Spec generated