%global _empty_manifest_terminate_build 0
Name: python-gmsh-interop
Version: 2021.1.1
Release: 1
Summary: A parser for GMSH's .msh format
License: MIT
URL: http://github.com/inducer/gmsh_interop
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/b0/79829dd4fd5745b859d3314f5b1854e609929107655d2da6cc4b317e3375/gmsh_interop-2021.1.1.tar.gz
BuildArch: noarch
%description
This package allows Python to interoperate with the `gmsh `_
mesh generator.
This package contains:
* ``gmsh_interop.reader`` to read gmsh's ``.msh`` file format.
* ``gmsh_interop.runner`` to run gmsh under program control and process its output.
Its contents was extracted from `meshpy `__
to escape its obnoxious licensing.
Links:
* `Github `_
* `Python package index `_
* `Documentation `_
%package -n python3-gmsh-interop
Summary: A parser for GMSH's .msh format
Provides: python-gmsh-interop
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gmsh-interop
This package allows Python to interoperate with the `gmsh `_
mesh generator.
This package contains:
* ``gmsh_interop.reader`` to read gmsh's ``.msh`` file format.
* ``gmsh_interop.runner`` to run gmsh under program control and process its output.
Its contents was extracted from `meshpy `__
to escape its obnoxious licensing.
Links:
* `Github `_
* `Python package index `_
* `Documentation `_
%package help
Summary: Development documents and examples for gmsh-interop
Provides: python3-gmsh-interop-doc
%description help
This package allows Python to interoperate with the `gmsh `_
mesh generator.
This package contains:
* ``gmsh_interop.reader`` to read gmsh's ``.msh`` file format.
* ``gmsh_interop.runner`` to run gmsh under program control and process its output.
Its contents was extracted from `meshpy `__
to escape its obnoxious licensing.
Links:
* `Github `_
* `Python package index `_
* `Documentation `_
%prep
%autosetup -n gmsh-interop-2021.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gmsh-interop -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2021.1.1-1
- Package Spec generated