%global _empty_manifest_terminate_build 0
Name:		python-setuptools_cython
Version:	0.2.1
Release:	1
Summary:	Cython setuptools integration
License:	http://www.gnu.org/licenses/gpl-2.0.html
URL:		http://pypi.python.org/pypi/setuptools_cython/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/34/de/d21aeeaccc38f3753d06a30e2eabcf56d39eb345cdc6a8e4610d69fef13f/setuptools_cython-0.2.1.tar.gz
BuildArch:	noarch


%description
Use setuptools, add setuptools_cython to your setup_requires.
Some verbatim code is required to make Extension behave as expected.

%package -n python3-setuptools_cython
Summary:	Cython setuptools integration
Provides:	python-setuptools_cython
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-setuptools_cython
Use setuptools, add setuptools_cython to your setup_requires.
Some verbatim code is required to make Extension behave as expected.

%package help
Summary:	Development documents and examples for setuptools_cython
Provides:	python3-setuptools_cython-doc
%description help
Use setuptools, add setuptools_cython to your setup_requires.
Some verbatim code is required to make Extension behave as expected.

%prep
%autosetup -n setuptools_cython-0.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-setuptools_cython -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
- Package Spec generated