%global _empty_manifest_terminate_build 0
Name:		python-pkcs11
Version:	1.0.4
Release:	1
Summary:	Python object-oriented wrapper for PKCS11 (Cryptoki) dlls
License:	GPL
URL:		http://www.ultraemail.net:8000/~jbj1/#pkcs11
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/37/0c/a5244429b0376660fb6267ad02515cbfc3e171bc5d493410d7d5d7f79d42/pkcs11-1.0.4.zip
BuildArch:	noarch


%description
The C++ extension module provides a nice object-oriented wrapper around a
binary PKCS11 module such as the PSM which comes as part of mozilla or the
various modules supplied by vendors of hardware crypto tokens.
        
The interface is somewhat limited as I only covered enough of it to handle the
functions defined in the module I care most about (for the Dallas
Semiconductor Java iButton) which for actual crypto operations only defines
signing hashes and unwrapping keys (browser handles the rest).

%package -n python3-pkcs11
Summary:	Python object-oriented wrapper for PKCS11 (Cryptoki) dlls
Provides:	python-pkcs11
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pkcs11
The C++ extension module provides a nice object-oriented wrapper around a
binary PKCS11 module such as the PSM which comes as part of mozilla or the
various modules supplied by vendors of hardware crypto tokens.
        
The interface is somewhat limited as I only covered enough of it to handle the
functions defined in the module I care most about (for the Dallas
Semiconductor Java iButton) which for actual crypto operations only defines
signing hashes and unwrapping keys (browser handles the rest).

%package help
Summary:	Development documents and examples for pkcs11
Provides:	python3-pkcs11-doc
%description help
The C++ extension module provides a nice object-oriented wrapper around a
binary PKCS11 module such as the PSM which comes as part of mozilla or the
various modules supplied by vendors of hardware crypto tokens.
        
The interface is somewhat limited as I only covered enough of it to handle the
functions defined in the module I care most about (for the Dallas
Semiconductor Java iButton) which for actual crypto operations only defines
signing hashes and unwrapping keys (browser handles the rest).

%prep
%autosetup -n pkcs11-1.0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pkcs11 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.4-1
- Package Spec generated