%global _empty_manifest_terminate_build 0
Name: python-autodoc-pydantic
Version: 1.8.0
Release: 1
Summary: Seamlessly integrate pydantic models in your Sphinx documentation.
License: MIT
URL: https://github.com/mansenfranzen/autodoc_pydantic
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e4/05/a9ba1008071a06deab177f820da772353645caeb0963120f6e5406351b3e/autodoc_pydantic-1.8.0.tar.gz
BuildArch: noarch
Requires: python3-Sphinx
Requires: python3-pydantic
Requires: python3-sphinx-rtd-theme
Requires: python3-sphinx-tabs
Requires: python3-sphinx-copybutton
Requires: python3-sphinxcontrib-mermaid
Requires: python3-pytest
Requires: python3-coverage
Requires: python3-flake8
Requires: python3-tox
%description
![Autodoc Pydantic](https://raw.githubusercontent.com/mansenfranzen/autodoc_pydantic/main/docs/source/material/logo_black.svg)
[![PyPI version](https://img.shields.io/pypi/v/autodoc_pydantic?style=for-the-badge)](https://pypi.org/project/autodoc-pydantic/)
![Python](https://img.shields.io/badge/python-3.6+-blue.svg?style=for-the-badge)
[![Master](https://img.shields.io/github/workflow/status/mansenfranzen/autodoc_pydantic/ci?style=for-the-badge)](https://github.com/mansenfranzen/autodoc_pydantic/actions/workflows/tests.yml)
[![Coverage](https://img.shields.io/codecov/c/gh/mansenfranzen/autodoc_pydantic?style=for-the-badge)](https://app.codecov.io/gh/mansenfranzen/autodoc_pydantic)
[![Downloads](https://img.shields.io/pypi/dm/autodoc_pydantic?color=fe7d37&style=for-the-badge)](https://pypistats.org/packages/autodoc-pydantic)
[![All Contributors](https://img.shields.io/badge/all_contributors-29-orange.svg?style=for-the-badge)](#contributors)
You love [pydantic](https://pydantic-docs.helpmanual.io/) β€ and you want to
document your models and configuration settings with [sphinx](https://www.sphinx-doc.org/en/master/)?
Perfect, let's go. But wait, sphinx' [autodoc](https://www.sphinx-doc.org/en/master/usage/extensions/autodoc.html)
does not integrate too well with pydantic models π.
Don't worry - just `pip install autodoc_pydantic` βΊ.
## Features
- π¬ provides default values, alias and constraints for model fields
- π adds hyperlinks between validators and corresponding fields
- π includes collapsable model json schema
- π natively integrates with autodoc and autosummary extensions
- π defines explicit pydantic prefixes for models, settings, fields, validators and model config
- π shows summary section for model configuration, fields and validators
- π hides overloaded and redundant model class signature
- π sorts fields, validators and model config within models by type
- π Supports `pydantic >= 1.5.0` and `sphinx >= 3.4.0`
### Comparison between autodoc sphinx and autodoc pydantic
[![Comparison](https://raw.githubusercontent.com/mansenfranzen/autodoc_pydantic/main/docs/source/material/example_comparison_v1.0.0.gif)](https://autodoc-pydantic.readthedocs.io/en/latest/examples.html#default-configuration)
To see those features in action, jump over to the [example documentation](https://autodoc-pydantic.readthedocs.io/en/stable/users/examples.html#default-configuration) to compare
the appearance of standard sphinx autodoc with *autodoc_pydantic*.
## Documentation
For more details, please visit the official [documentation](https://autodoc-pydantic.readthedocs.io/en/stable/):
- [Installation](https://autodoc-pydantic.readthedocs.io/en/stable/users/installation.html)
- [Configuration](https://autodoc-pydantic.readthedocs.io/en/stable/users/configuration.html)
- [Usage](https://autodoc-pydantic.readthedocs.io/en/stable/users/usage.html)
- [Examples](https://autodoc-pydantic.readthedocs.io/en/stable/users/examples.html)
## Acknowledgements
Thanks to great open source projects [sphinx](https://www.sphinx-doc.org/en/master/),
[pydantic](https://pydantic-docs.helpmanual.io/) and
[poetry](https://python-poetry.org/) (and so many more) β€ in addition to the following contributors:
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome!
%package -n python3-autodoc-pydantic
Summary: Seamlessly integrate pydantic models in your Sphinx documentation.
Provides: python-autodoc-pydantic
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-autodoc-pydantic
![Autodoc Pydantic](https://raw.githubusercontent.com/mansenfranzen/autodoc_pydantic/main/docs/source/material/logo_black.svg)
[![PyPI version](https://img.shields.io/pypi/v/autodoc_pydantic?style=for-the-badge)](https://pypi.org/project/autodoc-pydantic/)
![Python](https://img.shields.io/badge/python-3.6+-blue.svg?style=for-the-badge)
[![Master](https://img.shields.io/github/workflow/status/mansenfranzen/autodoc_pydantic/ci?style=for-the-badge)](https://github.com/mansenfranzen/autodoc_pydantic/actions/workflows/tests.yml)
[![Coverage](https://img.shields.io/codecov/c/gh/mansenfranzen/autodoc_pydantic?style=for-the-badge)](https://app.codecov.io/gh/mansenfranzen/autodoc_pydantic)
[![Downloads](https://img.shields.io/pypi/dm/autodoc_pydantic?color=fe7d37&style=for-the-badge)](https://pypistats.org/packages/autodoc-pydantic)
[![All Contributors](https://img.shields.io/badge/all_contributors-29-orange.svg?style=for-the-badge)](#contributors)
You love [pydantic](https://pydantic-docs.helpmanual.io/) β€ and you want to
document your models and configuration settings with [sphinx](https://www.sphinx-doc.org/en/master/)?
Perfect, let's go. But wait, sphinx' [autodoc](https://www.sphinx-doc.org/en/master/usage/extensions/autodoc.html)
does not integrate too well with pydantic models π.
Don't worry - just `pip install autodoc_pydantic` βΊ.
## Features
- π¬ provides default values, alias and constraints for model fields
- π adds hyperlinks between validators and corresponding fields
- π includes collapsable model json schema
- π natively integrates with autodoc and autosummary extensions
- π defines explicit pydantic prefixes for models, settings, fields, validators and model config
- π shows summary section for model configuration, fields and validators
- π hides overloaded and redundant model class signature
- π sorts fields, validators and model config within models by type
- π Supports `pydantic >= 1.5.0` and `sphinx >= 3.4.0`
### Comparison between autodoc sphinx and autodoc pydantic
[![Comparison](https://raw.githubusercontent.com/mansenfranzen/autodoc_pydantic/main/docs/source/material/example_comparison_v1.0.0.gif)](https://autodoc-pydantic.readthedocs.io/en/latest/examples.html#default-configuration)
To see those features in action, jump over to the [example documentation](https://autodoc-pydantic.readthedocs.io/en/stable/users/examples.html#default-configuration) to compare
the appearance of standard sphinx autodoc with *autodoc_pydantic*.
## Documentation
For more details, please visit the official [documentation](https://autodoc-pydantic.readthedocs.io/en/stable/):
- [Installation](https://autodoc-pydantic.readthedocs.io/en/stable/users/installation.html)
- [Configuration](https://autodoc-pydantic.readthedocs.io/en/stable/users/configuration.html)
- [Usage](https://autodoc-pydantic.readthedocs.io/en/stable/users/usage.html)
- [Examples](https://autodoc-pydantic.readthedocs.io/en/stable/users/examples.html)
## Acknowledgements
Thanks to great open source projects [sphinx](https://www.sphinx-doc.org/en/master/),
[pydantic](https://pydantic-docs.helpmanual.io/) and
[poetry](https://python-poetry.org/) (and so many more) β€ in addition to the following contributors:
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome!
%package help
Summary: Development documents and examples for autodoc-pydantic
Provides: python3-autodoc-pydantic-doc
%description help
![Autodoc Pydantic](https://raw.githubusercontent.com/mansenfranzen/autodoc_pydantic/main/docs/source/material/logo_black.svg)
[![PyPI version](https://img.shields.io/pypi/v/autodoc_pydantic?style=for-the-badge)](https://pypi.org/project/autodoc-pydantic/)
![Python](https://img.shields.io/badge/python-3.6+-blue.svg?style=for-the-badge)
[![Master](https://img.shields.io/github/workflow/status/mansenfranzen/autodoc_pydantic/ci?style=for-the-badge)](https://github.com/mansenfranzen/autodoc_pydantic/actions/workflows/tests.yml)
[![Coverage](https://img.shields.io/codecov/c/gh/mansenfranzen/autodoc_pydantic?style=for-the-badge)](https://app.codecov.io/gh/mansenfranzen/autodoc_pydantic)
[![Downloads](https://img.shields.io/pypi/dm/autodoc_pydantic?color=fe7d37&style=for-the-badge)](https://pypistats.org/packages/autodoc-pydantic)
[![All Contributors](https://img.shields.io/badge/all_contributors-29-orange.svg?style=for-the-badge)](#contributors)
You love [pydantic](https://pydantic-docs.helpmanual.io/) β€ and you want to
document your models and configuration settings with [sphinx](https://www.sphinx-doc.org/en/master/)?
Perfect, let's go. But wait, sphinx' [autodoc](https://www.sphinx-doc.org/en/master/usage/extensions/autodoc.html)
does not integrate too well with pydantic models π.
Don't worry - just `pip install autodoc_pydantic` βΊ.
## Features
- π¬ provides default values, alias and constraints for model fields
- π adds hyperlinks between validators and corresponding fields
- π includes collapsable model json schema
- π natively integrates with autodoc and autosummary extensions
- π defines explicit pydantic prefixes for models, settings, fields, validators and model config
- π shows summary section for model configuration, fields and validators
- π hides overloaded and redundant model class signature
- π sorts fields, validators and model config within models by type
- π Supports `pydantic >= 1.5.0` and `sphinx >= 3.4.0`
### Comparison between autodoc sphinx and autodoc pydantic
[![Comparison](https://raw.githubusercontent.com/mansenfranzen/autodoc_pydantic/main/docs/source/material/example_comparison_v1.0.0.gif)](https://autodoc-pydantic.readthedocs.io/en/latest/examples.html#default-configuration)
To see those features in action, jump over to the [example documentation](https://autodoc-pydantic.readthedocs.io/en/stable/users/examples.html#default-configuration) to compare
the appearance of standard sphinx autodoc with *autodoc_pydantic*.
## Documentation
For more details, please visit the official [documentation](https://autodoc-pydantic.readthedocs.io/en/stable/):
- [Installation](https://autodoc-pydantic.readthedocs.io/en/stable/users/installation.html)
- [Configuration](https://autodoc-pydantic.readthedocs.io/en/stable/users/configuration.html)
- [Usage](https://autodoc-pydantic.readthedocs.io/en/stable/users/usage.html)
- [Examples](https://autodoc-pydantic.readthedocs.io/en/stable/users/examples.html)
## Acknowledgements
Thanks to great open source projects [sphinx](https://www.sphinx-doc.org/en/master/),
[pydantic](https://pydantic-docs.helpmanual.io/) and
[poetry](https://python-poetry.org/) (and so many more) β€ in addition to the following contributors:
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome!
%prep
%autosetup -n autodoc-pydantic-1.8.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-autodoc-pydantic -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.8.0-1
- Package Spec generated