%global _empty_manifest_terminate_build 0
Name:		python-pynws
Version:	1.4.1
Release:	1
Summary:	Python library to retrieve observations and forecasts from NWS/NOAA
License:	MIT License
URL:		https://github.com/MatthewFlamm/pynws
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ba/68/00bbf9ba0d09f7e137c8695578dc5f65e5e25f8f37b35645ff272e475eb2/pynws-1.4.1.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-metar

%description
# pynws

A python library to asynchronously retrieve weather observation from NWS/NOAA.

![PyPI - Downloads](https://img.shields.io/pypi/dm/pynws?style=flat-square)

## Example
See [example.py](example.py) for a runnable example.
```python
PHILLY = (39.95, -75.16)
USERID = "testing@address.xyz"

async def example():
    async with aiohttp.ClientSession() as session:
        nws = pynws.SimpleNWS(*PHILLY, USERID, session)
        await nws.set_station()
        await nws.update_observation()
        await nws.update_forecast()
        await nws.update_alerts_forecast_zone()
        print(nws.observation)
        print(nws.forecast[0])
        print(nws.alerts_forecast_zone)
```

## Functionality
pynws exposes the ability to retrieve raw data using `raw_data` module. `Nws` class offers ability to retrieve minimally processed data for a single location.  `SimpleNWS` class offers data caching and several other helpers for interpreting output.


### Units for Observations in SimpleNWS
NWS API does not expose all possible units for observations.  Known units are converted to the following:

|unit type   | known NWS units| pynws unit |
|------------|----------------|------------|
|temperature | degF, degC     | Celsius    |
|pressure    | Pa             | Pascal     |
|speed       | m_s-1, km_h-1  | km_h-1     |
|percent     | percent        | percent    |
|angle       | degree_(angle) | degrees    |
|distance    | m              | meter      |




%package -n python3-pynws
Summary:	Python library to retrieve observations and forecasts from NWS/NOAA
Provides:	python-pynws
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pynws
# pynws

A python library to asynchronously retrieve weather observation from NWS/NOAA.

![PyPI - Downloads](https://img.shields.io/pypi/dm/pynws?style=flat-square)

## Example
See [example.py](example.py) for a runnable example.
```python
PHILLY = (39.95, -75.16)
USERID = "testing@address.xyz"

async def example():
    async with aiohttp.ClientSession() as session:
        nws = pynws.SimpleNWS(*PHILLY, USERID, session)
        await nws.set_station()
        await nws.update_observation()
        await nws.update_forecast()
        await nws.update_alerts_forecast_zone()
        print(nws.observation)
        print(nws.forecast[0])
        print(nws.alerts_forecast_zone)
```

## Functionality
pynws exposes the ability to retrieve raw data using `raw_data` module. `Nws` class offers ability to retrieve minimally processed data for a single location.  `SimpleNWS` class offers data caching and several other helpers for interpreting output.


### Units for Observations in SimpleNWS
NWS API does not expose all possible units for observations.  Known units are converted to the following:

|unit type   | known NWS units| pynws unit |
|------------|----------------|------------|
|temperature | degF, degC     | Celsius    |
|pressure    | Pa             | Pascal     |
|speed       | m_s-1, km_h-1  | km_h-1     |
|percent     | percent        | percent    |
|angle       | degree_(angle) | degrees    |
|distance    | m              | meter      |




%package help
Summary:	Development documents and examples for pynws
Provides:	python3-pynws-doc
%description help
# pynws

A python library to asynchronously retrieve weather observation from NWS/NOAA.

![PyPI - Downloads](https://img.shields.io/pypi/dm/pynws?style=flat-square)

## Example
See [example.py](example.py) for a runnable example.
```python
PHILLY = (39.95, -75.16)
USERID = "testing@address.xyz"

async def example():
    async with aiohttp.ClientSession() as session:
        nws = pynws.SimpleNWS(*PHILLY, USERID, session)
        await nws.set_station()
        await nws.update_observation()
        await nws.update_forecast()
        await nws.update_alerts_forecast_zone()
        print(nws.observation)
        print(nws.forecast[0])
        print(nws.alerts_forecast_zone)
```

## Functionality
pynws exposes the ability to retrieve raw data using `raw_data` module. `Nws` class offers ability to retrieve minimally processed data for a single location.  `SimpleNWS` class offers data caching and several other helpers for interpreting output.


### Units for Observations in SimpleNWS
NWS API does not expose all possible units for observations.  Known units are converted to the following:

|unit type   | known NWS units| pynws unit |
|------------|----------------|------------|
|temperature | degF, degC     | Celsius    |
|pressure    | Pa             | Pascal     |
|speed       | m_s-1, km_h-1  | km_h-1     |
|percent     | percent        | percent    |
|angle       | degree_(angle) | degrees    |
|distance    | m              | meter      |




%prep
%autosetup -n pynws-1.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pynws -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.1-1
- Package Spec generated