%global _empty_manifest_terminate_build 0 Name: python-labelme2coco Version: 0.2.4 Release: 1 Summary: Convert labelme annotations into coco format in one step License: MIT License URL: https://github.com/fcakyon/labelme2coco Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/ee/d2b7186eeb04007794edf49f3105ce3e128add0cb9cbf0ebeb42638fd614/labelme2coco-0.2.4.tar.gz BuildArch: noarch Requires: python3-sahi Requires: python3-jsonschema %description

labelme2coco

downloads pypi version ci fcakyon twitter

A lightweight package for converting your labelme annotations into COCO object detection format.

teaser

## Convert LabelMe annotations to COCO format in one step [labelme](https://github.com/wkentaro/labelme) is a widely used is a graphical image annotation tool that supports classification, segmentation, instance segmentation and object detection formats. However, widely used frameworks/models such as Yolact/Solo, Detectron, MMDetection etc. requires COCO formatted annotations. You can use this package to convert labelme annotations to COCO format. ## Getting started ### Installation ``` pip install -U labelme2coco ``` ### Basic Usage ```python labelme2coco path/to/labelme/dir ``` ```python labelme2coco path/to/labelme/dir --train_split_rate 0.85 ``` ### Advanced Usage ```python # import package import labelme2coco # set directory that contains labelme annotations and image files labelme_folder = "tests/data/labelme_annot" # set export dir export_dir = "tests/data/" # set train split rate train_split_rate = 0.85 # convert labelme annotations to coco labelme2coco.convert(labelme_folder, export_dir, train_split_rate) ``` ```python # import functions from labelme2coco import get_coco_from_labelme_folder, save_json # set labelme training data directory labelme_train_folder = "tests/data/labelme_annot" # set labelme validation data directory labelme_val_folder = "tests/data/labelme_annot" # set path for coco json to be saved export_dir = "tests/data/" # create train coco object train_coco = get_coco_from_labelme_folder(labelme_train_folder) # export train coco json save_json(train_coco.json, export_dir+"train.json") # create val coco object val_coco = get_coco_from_labelme_folder(labelme_val_folder, coco_category_list=train_coco.json_categories) # export val coco json save_json(val_coco.json, export_dir+"val.json") ``` %package -n python3-labelme2coco Summary: Convert labelme annotations into coco format in one step Provides: python-labelme2coco BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-labelme2coco

labelme2coco

downloads pypi version ci fcakyon twitter

A lightweight package for converting your labelme annotations into COCO object detection format.

teaser

## Convert LabelMe annotations to COCO format in one step [labelme](https://github.com/wkentaro/labelme) is a widely used is a graphical image annotation tool that supports classification, segmentation, instance segmentation and object detection formats. However, widely used frameworks/models such as Yolact/Solo, Detectron, MMDetection etc. requires COCO formatted annotations. You can use this package to convert labelme annotations to COCO format. ## Getting started ### Installation ``` pip install -U labelme2coco ``` ### Basic Usage ```python labelme2coco path/to/labelme/dir ``` ```python labelme2coco path/to/labelme/dir --train_split_rate 0.85 ``` ### Advanced Usage ```python # import package import labelme2coco # set directory that contains labelme annotations and image files labelme_folder = "tests/data/labelme_annot" # set export dir export_dir = "tests/data/" # set train split rate train_split_rate = 0.85 # convert labelme annotations to coco labelme2coco.convert(labelme_folder, export_dir, train_split_rate) ``` ```python # import functions from labelme2coco import get_coco_from_labelme_folder, save_json # set labelme training data directory labelme_train_folder = "tests/data/labelme_annot" # set labelme validation data directory labelme_val_folder = "tests/data/labelme_annot" # set path for coco json to be saved export_dir = "tests/data/" # create train coco object train_coco = get_coco_from_labelme_folder(labelme_train_folder) # export train coco json save_json(train_coco.json, export_dir+"train.json") # create val coco object val_coco = get_coco_from_labelme_folder(labelme_val_folder, coco_category_list=train_coco.json_categories) # export val coco json save_json(val_coco.json, export_dir+"val.json") ``` %package help Summary: Development documents and examples for labelme2coco Provides: python3-labelme2coco-doc %description help

labelme2coco

downloads pypi version ci fcakyon twitter

A lightweight package for converting your labelme annotations into COCO object detection format.

teaser

## Convert LabelMe annotations to COCO format in one step [labelme](https://github.com/wkentaro/labelme) is a widely used is a graphical image annotation tool that supports classification, segmentation, instance segmentation and object detection formats. However, widely used frameworks/models such as Yolact/Solo, Detectron, MMDetection etc. requires COCO formatted annotations. You can use this package to convert labelme annotations to COCO format. ## Getting started ### Installation ``` pip install -U labelme2coco ``` ### Basic Usage ```python labelme2coco path/to/labelme/dir ``` ```python labelme2coco path/to/labelme/dir --train_split_rate 0.85 ``` ### Advanced Usage ```python # import package import labelme2coco # set directory that contains labelme annotations and image files labelme_folder = "tests/data/labelme_annot" # set export dir export_dir = "tests/data/" # set train split rate train_split_rate = 0.85 # convert labelme annotations to coco labelme2coco.convert(labelme_folder, export_dir, train_split_rate) ``` ```python # import functions from labelme2coco import get_coco_from_labelme_folder, save_json # set labelme training data directory labelme_train_folder = "tests/data/labelme_annot" # set labelme validation data directory labelme_val_folder = "tests/data/labelme_annot" # set path for coco json to be saved export_dir = "tests/data/" # create train coco object train_coco = get_coco_from_labelme_folder(labelme_train_folder) # export train coco json save_json(train_coco.json, export_dir+"train.json") # create val coco object val_coco = get_coco_from_labelme_folder(labelme_val_folder, coco_category_list=train_coco.json_categories) # export val coco json save_json(val_coco.json, export_dir+"val.json") ``` %prep %autosetup -n labelme2coco-0.2.4 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-labelme2coco -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri May 05 2023 Python_Bot - 0.2.4-1 - Package Spec generated