%global _empty_manifest_terminate_build 0
Name:		python-AsyncDex
Version:	1.1
Release:	1
Summary:	Async MangaDex library
License:	MIT
URL:		https://github.com/PythonCoderAS/AsyncDex
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6c/21/088246b1591586fc1c65a09c169fbbe3b26ccc2522f6637feb17f6689a17/AsyncDex-1.1.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-natsort
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-pytest
Requires:	python3-asynctest
Requires:	python3-pytest-asyncio
Requires:	python3-pytest-recording
Requires:	python3-vcrpy

%description
A wrapper over the Mangadex API that supports authentication and ratelimits.
View full documentation here: https://asyncdex.readthedocs.io/

%package -n python3-AsyncDex
Summary:	Async MangaDex library
Provides:	python-AsyncDex
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-AsyncDex
A wrapper over the Mangadex API that supports authentication and ratelimits.
View full documentation here: https://asyncdex.readthedocs.io/

%package help
Summary:	Development documents and examples for AsyncDex
Provides:	python3-AsyncDex-doc
%description help
A wrapper over the Mangadex API that supports authentication and ratelimits.
View full documentation here: https://asyncdex.readthedocs.io/

%prep
%autosetup -n AsyncDex-1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-AsyncDex -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1-1
- Package Spec generated