%global _empty_manifest_terminate_build 0
Name: python-biosignalsnotebooks
Version: 0.6.10
Release: 1
Summary: A Python package for supporting the external loading and processing of OpenSignals electrophysiological acquisitions.
License: MIT
URL: https://github.com/biosignalsplux/biosignalsnotebooks
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/65/e3/ba9d2a42e09b6444396482c0c04ff2ec806a72261f0611e8a0826f026d78/biosignalsnotebooks-0.6.10.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-matplotlib
Requires: python3-scipy
Requires: python3-h5py
Requires: python3-wget
Requires: python3-datetime
Requires: python3-bokeh
Requires: python3-IPython
Requires: python3-pandas
Requires: python3-nbformat
Requires: python3-ipython
Requires: python3-requests
Requires: python3-libmagic
Requires: python3-magic-bin
Requires: python3-magic
%description
## Description
**biosignalsnotebooks** is a set of documents and a **Python** library to provide programming examples in the form of **Jupyter Notebooks**, as companion to the **OpenSignals** biosignals acquisition tools.
This collection of code samples has the purpose to help users of PLUX Wireless Biosignals systems, such as **BITalino** or **biosignalsplux**, and to the researcher or student interested on recording processing and classifying biosignals. The examples are set on a level of complexity to inspire the users and programmers on how easy some tasks are and that more complex ones can also be achieved, by reusing and recreating some of the examples presented here.
A **Python** library (entitled **biosignalsnotebooks** ) is the base toolbox to support the notebooks and to provide some useful functionalities. It can be installed through pip command, like demonstrated in a [PyPI
](https://pypi.org/project/biosignalsnotebooks/) dedicated page.
In many cases we also point and illustrate with code the usage of other python toolboxes dedicated to biosignal processing.
The notebooks will cover the full topics pipeline of working with biosignals, such as: **Load** a file; **Visualise** the data online and offline, **Pre-Process** a one channel signal or a multi-channel acquisition, **Detect** relevant events in the signals, **Extract** features from many different type of sensors and domains, **Train and Classify** among a set of classes with several machine learning approaches, **Understand** the obtained results with metrics and validations techniques.
These examples are carried in a multitude of biosignals , from ECG, EDA, EMG, Accelerometer, Respiration among many others.
The notebooks have a set of labels to help navigate among topics
, types of signals
, application area
and complexity
level to support the search for particular solutions.
We encourage you to share new example ideas, to pose questions helpdesk@pluxbiosignals.com, and to make improvements or suggestion to this set of notebooks.
**Be inspired on how to make the most of your biosignals!**
## What is **PLUX**
PLUX wireless biosignals is devoted to the creation innovative products for advanced biosignals monitoring platforms
that integrate wearable body sensors combined with wireless connectivity, algorithms and software applications.
We have been perusing the mission of making biosignals as accessible as possible to researchers and students in many areas of application, ranging from biomedical engineering, computer science, human computer interaction, sport sciences, psychology, clinical research among other fields.
## PLUX's Software and Hardware Environment
[**OpenSignals**](https://support.pluxbiosignals.com/knowledge-base/introducing-opensignals-revolution/) is the companion application to *PLUX* devices ([**BITalino**](https://support.pluxbiosignals.com/article-categories/bitalino/) or [**biosignalsplux**](https://support.pluxbiosignals.com/article-categories/biosignalsplux/)) where the users collect visualize an process biosignals in a intuitive user interface. Opensignals is free and can be used also with signals collected from other devices.
In some cases **OpenSignals** provides [*plugins*](https://www.pluxbiosignals.com/collections/software-add-ons) for advanced signals processing operations that automate some of the research process. Some of the plugins are curated and advanced versions of the base notebooks explained in here.
The list of plugins can be found here: https://www.pluxbiosignals.com/collections/software-add-ons
## Access to biosignalsnotebooks Notebooks
*For viewing biosignalsnotebooks .ipynb files correctly formatted and with the right CSS configurations the user should access the link contained in the previous image instead of navigating manually through the files in GitHub repository*
## Notebook Publication Status
Publication status is available in a [**Google Spreadsheet**](https://docs.google.com/spreadsheets/d/1Hyt7iLidHzDLHTeXrIsrWGlcmKCHTPwtS_d5KYpTSpA/edit?usp=sharing)
## Installation of biosignalsnotebooks package
In order to *biosignalsnotebooks* package be installed, the user should open a Windows command prompt (by searching for "cmd") and type the following instruction:
```
pip install biosignalsnotebooks
```
%package -n python3-biosignalsnotebooks
Summary: A Python package for supporting the external loading and processing of OpenSignals electrophysiological acquisitions.
Provides: python-biosignalsnotebooks
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-biosignalsnotebooks
## Description
**biosignalsnotebooks** is a set of documents and a **Python** library to provide programming examples in the form of **Jupyter Notebooks**, as companion to the **OpenSignals** biosignals acquisition tools.
This collection of code samples has the purpose to help users of PLUX Wireless Biosignals systems, such as **BITalino** or **biosignalsplux**, and to the researcher or student interested on recording processing and classifying biosignals. The examples are set on a level of complexity to inspire the users and programmers on how easy some tasks are and that more complex ones can also be achieved, by reusing and recreating some of the examples presented here.
A **Python** library (entitled **biosignalsnotebooks** ) is the base toolbox to support the notebooks and to provide some useful functionalities. It can be installed through pip command, like demonstrated in a [PyPI
](https://pypi.org/project/biosignalsnotebooks/) dedicated page.
In many cases we also point and illustrate with code the usage of other python toolboxes dedicated to biosignal processing.
The notebooks will cover the full topics pipeline of working with biosignals, such as: **Load** a file; **Visualise** the data online and offline, **Pre-Process** a one channel signal or a multi-channel acquisition, **Detect** relevant events in the signals, **Extract** features from many different type of sensors and domains, **Train and Classify** among a set of classes with several machine learning approaches, **Understand** the obtained results with metrics and validations techniques.
These examples are carried in a multitude of biosignals , from ECG, EDA, EMG, Accelerometer, Respiration among many others.
The notebooks have a set of labels to help navigate among topics
, types of signals
, application area
and complexity
level to support the search for particular solutions.
We encourage you to share new example ideas, to pose questions helpdesk@pluxbiosignals.com, and to make improvements or suggestion to this set of notebooks.
**Be inspired on how to make the most of your biosignals!**
## What is **PLUX**
PLUX wireless biosignals is devoted to the creation innovative products for advanced biosignals monitoring platforms
that integrate wearable body sensors combined with wireless connectivity, algorithms and software applications.
We have been perusing the mission of making biosignals as accessible as possible to researchers and students in many areas of application, ranging from biomedical engineering, computer science, human computer interaction, sport sciences, psychology, clinical research among other fields.
## PLUX's Software and Hardware Environment
[**OpenSignals**](https://support.pluxbiosignals.com/knowledge-base/introducing-opensignals-revolution/) is the companion application to *PLUX* devices ([**BITalino**](https://support.pluxbiosignals.com/article-categories/bitalino/) or [**biosignalsplux**](https://support.pluxbiosignals.com/article-categories/biosignalsplux/)) where the users collect visualize an process biosignals in a intuitive user interface. Opensignals is free and can be used also with signals collected from other devices.
In some cases **OpenSignals** provides [*plugins*](https://www.pluxbiosignals.com/collections/software-add-ons) for advanced signals processing operations that automate some of the research process. Some of the plugins are curated and advanced versions of the base notebooks explained in here.
The list of plugins can be found here: https://www.pluxbiosignals.com/collections/software-add-ons
## Access to biosignalsnotebooks Notebooks
*For viewing biosignalsnotebooks .ipynb files correctly formatted and with the right CSS configurations the user should access the link contained in the previous image instead of navigating manually through the files in GitHub repository*
## Notebook Publication Status
Publication status is available in a [**Google Spreadsheet**](https://docs.google.com/spreadsheets/d/1Hyt7iLidHzDLHTeXrIsrWGlcmKCHTPwtS_d5KYpTSpA/edit?usp=sharing)
## Installation of biosignalsnotebooks package
In order to *biosignalsnotebooks* package be installed, the user should open a Windows command prompt (by searching for "cmd") and type the following instruction:
```
pip install biosignalsnotebooks
```
%package help
Summary: Development documents and examples for biosignalsnotebooks
Provides: python3-biosignalsnotebooks-doc
%description help
## Description
**biosignalsnotebooks** is a set of documents and a **Python** library to provide programming examples in the form of **Jupyter Notebooks**, as companion to the **OpenSignals** biosignals acquisition tools.
This collection of code samples has the purpose to help users of PLUX Wireless Biosignals systems, such as **BITalino** or **biosignalsplux**, and to the researcher or student interested on recording processing and classifying biosignals. The examples are set on a level of complexity to inspire the users and programmers on how easy some tasks are and that more complex ones can also be achieved, by reusing and recreating some of the examples presented here.
A **Python** library (entitled **biosignalsnotebooks** ) is the base toolbox to support the notebooks and to provide some useful functionalities. It can be installed through pip command, like demonstrated in a [PyPI
](https://pypi.org/project/biosignalsnotebooks/) dedicated page.
In many cases we also point and illustrate with code the usage of other python toolboxes dedicated to biosignal processing.
The notebooks will cover the full topics pipeline of working with biosignals, such as: **Load** a file; **Visualise** the data online and offline, **Pre-Process** a one channel signal or a multi-channel acquisition, **Detect** relevant events in the signals, **Extract** features from many different type of sensors and domains, **Train and Classify** among a set of classes with several machine learning approaches, **Understand** the obtained results with metrics and validations techniques.
These examples are carried in a multitude of biosignals , from ECG, EDA, EMG, Accelerometer, Respiration among many others.
The notebooks have a set of labels to help navigate among topics
, types of signals
, application area
and complexity
level to support the search for particular solutions.
We encourage you to share new example ideas, to pose questions helpdesk@pluxbiosignals.com, and to make improvements or suggestion to this set of notebooks.
**Be inspired on how to make the most of your biosignals!**
## What is **PLUX**
PLUX wireless biosignals is devoted to the creation innovative products for advanced biosignals monitoring platforms
that integrate wearable body sensors combined with wireless connectivity, algorithms and software applications.
We have been perusing the mission of making biosignals as accessible as possible to researchers and students in many areas of application, ranging from biomedical engineering, computer science, human computer interaction, sport sciences, psychology, clinical research among other fields.
## PLUX's Software and Hardware Environment
[**OpenSignals**](https://support.pluxbiosignals.com/knowledge-base/introducing-opensignals-revolution/) is the companion application to *PLUX* devices ([**BITalino**](https://support.pluxbiosignals.com/article-categories/bitalino/) or [**biosignalsplux**](https://support.pluxbiosignals.com/article-categories/biosignalsplux/)) where the users collect visualize an process biosignals in a intuitive user interface. Opensignals is free and can be used also with signals collected from other devices.
In some cases **OpenSignals** provides [*plugins*](https://www.pluxbiosignals.com/collections/software-add-ons) for advanced signals processing operations that automate some of the research process. Some of the plugins are curated and advanced versions of the base notebooks explained in here.
The list of plugins can be found here: https://www.pluxbiosignals.com/collections/software-add-ons
## Access to biosignalsnotebooks Notebooks
*For viewing biosignalsnotebooks .ipynb files correctly formatted and with the right CSS configurations the user should access the link contained in the previous image instead of navigating manually through the files in GitHub repository*
## Notebook Publication Status
Publication status is available in a [**Google Spreadsheet**](https://docs.google.com/spreadsheets/d/1Hyt7iLidHzDLHTeXrIsrWGlcmKCHTPwtS_d5KYpTSpA/edit?usp=sharing)
## Installation of biosignalsnotebooks package
In order to *biosignalsnotebooks* package be installed, the user should open a Windows command prompt (by searching for "cmd") and type the following instruction:
```
pip install biosignalsnotebooks
```
%prep
%autosetup -n biosignalsnotebooks-0.6.10
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-biosignalsnotebooks -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.6.10-1
- Package Spec generated