%global _empty_manifest_terminate_build 0
Name:		python-errbot
Version:	6.1.9
Release:	1
Summary:	Errbot is a chatbot designed to be simple to extend with plugins written in Python.
License:	GPL
URL:		http://errbot.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ee/fe/73212b7a6ea63fc30cd4ec038bc7f6aa7661db81625e7d2d23bfc1193869/errbot-6.1.9.tar.gz
BuildArch:	noarch

Requires:	python3-webtest
Requires:	python3-setuptools
Requires:	python3-flask
Requires:	python3-requests
Requires:	python3-jinja2
Requires:	python3-pyOpenSSL
Requires:	python3-colorlog
Requires:	python3-markdown
Requires:	python3-ansi
Requires:	python3-Pygments
Requires:	python3-pygments-markdown-lexer
Requires:	python3-dulwich
Requires:	python3-deepmerge
Requires:	python3-daemonize
Requires:	python3-irc
Requires:	python3-slixmpp
Requires:	python3-pyasn1
Requires:	python3-pyasn1-modules
Requires:	python3-slackclient
Requires:	python3-slackclient
Requires:	python3-telegram-bot

%description
Errbot is a chatbot. It allows you to start scripts interactively from your chatrooms
for any reason: random humour, chatops, starting a build, monitoring commits, triggering
alerts...
It is written and easily extensible in Python.
Errbot is available as open-source software and released under the GPL v3 license.

%package -n python3-errbot
Summary:	Errbot is a chatbot designed to be simple to extend with plugins written in Python.
Provides:	python-errbot
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-errbot
Errbot is a chatbot. It allows you to start scripts interactively from your chatrooms
for any reason: random humour, chatops, starting a build, monitoring commits, triggering
alerts...
It is written and easily extensible in Python.
Errbot is available as open-source software and released under the GPL v3 license.

%package help
Summary:	Development documents and examples for errbot
Provides:	python3-errbot-doc
%description help
Errbot is a chatbot. It allows you to start scripts interactively from your chatrooms
for any reason: random humour, chatops, starting a build, monitoring commits, triggering
alerts...
It is written and easily extensible in Python.
Errbot is available as open-source software and released under the GPL v3 license.

%prep
%autosetup -n errbot-6.1.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-errbot -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 6.1.9-1
- Package Spec generated