%global _empty_manifest_terminate_build 0
Name: python-octomy-batch
Version: 1.0.73
Release: 1
Summary: OctoMY scheduler
License: GPL-3 LGPL-3 MIT
URL: https://gitlab.com/octomy/batch
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cd/9c/0f8c90c04f04a736101d3fa47cca88b5d7e5f2389aa3fa4cc5a649863285/octomy-batch-1.0.73.tar.gz
BuildArch: noarch
%description
[![pipeline status](https://gitlab.com/octomy/batch/badges/production/pipeline.svg)](https://gitlab.com/octomy/batch/-/commits/production)
# About batch
Batch is a batch tasks queue and executor in PyPi package form. See also [https://gitlab.com/octomy/batch-base](batch-base) for Docker image based on this.
- Batch is [available on gitlab](https://gitlab.com/octomy/batch).
- Batch is [available in PyPI](https://pypi.org/project/octomy-batch/).
```shell
# Clone git repository
git clone git@gitlab.com:octomy/batch.git
```
```shell
# Install into your current Python environment
pip install octomy-batch
```
%package -n python3-octomy-batch
Summary: OctoMY scheduler
Provides: python-octomy-batch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-octomy-batch
[![pipeline status](https://gitlab.com/octomy/batch/badges/production/pipeline.svg)](https://gitlab.com/octomy/batch/-/commits/production)
# About batch
Batch is a batch tasks queue and executor in PyPi package form. See also [https://gitlab.com/octomy/batch-base](batch-base) for Docker image based on this.
- Batch is [available on gitlab](https://gitlab.com/octomy/batch).
- Batch is [available in PyPI](https://pypi.org/project/octomy-batch/).
```shell
# Clone git repository
git clone git@gitlab.com:octomy/batch.git
```
```shell
# Install into your current Python environment
pip install octomy-batch
```
%package help
Summary: Development documents and examples for octomy-batch
Provides: python3-octomy-batch-doc
%description help
[![pipeline status](https://gitlab.com/octomy/batch/badges/production/pipeline.svg)](https://gitlab.com/octomy/batch/-/commits/production)
# About batch
Batch is a batch tasks queue and executor in PyPi package form. See also [https://gitlab.com/octomy/batch-base](batch-base) for Docker image based on this.
- Batch is [available on gitlab](https://gitlab.com/octomy/batch).
- Batch is [available in PyPI](https://pypi.org/project/octomy-batch/).
```shell
# Clone git repository
git clone git@gitlab.com:octomy/batch.git
```
```shell
# Install into your current Python environment
pip install octomy-batch
```
%prep
%autosetup -n octomy-batch-1.0.73
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-octomy-batch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.73-1
- Package Spec generated