%global _empty_manifest_terminate_build 0
Name:		python-textdata
Version:	2.4.1
Release:	1
Summary:	Easily get clean data, direct from text or Python source
License:	Apache License 2.0
URL:		https://bitbucket.org/jeunice/textdata
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/86/ad/0cd81c0169aeb9de5f3b60e442c99ce66a84994f9ecf58b2de95fb21e67f/textdata-2.4.1.zip
BuildArch:	noarch


%description
    >>> lines("""
    ['There was an old woman who lived in a shoe.',
     "She had so many children, she didn't know what to do;",
     'She gave them some broth without any bread;',
     'Then whipped them all soundly and put them to bed.']
Note that the "extra" newlines and leading spaces have been
taken care of and discarded. Or do you want that as just one
string? Okay:
    >>> text("""
    "There was an old woman who lived in a shoe.\nShe ...put them to bed."
Here ``text()`` does the same stripping of pointless whitespace at the beginning
and end of lines, returning the data as a clean, convenient string. Or if you
don't want most of the line endings, try ``textline`` on the same input to get a
single no-breaks line.

%package -n python3-textdata
Summary:	Easily get clean data, direct from text or Python source
Provides:	python-textdata
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-textdata
    >>> lines("""
    ['There was an old woman who lived in a shoe.',
     "She had so many children, she didn't know what to do;",
     'She gave them some broth without any bread;',
     'Then whipped them all soundly and put them to bed.']
Note that the "extra" newlines and leading spaces have been
taken care of and discarded. Or do you want that as just one
string? Okay:
    >>> text("""
    "There was an old woman who lived in a shoe.\nShe ...put them to bed."
Here ``text()`` does the same stripping of pointless whitespace at the beginning
and end of lines, returning the data as a clean, convenient string. Or if you
don't want most of the line endings, try ``textline`` on the same input to get a
single no-breaks line.

%package help
Summary:	Development documents and examples for textdata
Provides:	python3-textdata-doc
%description help
    >>> lines("""
    ['There was an old woman who lived in a shoe.',
     "She had so many children, she didn't know what to do;",
     'She gave them some broth without any bread;',
     'Then whipped them all soundly and put them to bed.']
Note that the "extra" newlines and leading spaces have been
taken care of and discarded. Or do you want that as just one
string? Okay:
    >>> text("""
    "There was an old woman who lived in a shoe.\nShe ...put them to bed."
Here ``text()`` does the same stripping of pointless whitespace at the beginning
and end of lines, returning the data as a clean, convenient string. Or if you
don't want most of the line endings, try ``textline`` on the same input to get a
single no-breaks line.

%prep
%autosetup -n textdata-2.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-textdata -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.1-1
- Package Spec generated