%global _empty_manifest_terminate_build 0
Name: python-pycheops
Version: 1.0.16
Release: 1
Summary: CHEOPS light curve analysis software
License: GNU GPLv3
URL: http://cheops.unibe.ch/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/30/9e/afbeb98f973b01c0b1d1e26713868fe34d28d9f4c2fadea8400061f574f5/pycheops-1.0.16.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-astropy
Requires: python3-emcee
Requires: python3-astroquery
Requires: python3-numba
Requires: python3-lmfit
Requires: python3-corner
Requires: python3-photutils
Requires: python3-matplotlib
Requires: python3-celerite2
Requires: python3-cdspyreadme
Requires: python3-dace-query
Requires: python3-IPython
Requires: python3-tqdm
%description
Python package for the analysis of light curves from the `ESA CHEOPS mission `_.
Use ``pip install pycheops`` to install.
See `pycheops/examples/Notebooks `_ for examples.
For discussion and announcements, please join the `pycheops google group `_
See pycheops/docs/PyCheops_Cookbook.pdf for a guide to using pycheops.
See pycheops/examples/Notebooks for Jupyter notebook that illustrate the
features of pycheops.
See Maxted et al. 2022MNRAS.514...77M for a full description of the
algorithms and assumptions used in pycheops.
Troubleshooting
***************
%package -n python3-pycheops
Summary: CHEOPS light curve analysis software
Provides: python-pycheops
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pycheops
Python package for the analysis of light curves from the `ESA CHEOPS mission `_.
Use ``pip install pycheops`` to install.
See `pycheops/examples/Notebooks `_ for examples.
For discussion and announcements, please join the `pycheops google group `_
See pycheops/docs/PyCheops_Cookbook.pdf for a guide to using pycheops.
See pycheops/examples/Notebooks for Jupyter notebook that illustrate the
features of pycheops.
See Maxted et al. 2022MNRAS.514...77M for a full description of the
algorithms and assumptions used in pycheops.
Troubleshooting
***************
%package help
Summary: Development documents and examples for pycheops
Provides: python3-pycheops-doc
%description help
Python package for the analysis of light curves from the `ESA CHEOPS mission `_.
Use ``pip install pycheops`` to install.
See `pycheops/examples/Notebooks `_ for examples.
For discussion and announcements, please join the `pycheops google group `_
See pycheops/docs/PyCheops_Cookbook.pdf for a guide to using pycheops.
See pycheops/examples/Notebooks for Jupyter notebook that illustrate the
features of pycheops.
See Maxted et al. 2022MNRAS.514...77M for a full description of the
algorithms and assumptions used in pycheops.
Troubleshooting
***************
%prep
%autosetup -n pycheops-1.0.16
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pycheops -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.16-1
- Package Spec generated