%global _empty_manifest_terminate_build 0
Name:		python-aiozaneapi
Version:	1.6
Release:	1
Summary:	An async wrapper made in Python for Zane API.
License:	MIT
URL:		http://github.com/kal-byte/aiozaneapi
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/1c/45/537e99093728c2a1d3c72a6e5dadc8b730e848c3a3e8c2f807515a24a09c/aiozaneapi-1.6.tar.gz
BuildArch:	noarch


%description
Made for Python 3.6+.
`Website Link <https://zane.ip-bash.com/>`_

%package -n python3-aiozaneapi
Summary:	An async wrapper made in Python for Zane API.
Provides:	python-aiozaneapi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-aiozaneapi
Made for Python 3.6+.
`Website Link <https://zane.ip-bash.com/>`_

%package help
Summary:	Development documents and examples for aiozaneapi
Provides:	python3-aiozaneapi-doc
%description help
Made for Python 3.6+.
`Website Link <https://zane.ip-bash.com/>`_

%prep
%autosetup -n aiozaneapi-1.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-aiozaneapi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6-1
- Package Spec generated