%global _empty_manifest_terminate_build 0
Name:		python-XBee
Version:	2.3.2
Release:	1
Summary:	Python tools for working with XBee radios
License:	MIT
URL:		https://github.com/nioinnovation/python-xbee
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4e/6b/34a1a5a0c45c662f8ae033a0d077b0fcc45b3e0e71e0b17522b2861e0090/XBee-2.3.2.tar.gz
BuildArch:	noarch

Requires:	python3-pyserial
Requires:	python3-tornado

%description
|build_status_badge| |pypi_badge| |py_versions_badge|
XBee provides an implementation of the XBee serial communication API. It
allows one to easily access advanced features of one or more XBee
devices from an application written in Python. An example use case might
look like this:
    #! /usr/bin/python
    # Import and init an XBee device
    from xbee import XBee, ZigBee
    import serial
    ser = serial.Serial('/dev/ttyUSB0', 9600)
    # Use an XBee 802.15.4 device
    xbee = XBee(ser)
    # To use with an XBee ZigBee device, replace with:
    # xbee = ZigBee(ser)
    # Set remote DIO pin 2 to low (mode 4)
    xbee.remote_at(
        dest_addr=b'\x56\x78',
        command='D2',
        parameter=b'\x04')
    xbee.remote_at(
        dest_addr=b'\x56\x78',
        command='WR')

%package -n python3-XBee
Summary:	Python tools for working with XBee radios
Provides:	python-XBee
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-XBee
|build_status_badge| |pypi_badge| |py_versions_badge|
XBee provides an implementation of the XBee serial communication API. It
allows one to easily access advanced features of one or more XBee
devices from an application written in Python. An example use case might
look like this:
    #! /usr/bin/python
    # Import and init an XBee device
    from xbee import XBee, ZigBee
    import serial
    ser = serial.Serial('/dev/ttyUSB0', 9600)
    # Use an XBee 802.15.4 device
    xbee = XBee(ser)
    # To use with an XBee ZigBee device, replace with:
    # xbee = ZigBee(ser)
    # Set remote DIO pin 2 to low (mode 4)
    xbee.remote_at(
        dest_addr=b'\x56\x78',
        command='D2',
        parameter=b'\x04')
    xbee.remote_at(
        dest_addr=b'\x56\x78',
        command='WR')

%package help
Summary:	Development documents and examples for XBee
Provides:	python3-XBee-doc
%description help
|build_status_badge| |pypi_badge| |py_versions_badge|
XBee provides an implementation of the XBee serial communication API. It
allows one to easily access advanced features of one or more XBee
devices from an application written in Python. An example use case might
look like this:
    #! /usr/bin/python
    # Import and init an XBee device
    from xbee import XBee, ZigBee
    import serial
    ser = serial.Serial('/dev/ttyUSB0', 9600)
    # Use an XBee 802.15.4 device
    xbee = XBee(ser)
    # To use with an XBee ZigBee device, replace with:
    # xbee = ZigBee(ser)
    # Set remote DIO pin 2 to low (mode 4)
    xbee.remote_at(
        dest_addr=b'\x56\x78',
        command='D2',
        parameter=b'\x04')
    xbee.remote_at(
        dest_addr=b'\x56\x78',
        command='WR')

%prep
%autosetup -n XBee-2.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-XBee -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.2-1
- Package Spec generated