%global _empty_manifest_terminate_build 0
Name: python-cmyt
Version: 1.2.0
Release: 1
Summary: A collection of Matplotlib colormaps from the yt project
License: BSD 3-Clause
URL: https://yt-project.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1d/c8/cf6f8bcef86ed426ca6de0f6d778a548ccd382374dd791b2658241fb551f/cmyt-1.2.0.tar.gz
BuildArch: noarch
Requires: python3-colorspacious
Requires: python3-matplotlib
Requires: python3-more-itertools
Requires: python3-numpy
%description
# cmyt
[](https://pypi.org/project/cmyt)
[](https://anaconda.org/conda-forge/cmyt)
[](https://pypi.org/project/cmyt/)
[](https://github.com/yt-project/cmyt/actions/workflows/ci.yml)
[](https://github.com/yt-project/cmyt/actions/workflows/bleeding-edge.yaml)
[](https://results.pre-commit.ci/latest/github/yt-project/cmyt/main)
[](https://yt-project.org)
[](https://github.com/psf/black)
[](https://github.com/charliermarsh/ruff)
Matplotlib colormaps from the yt project !
## Colormaps overview
The following colormaps, as well as their respective reversed (`*_r`) versions are available
### Perceptually uniform sequential colormaps
### Monochromatic sequential colormaps
### Miscellaneous
## Installation
with `pip`
```shell
python -m pip install cmyt
```
or with `conda`
```shell
conda install -c conda-forge cmyt
```
## Usage
cmyt integrates with matplotlib in a similar fashion to
[cmocean](https://matplotlib.org/cmocean/) or
[cmasher](https://cmasher.readthedocs.io)
```python
import numpy as np
import matplotlib.pyplot as plt
import cmyt # that's it !
# generate example data
prng = np.random.RandomState(0x4D3D3D3)
noise = prng.random_sample((100, 100))
x, y = np.mgrid[-50:50, -50:50]
z = 5 * np.exp(-(x**2 + y**2) / 1000)
# setup the figure
fig, ax = plt.subplots()
ax.set(aspect="equal")
# now we can refer to cmyt colormaps as strings
im = ax.pcolormesh(x, y, z + noise, cmap="cmyt.arbre", shading="flat")
fig.colorbar(im, ax=ax)
```
```python
# alternatively, cmyt maps can also be imported as objects
from cmyt import pastel
fig, ax = plt.subplots()
ax.set(aspect="equal")
im = ax.contourf(x, y, z + noise, cmap=pastel)
fig.colorbar(im, ax=ax)
```
A gallery of comparable examples using all colormaps from cmyt is available [in the test directory](https://github.com/yt-project/cmyt/tree/main/tests/baseline).
%package -n python3-cmyt
Summary: A collection of Matplotlib colormaps from the yt project
Provides: python-cmyt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cmyt
# cmyt
[](https://pypi.org/project/cmyt)
[](https://anaconda.org/conda-forge/cmyt)
[](https://pypi.org/project/cmyt/)
[](https://github.com/yt-project/cmyt/actions/workflows/ci.yml)
[](https://github.com/yt-project/cmyt/actions/workflows/bleeding-edge.yaml)
[](https://results.pre-commit.ci/latest/github/yt-project/cmyt/main)
[](https://yt-project.org)
[](https://github.com/psf/black)
[](https://github.com/charliermarsh/ruff)
Matplotlib colormaps from the yt project !
## Colormaps overview
The following colormaps, as well as their respective reversed (`*_r`) versions are available
### Perceptually uniform sequential colormaps
### Monochromatic sequential colormaps
### Miscellaneous
## Installation
with `pip`
```shell
python -m pip install cmyt
```
or with `conda`
```shell
conda install -c conda-forge cmyt
```
## Usage
cmyt integrates with matplotlib in a similar fashion to
[cmocean](https://matplotlib.org/cmocean/) or
[cmasher](https://cmasher.readthedocs.io)
```python
import numpy as np
import matplotlib.pyplot as plt
import cmyt # that's it !
# generate example data
prng = np.random.RandomState(0x4D3D3D3)
noise = prng.random_sample((100, 100))
x, y = np.mgrid[-50:50, -50:50]
z = 5 * np.exp(-(x**2 + y**2) / 1000)
# setup the figure
fig, ax = plt.subplots()
ax.set(aspect="equal")
# now we can refer to cmyt colormaps as strings
im = ax.pcolormesh(x, y, z + noise, cmap="cmyt.arbre", shading="flat")
fig.colorbar(im, ax=ax)
```
```python
# alternatively, cmyt maps can also be imported as objects
from cmyt import pastel
fig, ax = plt.subplots()
ax.set(aspect="equal")
im = ax.contourf(x, y, z + noise, cmap=pastel)
fig.colorbar(im, ax=ax)
```
A gallery of comparable examples using all colormaps from cmyt is available [in the test directory](https://github.com/yt-project/cmyt/tree/main/tests/baseline).
%package help
Summary: Development documents and examples for cmyt
Provides: python3-cmyt-doc
%description help
# cmyt
[](https://pypi.org/project/cmyt)
[](https://anaconda.org/conda-forge/cmyt)
[](https://pypi.org/project/cmyt/)
[](https://github.com/yt-project/cmyt/actions/workflows/ci.yml)
[](https://github.com/yt-project/cmyt/actions/workflows/bleeding-edge.yaml)
[](https://results.pre-commit.ci/latest/github/yt-project/cmyt/main)
[](https://yt-project.org)
[](https://github.com/psf/black)
[](https://github.com/charliermarsh/ruff)
Matplotlib colormaps from the yt project !
## Colormaps overview
The following colormaps, as well as their respective reversed (`*_r`) versions are available
### Perceptually uniform sequential colormaps
### Monochromatic sequential colormaps
### Miscellaneous
## Installation
with `pip`
```shell
python -m pip install cmyt
```
or with `conda`
```shell
conda install -c conda-forge cmyt
```
## Usage
cmyt integrates with matplotlib in a similar fashion to
[cmocean](https://matplotlib.org/cmocean/) or
[cmasher](https://cmasher.readthedocs.io)
```python
import numpy as np
import matplotlib.pyplot as plt
import cmyt # that's it !
# generate example data
prng = np.random.RandomState(0x4D3D3D3)
noise = prng.random_sample((100, 100))
x, y = np.mgrid[-50:50, -50:50]
z = 5 * np.exp(-(x**2 + y**2) / 1000)
# setup the figure
fig, ax = plt.subplots()
ax.set(aspect="equal")
# now we can refer to cmyt colormaps as strings
im = ax.pcolormesh(x, y, z + noise, cmap="cmyt.arbre", shading="flat")
fig.colorbar(im, ax=ax)
```
```python
# alternatively, cmyt maps can also be imported as objects
from cmyt import pastel
fig, ax = plt.subplots()
ax.set(aspect="equal")
im = ax.contourf(x, y, z + noise, cmap=pastel)
fig.colorbar(im, ax=ax)
```
A gallery of comparable examples using all colormaps from cmyt is available [in the test directory](https://github.com/yt-project/cmyt/tree/main/tests/baseline).
%prep
%autosetup -n cmyt-1.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cmyt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.0-1
- Package Spec generated