%global _empty_manifest_terminate_build 0
Name: python-pyvcd
Version: 0.3.0
Release: 1
Summary: Python VCD file support
License: MIT
URL: http://pyvcd.readthedocs.io/en/latest/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ee/97/369e75de6ac1c5f4400e439ac7ea53a85a79c69eaa3f4aaac13a6b81b376/pyvcd-0.3.0.tar.gz
BuildArch: noarch
%description
The PyVCD package writes Value Change Dump (VCD) files as specified in
IEEE 1364-2005.
Read the `documentation `_.
Visit `PyVCD on GitHub `_.
%package -n python3-pyvcd
Summary: Python VCD file support
Provides: python-pyvcd
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyvcd
The PyVCD package writes Value Change Dump (VCD) files as specified in
IEEE 1364-2005.
Read the `documentation `_.
Visit `PyVCD on GitHub `_.
%package help
Summary: Development documents and examples for pyvcd
Provides: python3-pyvcd-doc
%description help
The PyVCD package writes Value Change Dump (VCD) files as specified in
IEEE 1364-2005.
Read the `documentation `_.
Visit `PyVCD on GitHub `_.
%prep
%autosetup -n pyvcd-0.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyvcd -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.3.0-1
- Package Spec generated