%global _empty_manifest_terminate_build 0
Name:		python-pysoa
Version:	1.4.9
Release:	1
Summary:	A Python library for writing (micro)services and their clients
License:	Apache 2.0
URL:		http://github.com/eventbrite/pysoa
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/69/18/3ee8f997eba5b7ee3f15040baa2d877587602d1ef14d064764ec0b413474/pysoa-1.4.9.tar.gz
BuildArch:	noarch

Requires:	python3-attrs
Requires:	python3-conformity
Requires:	python3-currint
Requires:	python3-msgpack
Requires:	python3-pymetrics
Requires:	python3-pytz
Requires:	python3-redis
Requires:	python3-six
Requires:	python3-enum34
Requires:	python3-typing
Requires:	python3-contextvars
Requires:	python3-aiocontextvars
Requires:	python3-conformity[docs]
Requires:	python3-django
Requires:	python3-pyparsing
Requires:	python3-pytest
Requires:	python3-mock
Requires:	python3-pytest-asyncio
Requires:	python3-Faker
Requires:	python3-sphinx
Requires:	python3-mock
Requires:	python3-pyparsing
Requires:	python3-pytest
Requires:	python3-mock
Requires:	python3-pytest-asyncio
Requires:	python3-Faker
Requires:	python3-coverage
Requires:	python3-factory-boy
Requires:	python3-freezegun
Requires:	python3-lunatic-python-universal
Requires:	python3-mockredispy
Requires:	python3-parameterized
Requires:	python3-pyparsing
Requires:	python3-pytest
Requires:	python3-mock
Requires:	python3-typing-extensions
Requires:	python3-types-six
Requires:	python3-types-setuptools
Requires:	python3-types-mock
Requires:	python3-types-requests
Requires:	python3-pytest-asyncio
Requires:	python3-Faker
Requires:	python3-mypy
Requires:	python3-types-pytz
Requires:	python3-types-redis
Requires:	python3-mypy
Requires:	python3-typing-extensions

%description
**PySOA** is a general-purpose library for writing fast Python (micro)services and their clients, based on an RPC
(remote procedure call) calling style. It provides both a client and a server, which can be used directly by themselves
or, as we do, extended with extra functionality (our authentication, database routing, and other code is written as
private middleware and runs on top of this library).
PySOA uses the concept of pluggable "transports" to define a layer for sending requests and responses (messages)
between clients and servers. The default, production-ready included transport is a `Redis <https://redis.io/>`_ pub-sub
layer, which we use in combination with Redis Sentinel in clusters. A single Redis cluster is capable of handling tens
of thousands of PySOA messages per second with extremely efficient and desirable load-balancing properties. There is
also a local transport implementation primarily used for testing and demonstration but capable of being used in
production where appropriate.

%package -n python3-pysoa
Summary:	A Python library for writing (micro)services and their clients
Provides:	python-pysoa
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pysoa
**PySOA** is a general-purpose library for writing fast Python (micro)services and their clients, based on an RPC
(remote procedure call) calling style. It provides both a client and a server, which can be used directly by themselves
or, as we do, extended with extra functionality (our authentication, database routing, and other code is written as
private middleware and runs on top of this library).
PySOA uses the concept of pluggable "transports" to define a layer for sending requests and responses (messages)
between clients and servers. The default, production-ready included transport is a `Redis <https://redis.io/>`_ pub-sub
layer, which we use in combination with Redis Sentinel in clusters. A single Redis cluster is capable of handling tens
of thousands of PySOA messages per second with extremely efficient and desirable load-balancing properties. There is
also a local transport implementation primarily used for testing and demonstration but capable of being used in
production where appropriate.

%package help
Summary:	Development documents and examples for pysoa
Provides:	python3-pysoa-doc
%description help
**PySOA** is a general-purpose library for writing fast Python (micro)services and their clients, based on an RPC
(remote procedure call) calling style. It provides both a client and a server, which can be used directly by themselves
or, as we do, extended with extra functionality (our authentication, database routing, and other code is written as
private middleware and runs on top of this library).
PySOA uses the concept of pluggable "transports" to define a layer for sending requests and responses (messages)
between clients and servers. The default, production-ready included transport is a `Redis <https://redis.io/>`_ pub-sub
layer, which we use in combination with Redis Sentinel in clusters. A single Redis cluster is capable of handling tens
of thousands of PySOA messages per second with extremely efficient and desirable load-balancing properties. There is
also a local transport implementation primarily used for testing and demonstration but capable of being used in
production where appropriate.

%prep
%autosetup -n pysoa-1.4.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pysoa -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.9-1
- Package Spec generated