%global _empty_manifest_terminate_build 0
Name:		python-ocs-academic-hub
Version:	1.0.1
Release:	1
Summary:	Academic Hub Library
License:	Apache Software License
URL:		https://github.com/cfoisy-osisoft/academic-hub
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/aa/f5/7b815b036b8e78206e818b922be82786a6859064734028b1b39f8ba389df/ocs_academic_hub-1.0.1.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-ocs-sample-library-hub
Requires:	python3-numpy
Requires:	python3-dateutil
Requires:	python3-typeguard
Requires:	python3-requests
Requires:	python3-gql
Requires:	python3-backoff
Requires:	python3-markdown
Requires:	python3-importlib-metadata
Requires:	python3-ipywidgets

%description
# OSIsoft Academic Hub 

To support data analytics learning material developed for [OSIsoft Academic Hub](https://academic.osisoft.com). 

IN DEVELOPMENT 




%package -n python3-ocs-academic-hub
Summary:	Academic Hub Library
Provides:	python-ocs-academic-hub
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ocs-academic-hub
# OSIsoft Academic Hub 

To support data analytics learning material developed for [OSIsoft Academic Hub](https://academic.osisoft.com). 

IN DEVELOPMENT 




%package help
Summary:	Development documents and examples for ocs-academic-hub
Provides:	python3-ocs-academic-hub-doc
%description help
# OSIsoft Academic Hub 

To support data analytics learning material developed for [OSIsoft Academic Hub](https://academic.osisoft.com). 

IN DEVELOPMENT 




%prep
%autosetup -n ocs-academic-hub-1.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ocs-academic-hub -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
- Package Spec generated