%global _empty_manifest_terminate_build 0
Name:		python-see
Version:	1.4.1
Release:	1
Summary:	dir for humans
License:	BSD License
URL:		https://ljcooke.github.io/see/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ff/fc/fcabb6a9bfe7c56798285839780cae67342256b823b97e94d862b0ba21d6/see-1.4.1.tar.gz
BuildArch:	noarch


%description
**see** is an alternative to ``dir()``, for Python 2.6+ and 3.3+.
It neatly summarises what you can do with an object.
Use it to inspect your code or learn new APIs.

%package -n python3-see
Summary:	dir for humans
Provides:	python-see
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-see
**see** is an alternative to ``dir()``, for Python 2.6+ and 3.3+.
It neatly summarises what you can do with an object.
Use it to inspect your code or learn new APIs.

%package help
Summary:	Development documents and examples for see
Provides:	python3-see-doc
%description help
**see** is an alternative to ``dir()``, for Python 2.6+ and 3.3+.
It neatly summarises what you can do with an object.
Use it to inspect your code or learn new APIs.

%prep
%autosetup -n see-1.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-see -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.1-1
- Package Spec generated