%global _empty_manifest_terminate_build 0
Name: python-visualpython
Version: 2.3.6
Release: 1
Summary: Visual Python is a GUI-based Python code generator, developed on the Jupyter Notebook as an extension.
License: GPLv3
URL: https://github.com/visualpython/visualpython
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/68/a0a63d960c946947cdd4cc72fded500b8a7fb46c349794adb6f3586c0c0e/visualpython-2.3.6.tar.gz
BuildArch: noarch
%description
[](https://pypi.python.org/pypi/jupyterlab-visualpython/)

[](https://github.com/visualpython/visualpython/blob/main/LICENSE)
[](https://pepy.tech/project/visualpython)
[](https://github.com/visualpython/visualpython/issues)
[](https://mybinder.org/v2/gh/visualpython/visualpython-binder/HEAD?labpath=index.ipynb)
## Introduction
Visual Python is a GUI-based Python code generator, developed on the **Jupyter Lab**, **Jupyter Notebook** and **Google Colab** as an extension.
Visual Python is an open source project started for students who struggle with coding during Python classes for data science.
Try Visual Python if you would like to:
* manage big data with minimal coding skills.
* help students / business analysts / researchers to overcome learning barriers for Python.
* save & reuse repeatedly used codes(snippets).
## Getting Started with Jupyter Lab
### 1. Requirements
Visual Python is an extension to Jupyter Lab, so you must have Jupyter Lab installed already.
- Python version 3.x
- Jupyter lab environment
### 2. How to Install
**1) Install package from PyPI**
```
pip install jupyterlab-visualpython
```
**2) Activate Visual Python on Jupyter Lab**
Click orange square button on the right side of the Jupyter Lab.
## Getting Started with Jupyter Notebook
### 1. Requirements
Visual Python is an extension to Jupyter Notebook, so you must have Jupyter Notebook installed already.
- Python version 3.x
- Jupyter notebook environment
### 2. How to Install
**1) Install package from PyPI**
```
pip install visualpython
```
**2) Enable the package**
```
visualpy install
```
**3) Activate Visual Python on Jupyter Notebook**
Click orange square button on the right side of the Jupyter Notebook menu bar.
### 3. Package Control Info
* Usage: visualpy **[option]**
* Optional arguments:
```
help - show help menu
install - install packages
uninstall - uninstall packages
upgrade - version upgrade
version - version check
```
## Getting Started with Google Colab
### 1. Requirements
Visual Python is an extension to Google Colab, so you must have Google Colab opened.
- Google Colab
### 2. How to Install
**1) Install package using Chrome Web Store**
- [Link to Visual Python for Colab](https://chrome.google.com/webstore/detail/visual-python-for-colab/ccmkpknjfagaldcgidgcipbpdipfopob)
**2) Open Google Colab**
- [Link to Google Colab](https://colab.research.google.com/)
**3) Activate Visual Python on Google Colab**
## Contributing
If you are interested in contributing to the Visual Python, please see [`CONTRIBUTING.md`](CONTRIBUTING.md).
All skills from programmers, non-programmers, designers are welcomed.
* Programming Guide: [Developer Documentation](https://bird-energy-733.notion.site/visualpython-docs-85c0274ff7564747bb8e8d77909fc8b7)
* GUI Design Guide: [Visual Python GUI Kit 1.0](https://www.figma.com/community/file/976035035360380841)
## License
GNU GPLv3 with Visual Python special exception (See LICENSE file).
## Mission & Vision
**Mission**
To support technology and education so that anyone can leverage big data analytical skills to create a variety of social values.
**Vision**
To create an environment where everyone can learn and use big data analytical skills easily.
## Support Visual Python
Love Visual Python?
Your support will help us continue to actively develop and improve Visual Python.☕
[](https://github.com/sponsors/visualpython?frequency=recurring)
%package -n python3-visualpython
Summary: Visual Python is a GUI-based Python code generator, developed on the Jupyter Notebook as an extension.
Provides: python-visualpython
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-visualpython
[](https://pypi.python.org/pypi/jupyterlab-visualpython/)

[](https://github.com/visualpython/visualpython/blob/main/LICENSE)
[](https://pepy.tech/project/visualpython)
[](https://github.com/visualpython/visualpython/issues)
[](https://mybinder.org/v2/gh/visualpython/visualpython-binder/HEAD?labpath=index.ipynb)
## Introduction
Visual Python is a GUI-based Python code generator, developed on the **Jupyter Lab**, **Jupyter Notebook** and **Google Colab** as an extension.
Visual Python is an open source project started for students who struggle with coding during Python classes for data science.
Try Visual Python if you would like to:
* manage big data with minimal coding skills.
* help students / business analysts / researchers to overcome learning barriers for Python.
* save & reuse repeatedly used codes(snippets).
## Getting Started with Jupyter Lab
### 1. Requirements
Visual Python is an extension to Jupyter Lab, so you must have Jupyter Lab installed already.
- Python version 3.x
- Jupyter lab environment
### 2. How to Install
**1) Install package from PyPI**
```
pip install jupyterlab-visualpython
```
**2) Activate Visual Python on Jupyter Lab**
Click orange square button on the right side of the Jupyter Lab.
## Getting Started with Jupyter Notebook
### 1. Requirements
Visual Python is an extension to Jupyter Notebook, so you must have Jupyter Notebook installed already.
- Python version 3.x
- Jupyter notebook environment
### 2. How to Install
**1) Install package from PyPI**
```
pip install visualpython
```
**2) Enable the package**
```
visualpy install
```
**3) Activate Visual Python on Jupyter Notebook**
Click orange square button on the right side of the Jupyter Notebook menu bar.
### 3. Package Control Info
* Usage: visualpy **[option]**
* Optional arguments:
```
help - show help menu
install - install packages
uninstall - uninstall packages
upgrade - version upgrade
version - version check
```
## Getting Started with Google Colab
### 1. Requirements
Visual Python is an extension to Google Colab, so you must have Google Colab opened.
- Google Colab
### 2. How to Install
**1) Install package using Chrome Web Store**
- [Link to Visual Python for Colab](https://chrome.google.com/webstore/detail/visual-python-for-colab/ccmkpknjfagaldcgidgcipbpdipfopob)
**2) Open Google Colab**
- [Link to Google Colab](https://colab.research.google.com/)
**3) Activate Visual Python on Google Colab**
## Contributing
If you are interested in contributing to the Visual Python, please see [`CONTRIBUTING.md`](CONTRIBUTING.md).
All skills from programmers, non-programmers, designers are welcomed.
* Programming Guide: [Developer Documentation](https://bird-energy-733.notion.site/visualpython-docs-85c0274ff7564747bb8e8d77909fc8b7)
* GUI Design Guide: [Visual Python GUI Kit 1.0](https://www.figma.com/community/file/976035035360380841)
## License
GNU GPLv3 with Visual Python special exception (See LICENSE file).
## Mission & Vision
**Mission**
To support technology and education so that anyone can leverage big data analytical skills to create a variety of social values.
**Vision**
To create an environment where everyone can learn and use big data analytical skills easily.
## Support Visual Python
Love Visual Python?
Your support will help us continue to actively develop and improve Visual Python.☕
[](https://github.com/sponsors/visualpython?frequency=recurring)
%package help
Summary: Development documents and examples for visualpython
Provides: python3-visualpython-doc
%description help
[](https://pypi.python.org/pypi/jupyterlab-visualpython/)

[](https://github.com/visualpython/visualpython/blob/main/LICENSE)
[](https://pepy.tech/project/visualpython)
[](https://github.com/visualpython/visualpython/issues)
[](https://mybinder.org/v2/gh/visualpython/visualpython-binder/HEAD?labpath=index.ipynb)
## Introduction
Visual Python is a GUI-based Python code generator, developed on the **Jupyter Lab**, **Jupyter Notebook** and **Google Colab** as an extension.
Visual Python is an open source project started for students who struggle with coding during Python classes for data science.
Try Visual Python if you would like to:
* manage big data with minimal coding skills.
* help students / business analysts / researchers to overcome learning barriers for Python.
* save & reuse repeatedly used codes(snippets).
## Getting Started with Jupyter Lab
### 1. Requirements
Visual Python is an extension to Jupyter Lab, so you must have Jupyter Lab installed already.
- Python version 3.x
- Jupyter lab environment
### 2. How to Install
**1) Install package from PyPI**
```
pip install jupyterlab-visualpython
```
**2) Activate Visual Python on Jupyter Lab**
Click orange square button on the right side of the Jupyter Lab.
## Getting Started with Jupyter Notebook
### 1. Requirements
Visual Python is an extension to Jupyter Notebook, so you must have Jupyter Notebook installed already.
- Python version 3.x
- Jupyter notebook environment
### 2. How to Install
**1) Install package from PyPI**
```
pip install visualpython
```
**2) Enable the package**
```
visualpy install
```
**3) Activate Visual Python on Jupyter Notebook**
Click orange square button on the right side of the Jupyter Notebook menu bar.
### 3. Package Control Info
* Usage: visualpy **[option]**
* Optional arguments:
```
help - show help menu
install - install packages
uninstall - uninstall packages
upgrade - version upgrade
version - version check
```
## Getting Started with Google Colab
### 1. Requirements
Visual Python is an extension to Google Colab, so you must have Google Colab opened.
- Google Colab
### 2. How to Install
**1) Install package using Chrome Web Store**
- [Link to Visual Python for Colab](https://chrome.google.com/webstore/detail/visual-python-for-colab/ccmkpknjfagaldcgidgcipbpdipfopob)
**2) Open Google Colab**
- [Link to Google Colab](https://colab.research.google.com/)
**3) Activate Visual Python on Google Colab**
## Contributing
If you are interested in contributing to the Visual Python, please see [`CONTRIBUTING.md`](CONTRIBUTING.md).
All skills from programmers, non-programmers, designers are welcomed.
* Programming Guide: [Developer Documentation](https://bird-energy-733.notion.site/visualpython-docs-85c0274ff7564747bb8e8d77909fc8b7)
* GUI Design Guide: [Visual Python GUI Kit 1.0](https://www.figma.com/community/file/976035035360380841)
## License
GNU GPLv3 with Visual Python special exception (See LICENSE file).
## Mission & Vision
**Mission**
To support technology and education so that anyone can leverage big data analytical skills to create a variety of social values.
**Vision**
To create an environment where everyone can learn and use big data analytical skills easily.
## Support Visual Python
Love Visual Python?
Your support will help us continue to actively develop and improve Visual Python.☕
[](https://github.com/sponsors/visualpython?frequency=recurring)
%prep
%autosetup -n visualpython-2.3.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-visualpython -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 2.3.6-1
- Package Spec generated