%global _empty_manifest_terminate_build 0
Name:		python-ucsmsdk
Version:	0.9.14
Release:	1
Summary:	Python SDK for Cisco UCS
License:	http://www.apache.org/licenses/LICENSE-2.0
URL:		https://github.com/CiscoUcs/ucsmsdk
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7e/d1/dd30b088cc9c0028fef39c66e8c3c664ac492c824622215d119ba1f052ac/ucsmsdk-0.9.14.tar.gz
BuildArch:	noarch

Requires:	python3-setuptools
Requires:	python3-pyparsing
Requires:	python3-six
Requires:	python3-sphinx
Requires:	python3-sphinxcontrib-napoleon
Requires:	python3-sphinx-rtd-theme
Requires:	python3-pyOpenSSL

%description


%package -n python3-ucsmsdk
Summary:	Python SDK for Cisco UCS
Provides:	python-ucsmsdk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ucsmsdk


%package help
Summary:	Development documents and examples for ucsmsdk
Provides:	python3-ucsmsdk-doc
%description help


%prep
%autosetup -n ucsmsdk-0.9.14

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ucsmsdk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.14-1
- Package Spec generated