%global _empty_manifest_terminate_build 0
Name:		python-flask-praetorian
Version:	1.4.0
Release:	1
Summary:	Strong, Simple, and Precise security for Flask APIs (using jwt)
License:	MIT
URL:		https://flask-praetorian.readthedocs.io/en/latest/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/15/27/c7579df433f6c0ec82ed3f6cb097b3b8ea9ca29d869bbfd0a9856af13509/flask-praetorian-1.4.0.tar.gz
BuildArch:	noarch

Requires:	python3-pyjwt
Requires:	python3-pendulum
Requires:	python3-passlib
Requires:	python3-flask-buzz
Requires:	python3-flask-mail
Requires:	python3-flask

%description


%package -n python3-flask-praetorian
Summary:	Strong, Simple, and Precise security for Flask APIs (using jwt)
Provides:	python-flask-praetorian
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-flask-praetorian


%package help
Summary:	Development documents and examples for flask-praetorian
Provides:	python3-flask-praetorian-doc
%description help


%prep
%autosetup -n flask-praetorian-1.4.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-flask-praetorian -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.0-1
- Package Spec generated