%global _empty_manifest_terminate_build 0
Name: python-lumibot
Version: 2.5.11
Release: 1
Summary: Backtesting and Trading Library, Made by Lumiwealth
License: MIT License
URL: https://github.com/Lumiwealth/lumibot
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/17/03/68f3fe298c287fbcd04dcaca44e041518fe2114f4b057504776b1942245f/lumibot-2.5.11.tar.gz
BuildArch: noarch
Requires: python3-pydantic
Requires: python3-alpaca-trade-api
Requires: python3-alpha-vantage
Requires: python3-ibapi
Requires: python3-yfinance
Requires: python3-matplotlib
Requires: python3-quandl
Requires: python3-pandas
Requires: python3-pandas-datareader
Requires: python3-pandas-market-calendars
Requires: python3-plotly
Requires: python3-flask-socketio
Requires: python3-flask-sqlalchemy
Requires: python3-flask-marshmallow
Requires: python3-marshmallow-sqlalchemy
Requires: python3-flask-security
Requires: python3-email-validator
Requires: python3-bcrypt
Requires: python3-pytest
Requires: python3-scipy
Requires: python3-quantstats
Requires: python3-ccxt
Requires: python3-termcolor
Requires: python3-jsonpickle
%description
Backtesting and trading for stocks, options, crypto, futures and more!
# Documentation
**Check out the documentation for the project here: **
# Community
If you want to learn more about Lumibot or Algorithmic Trading then you will love out communities! You can join us on our forum or Discord.
**To join/view our forum: **
**To join us on Discord: **
# Courses
If you need extra help building your algorithm, we have courses to help you out.
**For our Algorithmic Trading course: **
**For our Machine Learning for Trading course: **
**For our Options Trading course: **
# License
This library is covered by the MIT license for open sourced software which can be found here:
# Profiling and Optimization Tips to Improve Performance
## Profiling
We recommend using yappi to profile your code. You can install it with `pip install yappi`. You can then use it to profile your code like this:
```python
import yappi
yappi.start()
# Run your code here, eg. a backtest
MachineLearningLongShort.backtest(
PandasDataBacktesting,
backtesting_start,
backtesting_end,
pandas_data=pandas_data,
benchmark_asset="TQQQ",
)
# Stop the profiler
yappi.stop()
# Save the results
threads = yappi.get_thread_stats()
for thread in threads:
print(
"Function stats for (%s) (%d)" % (thread.name, thread.id)
) # it is the Thread.__class__.__name__
yappi.get_func_stats(ctx_id=thread.id).save(
f"profile_{thread.name}.out", type="pstat"
)
```
## Viewing the results
We recommend using snakeviz to view the results. You can install it with `pip install snakeviz`. You can then use it to view the results like this:
```bash
snakeviz profile_MachineLearningLongShort.out
```
%package -n python3-lumibot
Summary: Backtesting and Trading Library, Made by Lumiwealth
Provides: python-lumibot
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-lumibot
Backtesting and trading for stocks, options, crypto, futures and more!
# Documentation
**Check out the documentation for the project here: **
# Community
If you want to learn more about Lumibot or Algorithmic Trading then you will love out communities! You can join us on our forum or Discord.
**To join/view our forum: **
**To join us on Discord: **
# Courses
If you need extra help building your algorithm, we have courses to help you out.
**For our Algorithmic Trading course: **
**For our Machine Learning for Trading course: **
**For our Options Trading course: **
# License
This library is covered by the MIT license for open sourced software which can be found here:
# Profiling and Optimization Tips to Improve Performance
## Profiling
We recommend using yappi to profile your code. You can install it with `pip install yappi`. You can then use it to profile your code like this:
```python
import yappi
yappi.start()
# Run your code here, eg. a backtest
MachineLearningLongShort.backtest(
PandasDataBacktesting,
backtesting_start,
backtesting_end,
pandas_data=pandas_data,
benchmark_asset="TQQQ",
)
# Stop the profiler
yappi.stop()
# Save the results
threads = yappi.get_thread_stats()
for thread in threads:
print(
"Function stats for (%s) (%d)" % (thread.name, thread.id)
) # it is the Thread.__class__.__name__
yappi.get_func_stats(ctx_id=thread.id).save(
f"profile_{thread.name}.out", type="pstat"
)
```
## Viewing the results
We recommend using snakeviz to view the results. You can install it with `pip install snakeviz`. You can then use it to view the results like this:
```bash
snakeviz profile_MachineLearningLongShort.out
```
%package help
Summary: Development documents and examples for lumibot
Provides: python3-lumibot-doc
%description help
Backtesting and trading for stocks, options, crypto, futures and more!
# Documentation
**Check out the documentation for the project here: **
# Community
If you want to learn more about Lumibot or Algorithmic Trading then you will love out communities! You can join us on our forum or Discord.
**To join/view our forum: **
**To join us on Discord: **
# Courses
If you need extra help building your algorithm, we have courses to help you out.
**For our Algorithmic Trading course: **
**For our Machine Learning for Trading course: **
**For our Options Trading course: **
# License
This library is covered by the MIT license for open sourced software which can be found here:
# Profiling and Optimization Tips to Improve Performance
## Profiling
We recommend using yappi to profile your code. You can install it with `pip install yappi`. You can then use it to profile your code like this:
```python
import yappi
yappi.start()
# Run your code here, eg. a backtest
MachineLearningLongShort.backtest(
PandasDataBacktesting,
backtesting_start,
backtesting_end,
pandas_data=pandas_data,
benchmark_asset="TQQQ",
)
# Stop the profiler
yappi.stop()
# Save the results
threads = yappi.get_thread_stats()
for thread in threads:
print(
"Function stats for (%s) (%d)" % (thread.name, thread.id)
) # it is the Thread.__class__.__name__
yappi.get_func_stats(ctx_id=thread.id).save(
f"profile_{thread.name}.out", type="pstat"
)
```
## Viewing the results
We recommend using snakeviz to view the results. You can install it with `pip install snakeviz`. You can then use it to view the results like this:
```bash
snakeviz profile_MachineLearningLongShort.out
```
%prep
%autosetup -n lumibot-2.5.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-lumibot -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 2.5.11-1
- Package Spec generated